Intel RST/RSTe Drivers (latest: v20.1.0.1013/ v8.6.0.2003)

@Dagal
Thanks for having found and uploaded the new Intel RST driverpack v18.37.7.1013 WHQL.

@all
The start post has been updated by me today (04/28/2023).

1 Like

The start post has been updated again today (04/29/2023). Thanks to S-D for the source package.
Changelog:
new: 64bit Intel RST VMD driver v18.7.7.1013 WHQL dated 02/06/2023
new: Intel RST Drivers & Software Set v18.7.7.1013.1 dated 03/08/2023

Enjoy it!

1 Like

The start post has been updated again today (05/17/2023). Thanks to S-D for the source package.
Changelog:
new: Intel RSTe VROC+NVMe Drivers & Software Set v8.0.4.1009 dated 12/30/2022

Enjoy it!

Why has the version 15.2 been removed from the title post ? I needed to reinstall it today and couldn’t find the link, had to dig up an archive hard drive to find it. I need it because, on any version after 15.2 (so 15.5 and after, up to the latest versions that still support RST on pre Alder-lake), i have insanely high cpu usage when accessing RAID1 or RAID5 arrays, regardless of the cache settings in the intel utility. This will also limit the throughput of many-disk RAID5 arrays, here is a pair of screenshots demonstrating the difference:


@rajkosto

I don’t remember the reason for their removal.

Just for your information:
The Intel RST drivers v15.2.16.1060 dated 03/30/2017 have been replaced already in 2017 by the v15.5.2.1054 ones dated 04/24/2017, because they were newer and according to my own test results better for systems with an Intel 100/200 Series chipsets and a RAID array.
Please have a look into the start post of >this< thread.

It was not a good idea to compare drivers, which belong to completely different RST platforms (v15.2.16.1060 vs. v18.37.6.1010). It would have been better to compare the RST RAID drivers v15.2.16.1060 with the v15.5.2.1054.
Please let me know your results.

Yes, as i said in that post, and here Intel RST/RSTe Drivers (latest: v19.5.5.1052/ v8.0.4.1006) - #2394 by rajkosto

anything AFTER 15.2, starting with 15.5 (and ive tried a couple of versions from each of v16, v17, v18, etc), which has Optane support, has this high cpu usage (and low throughput because of CPU limitations on many-disk RAID5) bug. and it still hasnt been fixed in in the latest v18 we got in 2023.

And this is on a Gigabyte Aorus Pro Z390 board with latest bios, so the firmware RST is way newer than v15 anyway, that has no effect on this bug, v15.2.16 is still the last version that has normal CPU usage and performance on RAID1/RAID5 arrays.

It’s also not something with my configuration/OS, because i’ve had it on win8.1, win10, and i just tried it with a clean install of win11 with latest driver 18.37.7 and it still has the high cpu usage.

Here is a mirror of the v15.2.16 you had previously in the main post, the last version for me that has normal CPU usage and performance on RAID1 and RAID5 arrays.
full set: 12.5 MB file on MEGA
64bit driver only: 403.3 KB file on MEGA

@rajkosto
Thank you very much for your additional explanations.

You were and are absolutely right - I must have removed the v15.2 RST drivers and the related Software Set during the past 2 years, but I didn’t remember that. I am sorry for the confusion - my bad.
Although I am not 100% sure about the reason, I suspect, that the start post of this thread had reached the maximum possible number of characters and the consequence was, that I had to remove an old driver for being able to add a new one to the start post.

Fortunately such character limit for a certain post doesn’t exist within our new home at level1techs. So I was able to re-add the related drivers today.
Thanks again for your input!

here is direct comparison of 15.2.16 System process CPU usage compared with 15.5.2 (version released right after 15.2.16, first one to include Optane support), please ignore additional 10% total cpu usage added in comparison to previous tests by running Process Explorer:


i didnt even have the RST software installed this time, i just compared the 2 drivers standalone (its the same if i do install the RST software anyway, its just for management)

the in-box win10 21H2 driver iaStorAVC.sys 15.44 has the same high cpu usage as anything after 15.2.16:

my firmware uefi RST module version is “Intel(R) RST 17.7.0.4404 RAID Driver”

Fernando i need your help.

After reading this thread (and many others on this topic) i follow your advice and installed the 64bit Intel RST AHCI & RAID driver v11.2.0.1006 WHQL for my ICHR8 SATA controller that is running in RAID mode.

This driver replaced the default one that MS offers with windows 8.1 x64, now i would like to install the RST console software in order to be able to monitor my RAID status (verifying/ rebuilding etc) over windows but the driver package link that u offer does NOT include the console software.

Is there any link you can provide? Do i need to make sure that the console version matched the driver version?

Thanx in advance.

@Kotik Welcome to the Win-RAID Forum!
The link to the Intel RST AHCI/RAID Drivers & Software Set v11.2.0.1006 WHQ is available within the start post of this thread.
Did you run the Setup.exe of that Set? If yes, you should get access to the Intel RST RAID Console Software.
Enjoy it!
Dieter (alias Fernando)

Thank you for the quick reply Fernando,

There is no Setup.exe present in the .rar file. The linked .rar file contains only the driver files but it seems to be missing the console file.

See attached screenshot.

Never mind @Fernando , i just realized there are 3 files attached and the last one has the console files.

Next question is how to proceed now that i already have the drivers installed? Do i install setup.exe ontop of them?

Yes! Since the related Intel RAID driver is already installed and running, only the Console Software will be additionally installed.

Thank you very much for your time and work.

Intel Rapid Storage Technology (RST-VMD) Version 19.5.7.1058 WHQL

1 Like

Whe first post of this thread has been updated by me today (09.09.2023).

The first post has been updated by me today (11/20/2023).
Enjoy the new Intel RSTe drivers!

1 Like

Intel VMD Drivers. Drivers Only v20.0.0.1035 WHQL

Intel VROC Drivers. Drivers Only:
NVMe : 8.2.0.2004 WHQL

SATA : 8.2.0.2004 WHQL

1 Like

The first post has been updated by me today (12/16/2023).
Enjoy the new Intel RST and RSTe drivers!

2 Likes

Due to the fact, that I found today a new 64bit Intel RST VMD driver v20.0.0.1037 WHQL, I have updated today (12/18/2023) the start post again.

2 Likes