Intel UHD Graphics 630 Video Driver for Win7 x64

Hello canonkong!
PLEASE, i’m looking for those drivers but your link has expired.

Can you help me?

Do you find solution for UHD610? I have a ASROCK H310M-HDV with g5400 cpu. After some test, no works

I am still trying to modify it. UHD610 still can not work well. Modify Graphics driver is very difficult. Not like B360/Z390 USB driver, it took me two days to finish it.

Holy smokes! Why isn’t this thread more popular? This is amazing! 8700k integrated graphics fully working on windows 7!

For uhd 630, canonkong has made a working driver for us, get it here: PASSWORD:xiaofengmod. Confirmed to work on i5-8300h. Many many thanks my friend!

Thanks to Canonkong for the UHD630 driver.

I have been using / testing / benchmarking it on my Asus Z390 WS Pro motherboard with a 9900K CPU, and have not experienced a single issue.

So a big thank you.

This + wufuc + the USB2.0 / USB3.0 / USB3.1 Z390 chipset (A36D device) driver released by reducer, dricks and canonkong in another thread of this site, allows full usage of W7 on the Z390/9900K, which makes for an incredibly fast and stable system, without the threat of the uncontrollable W10 update train.

Win10 is horrible for the role I need it for in this unit as i cannot have a computer restarting at random. It’s possible for it to lose a clients data …

Once I have more time I intend to write up a very easy to follow set of instructions.

One thing though - the driver for UHD 630 has installed (for the IG GPU of the i7-8700k) …
but when it installs and replaces the Generic PnP driver … I get no video.

Anyone have any ideas as to what’s going on with this? Are there supplemental devices that need to be installed in addition to the GPU for it to work ?

The attached photo is from Win 10 … maybe I need these software components within Win 7 also ?


SS 2019-09-12 at 10.42.56 AM.png

@TrumanHW :

1. Have you tried both the drivers ? Both are good enough for your device.

(i). By Sir CoolEAP

(ii). By Sir canonkong ( PASSWORD : xiaofengmod )

2. Share your System information from the problematic Win 7 installation :

(i) Login as Admin.
(ii) Download & place this file on the desktop : SysInfo.bat : Google Drive Link
(iii) Make a new desktop folder with the name sysinfo
(iv) Run the SysInfo.bat file as Admin & let it complete.
(v) Now go into the sysinfo folder on the desktop & share the file.

Thanks & Regards. …

i7-8700k (Coffee Lake S released in 2017) has 0x3E92 as device id for the UHD 630, also has 24 execution units, so you should try (i). By Sir CoolEAP. The canonkong’s driver is for UHD 630 from 0x3E9B compatible with i5-8300H (Coffee Lake H released in 2018), which has 23 execution units. That’s why it doesn’t work I think. I have i7-8550u (Kaby Lake R released in 2017) with UHD 620 0x5917 24 execution units and the I also tried the canonkong’s driver and it works, but I have no hardware acceleration.

This is amazing, @canonkong I can’t thank you enough. It has working sleep mode, control panel, brightness, etc, on a laptop. Because of this I can use Windows 7 on my Dell G5 15 5587 without issues. Thanks again.

It’s not CoolEAP’s mod. It’s mine mod, signed by Mex4x -
I came up with this modification in November, 23 2018 with nanoflooder help -

One bug with the @canonkong driver - the win7 resolution control panel is broken - you can’t select anything when plugged in, and it locks up explorer when on battery. System for reference is a Dell G5 15 5587 with the 8750h and 1050ti.

It’s not too bad tho, I can still use the intel control panel.

B360 and i5 8500. Win7 x64.
SMXDIY_Win64_15.45.27.5068_Beta_4.0_signature.7z by canonkong. The driver is not installed. (Error: This system does not meet the minimum requirements for installing software.)

After further investigation this seems to be only an issue in very specific cases. Usually the properties work just fine. Excellent work, this is basically turn-key.

Try to use the other driver. This in particular is more laptop-geared than desktop (laptop cpus use newer graphics chips)

I’m facing a similar compatibility issue in Windows 8.1 with the i2c driver for i7-9750h, which in theory should be the same as the 8750h (8th generation).

There are drivers from Intel for i2c with Windows 8.1, but they aren’t compatible with the “A369” device ID that’s part of HM370 (8th generation).

Is this another case where perhaps we can force-install an older Win 10 driver? These are some details from a 5.x linux kernel where it’s working (why Linux? because I thought perhaps I could look at the open source Linux driver and then re-implement it as a windows driver with WDK for Windows 8.1)

E: DRIVER=intel-lpss
E: PCI_ID=8086:A369
E: ID_PCI_CLASS_FROM_DATABASE=Serial bus controller
E: ID_MODEL_FROM_DATABASE=Cannon Lake PCH Serial IO I2C Controller

Why do I care about the i2c (A369) driver? Well, because the laptop touchpad uses it, so the laptop requires an external mouse without this driver!!!

I’ve made new mod for with full support UHD 610 & 630. I think now it supports all graphics for Coffee Lake core, incl. Iris Plus.
Base driver -
Modified files with the digital sign (Thanks to Mex4x from -…PBv8ha_M-U64WH3
Warning: support for Kaby Lake graphics is dropped by this mod!

thank you!
I tested it, the driver is usable, but it doesn’t seem to be successfully signed.
And, is there a plan to modify the 32-bit driver?

Only sys-file has the digital sign, but not the entire driver package. So for Win8.1 testing mode is required for installing. But you can disable testing mode after driver installing.

I’m not interested in that.