intel X79 unknown chinese motherboard ME question

Working my way trough unlocking the bclk slider, I wanted to change the FCIM/BTM settings to the recommended overclock settings.
However, I noticed that the settings in the bios of this board are considerably different than the standard intel settings.

So now, I’m a bit worried.
Here’s a screenshot of the settings in my firmware extracted from the bios:

Can it harm, to take the default values of the default image and change the values to the overclock safe options?

these are the intel defaults:

seems like something went wrong.
I’ll be back on this.

Are you trying to update the ME and apply the settings that your current one has? I’m not sure I understand the question.

I forgot about the update fuction.
So it’s updated now.

However, I’m trying to unlock the bclk slider.
So i wanted to change the values into the recommended intel overclock voltages. But the default values from my icc profile seem to be totally different then the default me values.

I don’t know what these values do exactly, you would need to check the “BringUp Guide” as it’s called for that. It makes sense for the values to differ depending on OEM adjustments. It may help if you check some other X79 boards with overclocking enabled and compare accordingly. The stock firmware does not necessarily have overclocking options set by default.

damn it, I received a new bios for the motherboard (to solve a fan speed issue). I flashed it with the -f -bios option and now my me appears to be dead.

I can do a full spi dump.

meinfo gives me this error:

Error 9470: Fail to load driver (PCI access for Windows)
Tool needs to run with an administrator privilege account

I dumped the me region from the bios itself. wich is an older version than the latest 8 version.
I tried to flash that one again with :
fptw64.exe -rewrite -me -f ME_Region.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2014, Intel Corporation. All rights reserved.

Error 284: Fail to load driver (PCI access for Windows).
Tool needs to run with an administrator priviledge account.

a -greset doesn't to a thing either.
C:\Users\jo\Downloads\Intel ME System Tools v8 r1\Flash Programming Tool\Windows64>fptw64.exe -greset
Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2014, Intel Corporation. All rights reserved.
Platform: Intel(R) Patsburg Chipset - Reserved DID 0x1D41
Reading HSFSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
EN25F64 ID:0x1C3117 Size: 8192KB (65536Kb)
Could not set the GlobalReset bit
Initializing HECI Client...
FW Status Register1: 0x4E000185
FW Status Register2: 0x10660120
Current ME State ( 0x1 ) : Bring Up
The ME is not is a functional state. Cannot execute ME Reboot.
The ME could not be reset from the program. The system requires a manual Power-off
Error 217: Setting Global Reset Failed

So I'm a bit stuck :(

any ideas?

Do you have a ME driver installed? Try the DOS versions of the tools and -greset again there. Attach the full SPI dump. The fpt -f -bios option should not have caused anything at the ME region.

plutomaniac, the dos version gave the same result.
The me is not showing in my device manager either.

I have reflashed the original me from my bios but that doesn’t change a thing either.

Here is my current full spi dump: (3.33 MB)

don’t know if its usefull but this was my previous bios: (3.31 MB)

I just followed the cleanup guide and produced a ME region for you to reflash. Use “fpt -f me_fix.bin -me” followed by “fpt -greset” command.

me_fix.rar (973 KB)

thnx @plutomaniac. flashing went ok.
The -greset doenst work :frowning:

Still the same message:

Could not set the globalReset bit
Current me state (0x1): bring up
The me is not in a functional state. cannot execute me reboot.
The me could not be reset from the program. The system requires a manual power off.

The poweroff didn’t help either :frowning:

anymore ideas?


I flashed back my old bios with the -bios option and now the me is functional again :s

In the new bios, they fixed the automatic fanspeedcontrol in bios but it seem to screw up the me :s

any ideas?

No, the problem is entirely BIOS related. You’ll have to ask them about it. Try restoring default settings and check if they have enabled any option such as “ME Reflash”.

Well, I’ve opened the bios with amibcp. There is an me page under chipset. but in the bios it’s hidden. It’s set to visible in amibcp but I guess they use a bitmask to hide it. The same applies for the 1-core till 10-core turbo option. A lot of options are masked. Anyone here knows how to unhide them?

I’ve read something about extracting the setup ifr en looking for the options and then searching for the bitmasks with a hex editor. But I’m afraid that it goes beyond my knowledge.

The BIOS they have given you looks very different from your original, it’s not just a simple mod or something. Did you contact the OEM or something? Generally, your problem is at the BIOS and not ME. So I believe that you should contact whoever provided that modified one ask them if they can fix that from their end.

I did. But it’s a chinese company.
Don’t even know if the lady understands what I mean.

I requested them with a new bios because the autofan control (pwm) with preset temps and fanspeeds didn’t work. It was 100% all the time.

The new bios was the so called solution their engineer had written…

I asked for a changelog but she told me that the only thing he changed was the fancontroll issue.

With the new bios, the fan turns slower but the preset temps and according fan speeds still don’t work. So I don’t have high expectations anymore.

The x79 board was €150 and that pulled me over the line to buy and try it.

I had a e5-2690 xeon for cheap out of an obsolete blade server.

@plutomanica: how did you compare them?


I just got a reply from the manufacturer:

The me is disabled from within the bios, because some clients can’t find the ME driver.
They will say our motherboard has a problem, so our engineer disablet it.

now they ask if I use the me.
Don’t know what to answer realy :s

What? Completely ridiculous answer. Can’t find the driver, ha-ha. Lol. Tell them that you use it in that case. Unfortunately or not, the ME is responsible for other system components like system clocks, overclocking, thermal monitoring, silicon workaround (solve cpu silicon issues which normally require a new stepping), fan control and more. So the engineer should not have it disabled. No need to explain it to them, just tell them that you use it and you’d appreciate a BIOS version which works with it. Long stretch but if you can get them to also update it to the latest version (so that we can grab it for other people, we are stuck at 8.1.65) then that would be super great. They seem to cooperate so who knows, we might get lucky. But yes, the first priority for your system it to at least have a BIOS that works with it.


I noticed something weird.
If I only dump my me (fptw64.exe -d me.bin -ME) a lot of values (in fitc), are different then when I open a full spi dump in fitc.

Is this normal behaviour?
Because now, i’m a bit confused about what my real me settings are.

both files are in my drive:…QmJ5VUM4VWJYYXM

me.bin and full.bin

for instance: the icc data - icc profile 0 - Fcim/BTM specific ICC registers are totaly different.
I’m a bit puzzled now.

That’s due to something you did recently. You flashed some SPI or ME region which has completely different settings. The previous files you provided (dump, backup, my cleanup fix) as well as the last ones (full = dump, x7909_PCI_0929_bios = backup) have the exact same settings. The me.bin dump is completely different so it’s something you flashed recently. Restore back to the previous ME regions we were working with.


I think you might have misunderstand me.
Both the me.bin and the full.bin are dumps I took now from my running system.
first I did the full dump and after that I dumped only the me.
but fitc is showing different settings. the full spi is supposed to have the exact same me settings like the me dump right?