Intel z97 RAID 0 SSD - SATA array incomaptible after a reboot.

Hi everyone. I’ve just bought another identical SSD (Crucial MX500) for my desktop PC so I have now 2 of them now and I wanted to make a RAID 0 array using my motherboards (ASUS Sabertooth Mark2) controller. I have an updated BIOS using UBUU (the raid drivers are 14.8 series). Everything configures just fine but when I entered windows I have a message from Intel RST console that the array is “incompatible” despite it was made on the same PC. I’ve noticed that if I go to BIOS and remake the array its ok on first boot, but then when I reboot, it shows the same message again. I did secure erase both drives and the same thing happens. Any help would be appreciated.

EDIT: I forgot to mention, I’m using Windows 10 1909 x64 with the latest updates. The array works well tho, I can read and write data from it without any problems. That’s just weird.
Also, as a side question, what is TRIM_6 raid orom version?

EDIT2: I 've made another BIOS with 13.2 EFI driver but the same issue still occurs. Another weird fact is that I cannot install 13.2 RST driver onto this platform as it gives me an error during install, the 14.8 package makes no problem …
EDIT3: I’ve settled with 14.8 EFI driver and just uninstalled RST software for now but anyway, this is a weird issue after all. I’ve added a screenshot of what I mean, it is in Polish but maybe it will help.

@izajasz :
To be able to help you, I need some additional information:
1. Did you install the OS in UEFI mode?
2. Is the system drive C: and the boot sector within or outside the RAID array?
3. With which Intel RAID BIOS module version did you create the RAID array?
4. Does the currently running Intel RST RAID driver version match the Intel RAID BIOS module version? Please post the exact version numbers.

@Fernando Thank for the fast answer. Here are the details You asked:

1. Yes, UEFI mode with CSM disabled.
2. I use Transcend M.2 Nvme 256GB drive as a boot drive so this is out of the equation.
3. The first trial was on EFI driver and Windows driver version with software “console”. The second trial was on EFI driver v but I could not install the driver with software “console” v13.2 so I installed 14.8 instead. The same error popped up. At each try, I deleted the array and recreated it using the module I was testing at the moment. Weird thing is that at the first boot after creation it worked flawlessly but when I reboot again it starts to show the error posted above.
4. My current setup is EFI driver + driver without software “console”. I just made a crystal disk mark and results seem fine. I never stumbled upon such error so it’s weird for me. The array seems to work fine. I am restoring my files to it and it works flawlessly. Altho the console is a nice addition I am ready to settle with the config I’ve made now.

@izajasz :
Your problem may have been caused by trying to install the Intel RST Software v13.2. ontop of the already installed v14.8. one.
That is why I generally recommend
a) to create the Intel RAID array by using the Intel RST RAID Utility (from within the BIOS in UEFI mode resp. via CTRL+I in LEGACY mode) and
b) to uninstall the Intel RST Software from within the Control Panel and to do a reboot thereafter before running the SetupRST.exe of any Drivers & Software Set.
The usage of the Intel RST Console is nice for users, who want to monitor the health of their RAID array, but will reduce the performance of an Intel RAID0 array if permanently running in the background. The only real benefit of the Console Software is the option to enable the "Write-back" feature, but this setting once having done it will be still valid after having uninstalled the Intel RST Software.

@Fernando Nice, I will install the software, enable write back and uninstall it after. Thanks for the feedback. But just for Your information, I did reinstall it the way You described, I even did a clean of temp and cache and other “temp” files using BleachBit utility before I tried to install 13.2 software. I even tried to install Your modified driver and software (v15) but the software didn’t want to install, but only to assure You, I did try to install the RST software using the “clean” method.

EDIT: So, I did just like Fernando said. I’ve installed the 14.8 software, enabled Intel write back instead of Windows one, then rebooted, uninstalled the software and viola! From what I’ve understood, the intel write-back cache option remained enabled without the RST software. This is the best solution for me, as what mattered to me is that one option. I do not need the software. Yet again, thank You for the feedback! I appreciate it.