Invalid UUID, serial number and product name on Lenovo 330S-15ARR after flashing

Hello. My Lenovo 330s-15arr laptop stopped turning on (black screen). After flashing using a clean BIOS, the laptop powers up, but the UUID, serial number and product name are invalid in BIOS. There is a merged corrupted bios and a new worker. Please help with recovering UUID, serial number and product name.
Sorry for my English

I uploaded dumps to the file hosting service, but so far I can not publish

I need to write 3 messages before posting a link.

My dumps
Can this be fixed?

@VasX - Yes, I can help you fix this. Do you have image of BIOS main page before you broke the system?

Unfortunately, I did not have a BIOS main page image before I broke the system. Photographed how she looks now, if I understand you correctly. I only have 2 dumps before and after.


Sorry for quality

Try this program ThinkPad Hardware Maintenant Diskette(HMD) 1.89

i7tm37us.rar (1.33 MB)

How to create and use ThinkPad Maintenance Diskette USB Media version 1.89.doc (1.63 MB)

@VasX - If you cannot use above tools, I can fix, I have other user dump and their info, to find proper location and layout of UUID etc, so I can do this for you directly
But, please upload your linked files above to another host, that one is blocked by malwarebytes - Good ones for me are or

Also, I’m not sure what you mean by ““Merged”” corrupted BIOS"?? Please upload for me the originally dumped corrupted BIOS, without you editing it at all.
And then also include whatever you programmed in that you are using now

I think the BIOS is damaged due to the fact that the laptop does not turn on with it. I tried ThinkPad Hardware Maintenanсe Diskette 1.89, but the laptop writes “non-system disk”, then I was advised to take ThinkPad Hardware Maintenanсe Diskette version 2.02 for UEFI, and nothing worked. I am attaching a photo. Maybe I’m doing something wrong. Uploaded files
I will be grateful for any help. If you send me dumps of other users, that’s fine too, only I don’t know where to look for information there.


System probably should be bootable before you use the software method. Looks like it’s not compatible, so we’ll fix directly.
You never mention system was bricked? Well, I mean you said you fixed it and system was running now.
What do you mean >> “BIOS is damaged due to the fact that the laptop does not turn on with it” << Is it bricked and not working, or is system working now as you said, just invalid system info?

I would not send you other dumps, I would fix your BIOS and system info and send you your own BIOS back.
Please do as I requested at #5, and answer my question there too.

My BIOS was corrupted (I think so, because the laptop did not turn on) and it was programmed with another dump, the laptop works with it, but there is no information about the laptop in the BIOS, everything is INVALID and I posted both dumps to the file sharing

Yes, I thought you fixed it with another BIOS, so it’s working now.

what you mean by ““Merged”” corrupted BIOS"?? What did you merge, with what? I want the not merged, original corrupted BIOS dump.
Please upload for me the originally dumped corrupted BIOS, without you editing it at all + Whatever BIOS you programmed in that is now running on the system.

Yes, thanks, I uploaded my corrupted dump to file sharing

BIOS write protection may need to be removed first.


Thank you, we tried it, but nothing happens when you press the ESC, perhaps there is another way to unlock it? In any case, it is flashed

That could be the software doesn’t support AMD CPU.

By the way, you can try software "DMI EDITOR" ,it only need to fill in the Type and Model ,System Serial Number, in addition, UUID can be generated automatically.

Thanks. I only know the model. It is written on the motherboard. I have no box, there are no inscriptions on the case. Therefore, the option to restore the serial can only be from the old dump.

Emm,I guess you can scan the QR code to get further information about the machine ,and the MAC of the network card should be on a sticker on the motherboard.


Hello, i have the same problem with Lenovo 330S-15ARR, invalid UUID, serial number and product name in bios, the laptops works, but i want to put information back in bios! Can someone help me?