Issue installing windows 10 on NVME drives in raid, irql_not_less_or_equal pointing to iaStorAVC.sys

Hello so i have tried almost everything to get windows 10 installed on the nvme drives in raid. if i turn off raid i can install windows and see both drives and install windows on either. If i turn it on i can setup a raid set and see raid volume but once i start windows install i get one of two outcomes it BSOD with IRQL error or goes through to install but doesnt see drive even if i load drivers. I have injected drivers directly into image. I have come to the conclusion the drives are not compatible with my board which is a ASUS ROG Maximus X hero WIFI with latest bios. The drives are Adata XPG SX6000 PROS. The board is not on the compatibility list of motherboards on the Adata site. I have tried the drives on 3 different asus boards same outcome. Is there anything i can do to try and get the raid detected by windows and make the drives compatible. Thanks again for any help

@Tekytech :
Welcome to the Win-RAID Forum and thanks for your report!

I suspect, that your issue has been caused by the fact, that neither the Win10 in-box NVMe driver nor the Win10 in-box Intel RAID driver do support your Intel RAID0 array consisting of 2 NVMe SSDs.
The solution is either to load the desired Intel RST RAID driver version (should belong to the v16 or v17 platform) during the Win10 installation (when you get the option to load a driver) or to integrate it into both WIM images (install.wim and boot.wim) of the desired Win10 Edition by using a tool like NTLite.
Attention: The related INF file is named iaStorAC.inf and the related Controller name is “Intel(R) NVMe Controller”. Don’t load or integrate any other INF file or Controller!

Good luck!
Dieter (alias Fernando)

Firstly thank you for your response this has been driving me crazy for the past week, Yea when i load the driver during install i dont get the Intel nvme controller its named intel raid something so maybe your correct the driver being loaded is incorrect. If this doesnt work what do you suggest i try then?

@Tekytech :
If the Win10 Setup routine shouldn’t be able to load the correct Intel RST NVMe driver resp. its NVMe Controller, I recommend to choose the second option (integration into the boot.wim and install.wim) and to boot off that customized Win10 image in UEFI mode.

the image is uefi im injecting the drivers now

One driver resp. its INF file is enough!

ok i stripped all intel drivers from the storage controller section of the and and installed the iastorac.inf driver package in both. booted windows installed and not it spins gets past where it would crash before and then i get to the page to select drive to install too and nothing is listed i load drivers and still not drive. this is with version 17 im going to try version 16 and see what happens