Issue with AMIBCP saves not posting

Hey everyone, I have an atom z8350 board that I was botting off a windows to go external drive and wanted to enable my USB 3 support and changed the XHCI settings…which disabled my USBs (well partially - keyboards and mouse don’t work, but a USB lights up). I am not stuck with a bios that stays on the bios post splash page telling me to hit “esc” or “del” to enter bios (which I can’t as no USB is working).

I have backed up my bios, but any attempt to alter it in AMIBCP results in not posting at all. Reflashing to the original backup brings back the bios splash page, but the problem remains.

How can I fix this issue and change the XHCI settings back and modify the bios and actually get it to post? Any and all help would be incredibly appreciated. I’ve spent days now trying to fix this.

I’ve attached my bios. (3.0 MB)

Most modern AMI V Core bios wont reflect the changes with AMIBCP tool, like it was in AMI IV, as it needs other modifications in AMIsetup.
You need to change variables/strings values with IFRextract tool/HEX edit it manually.
Dont have time to search links for you, search it in the forum for related mods.

1 Like

Appreciate the response. I’ve been searching for days now, and haven’t had luck. I’m not very versed in this. The board is not a board I can contact anyone for a fresh bios, so I’m stuck figuring this all out. I have a mini programmer and have tried a ton of things I’ve found online without success.

Okay, so I’ve made progress. I replaced everything between StdDefaults and GUID in both sections with FFs (that was my issue before, I had replaced them with FFs but didn’t realize there are two sections containing that sections), and now on boot my keyboard and mouse light up and are active - but now I just get a black screen, no bios option. Ctr+Alt+Del reset it, but just bring me back to a black screen.

Withing that section is there a particular section that would be responsible for the USB issues, that I can change to FFs but leave the rest intact?

Also - I have a StdDefaults and MfgDefaults?

Please post the edited bios and some information about this board and a link to the manufacturers site / to a stock bios.

So the board is from a laser cutter and the manufacturer refuses to send the bios as it’s “proprietary”. But I found the manufacturer who is Highton and they weren’t able to provide a bios:

This is the board: Highton Intel Board Z8350 Win10 2+32 4+32 4+64 Main Board With Wifi 3*usb2.0,1*usb3.0 Rj45 Hdml Board - Buy Android Phone Motherboard,Mobile Phone Motherboard,Mobile Phone Motherboard Parts Product on

Bios is attached above in my first post. Appreciate the help.

If it has winbond 25XX on the main board you can reset with this:
-Tricks10000: How to reset UFEI CMOS of the windows tablet which do not come with CMOS battery.

Unfortunately I’ve tried that, and it does nothing. On my winbond 25Q64FW it’s supposed to be pin 7 & 4. But I’ve tried it multiple times and it just doesn’t do anything.

I’ve seen the bios in post #1

I’d like to have a look into the bios you modified.

Here are the three bios versions - Modified based off the thread I initially commented on, modified by AMIBCP (where I reversed the changes I made which resulted in loss of USB), and the original USBless version I extracted to begin with.
Bios (9.1 MB)

Thanks. You were a little imprecise when FFing, you cut some bytes of the Mfgdefaults in 1. NVRAM volume and same amount of the last Stddefaults in 2. NVRAM having deleted Mfgdefaults. Unsure what bios might load som standard but that would cut the GUID for index 0 making possibly Mfgdefaults in NVRAM1 and StdDefaults in NVRAM2 unreadable?
In addition you didn’t empty the GUID store of the NVRAMs, it’s just the last line that’s still needed, but that’s normally corrected by the system when writing new guids.

Try: (2.8 MB)

Unfortunately it has the same result. USB is on, but I get a blank backlit screen. Hitting ctr+alt+del resets but nothing on screen.

Next thing checking was ME, and it doesn’t open in FIT- TXE can’t be decomposed.

So can’t read the TXE configuration but on the other hand there’s not too much / almost nothing to configure directly in TXE. Checked quite a lot of other Atom bios and all 8MByte firmwares came with the same SOC straps, so maybe replacing the TXE region does help?

Try this one: (2.8 MB)

That worked!!! I seriously can’t thank you enough :pray:t3: Thank you for your time and help. I’m new to this forum but it’s clear you’re an integral part.

1 Like

A little difficult to assume that this settings change should brick the TXE region, but I know too little about these Atom / TXE machines. May be reproducable, may be a coincidence.

Thanks for the feedback :+1: :smiley: