Issues with sata ahci drivers with Skylake intel i5-6200u @ 2.30ghz (Windows XP)

Hi, I’ve been having issues with none of the drivers working with my Skylake laptop, resulting in the 7b error bsod. I’m trying to install windows xp.

Windows XP and older do not provide AHCI support out of the box.But if you check out the relevant topics,you will see that it’s not an issue
you need to add the drivers into your xp installation image beforehand

there is another way but its somewhat tricky

check under “Start => Settings => Control Panel => System => System Restore”, that the option Turn off system Restore on all drives is not active, and that the drive where your Windows resides is being monitored. This will allow to undo the changes by pressing F8 when Windows reboots, if anything goes wrong.
If you are able to start up Windows and don’t have AHCI enabled you probably have in your BIOS the IDE-mode enabled, right? If not, enable it and start up Windows as usual.
Now start by downloading the drivers from the Intel homepage - they’re called Intel Matrix Storage Manager and can be found here.
Now that you have the drivers, e.g. in “C:\temp”, create in there a new directory, e.g. “C:\temp\unpacked”.
Open up a MSDOS-shell and unpack the drivers into the new directory by using the “-A -P” flags, so in my case it would be…
iata82_enu.exe -A -PC:\temp\unpacked
Where you unpacked the files you should now see that there are files called “IaStor.sys”, “iastor.inf” and “iaAHCI.inf”.
Now, this probably is not needed and it won’t do anything at all, but as I did it (while I was still experimenting) and everything is now working, you should do it as well - you never know: rightclick on “iaAHCI.inf” and choose “Install”. Do the same with the “iastor.inf”-file. Nothing should happen - the system should act as if nothing has happened.
Now the real fun starts: go to “Start => Settings => Control Panel => System => Hardware => Device Manager”, search in the list for “IDE ATA/ATAPI controllers” and in there you should see a couple of entries including your IDE controllers - something like “Intel ICH10 family…serial ATA controller”. It might be that you see two such entries.
Select one of the “Intel ICH10 family…serial ATA controller”-entries, click with the right-mouse button and select “Update driver”.
Answer “No, not this time”, then “Install from a list or specific location (Advanced)”, then “Don’t search. I will choose the driver to install.”, then “Have a disk”.
A new window should appear asking you where the drivers are. Click on “Browse” and select the directory where the “IaStor.sys” & Co. were unpacked.
You should now see a list (or at least 1 entry) of different AHCI-ICH-controllers including the one you have - if not, deselect the checkbox which makes the system list only the compatible drivers.
Search for your ICH-controller. Have a look at the manual of your motherboard if you’re not sure which one it is.
Once you found & highlighted your AHCI-controller (“Intel(R) ICH10R SATA AHCI Controller” in my case), click on “Next”. At this stage Windows a message box will pop up showing a warning about not being able to verify the compatibility of those drivers. Just smile and continue the installation.
Now the system will install the drivers and it might take a looong time. Have a beer in the meanwhile as in my case I had to wait for about 20 minutes.
Once the driver has been installed, go back the the device manager, select (if you have it) the second “Intel ICH10 family…serial ATA controller”-entry and do again exactly the same. In my case the installation of the driver finished this time immediately.
After the drivers have been installed, reboot the machine, go into your BIOS, change the settings for your HDD-controller from “IDE” to “AHCI” and start up Windows again.
If your Windows XP manages to boot then it means you did everything right - if the installation of the AHCI-drivers wouldn’t have been successful your PC would now hang or reboot continously. If this happens go back to your BIOS, change AHCI back to IDE and boot Windows. If Windows still doesn’t want to wake up, keep the key “F8” pressed at the very beginning when the OS boots to bring up a menu and choose the “Last good known configuration” to undo the changes described above.
Not finished yet: once Windows is up you should see in the taskbar that something is being installed - you might get the bubbles saying that some new HDDs have been found. Additionally if you look in the Device Manager at the “IDE ATA/ATAPI controllers” you should see that all you have listed in there is just a “PCI device”. Again, be patient and have one more beer.
Again after ~10 to ~20 minutes Windows should tell you that it found new hardware, the AHCI-controller. Still wait until Windows asks you if you want to restart the PC.
Accept to restart it and after the reboot everthing should be ready. Under “IDE ATA/ATAPI controllers” you should now see your AHCI controller ready.

Thank you for the reply. I was able to install windows xp integral edition instead, So I have windows xp installed. the issues that I’m having now are with intel hd graphics and with the nvidia gtx 950m drivers. I’m trying to force windows xp to use the gtx 950m but it isn’t working. I installed a an nvidia gtx 950m win xp compatible driver, but it still didn’t do the trick. It has a problem starting up