Issues with Xiaomi Mi Pad 2: "ME fw update failed, please try again!" failure on boot

Hello everyone!

I’m new here and I apologize in advance if I’ve created this thread in a wrong forum section.

The issue I have with my Xiaomi tablet is that during the bootstrap of the system I see following message “ME fw update failed, please try again!”. Some sensors are missing within system: accelerometer, gyroscope, ambient light sensor, proximity sensor. Without these sensor user experience of the device is a headache.

I believe that this is related to ‘Intel Management Engine Interface’ or ‘Intel Trusted Execution Engine Interface’ broken firmware. I’ve read this forum sections and tried to find out what is TEX version or ME in my tab, but tools I tried don’t work in Windows 10 installed on the tablet.
In device manager I see that ‘Intel Trusted Execution Engine Interface’ marked as missing driver device. It wasn’t possible to install any TEX driver via .inf files on that device.

I’ve lost the track on how to troubleshoot and this forum is my last hope. I bought this tablet as used one and I can’t just bring it back to the seller and ask for cashback. Vendor’s support representatives are ignorant and careless - they just told me to flash MIUI 8 developer release (sic!).
Other communities and forums related to this device (e.g. , do not help much, cause issue I have is quite rare.

Here is device configuration:

get-wmiobject win32_bios

SMBIOSBIOSVersion : MIPad-P4.X64.0043.R03.1603071414
Manufacturer : Byosoft Corporation
Name : MIPad-P4.X64.0043.R03.1603071414
SerialNumber : A3P44EAD64A7
Version : INTEL - 3

OS Name Microsoft Windows 10 Home
Version 10.0.10586 Build 10586
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name MIPAD2
System Manufacturer Xiaomi Inc
System Model Mipad2
System Type x64-based PC
System SKU 0001
Processor Intel(R) Atom™ x5-Z8500 CPU @ 1.44GHz, 1441 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date Byosoft Corporation MIPad-P4.X64.0043.R03.1603071414, 3/7/2016
SMBIOS Version 3.0
Embedded Controller Version 255.255
BaseBoard Manufacturer Xiaomi Inc
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.10586.0"
User Name MIPAD2\Rawman
Time Zone China Standard Time
Installed Physical Memory (RAM) 2.00 GB

I’ve put Speccy report in .pdf format to this post attachment.

I’ll be glad for any feedback or advice.

Thanks to the author of this Forum and all participants, information here is really valuable!

Speccy details.pdf (439 KB)

That is a CherryTrail tablet so it uses TXE 2 firmware. Since it happens at boot and not within an OS, that problem is either BIOS or TXE firmware related. Both are possible when it comes to Chinese manufacturers. First, you should try updating the BIOS to the latest from the OEM, if you can find it. From what I can see from a quick search, the SPI image is included at the OS images/flashpacks at “ifwi.bin” file (8MB). So I suppose, updating the OS might also update the SPI/BIOS and thus fix your problem that way. If the problem is only the TXE region being dirty/corrupted then you would need to rewrite it but for that you need an unlocked Flash Descriptor (checked via Flash Programming Tool’s “fptw -d spi.bin” command which should dump an 8MB file and not show error 26 or similar).

Thanks for your feedback.

I barely see how to follow your suggestions regarding TXE, but I’ll do my best and I’ll try to research that way. Luckily there are tonns of instructions in this forum!

Plutomaniac, dude, thank you very much for your help!

Finally I’ve managed to resolve the issue with firmware.

What I did is:

0. I’ve downloaded ‘Android latte’ archive (Native release) for the Mi Pad 2 tablet and “Intel TXE System Tools v2” pack from this forum

1. Then I extracted ifwi.bin from the android image and copied it with TXE tools onto USB stick

2. I’ve loaded Windows 10 on the tablet and copied files from USB stick from step.1 to the C:\TXE

3. Opened command prompt with elevaded permission (Administrator account) in the C:\TXE

4. I checked if fptw can dump SPI with the command: C:\TXE > fptw64.exe -d spi.bin
that completed just fine and dump was saved on the disk in ~8 MB file

5. I checked TXE info with command: fptw64.exe -I
For some reason no PRD region was detected, other fieds were OK

6. Finally I performed flashing of the SPI: fptw64.exe -f ifwi.bin
Process completed and then I restarted device.

After that procedure no errors\warning ocurred during bootstrap and all sensor were detected within Windows 10. Currently I’m in process of flashing custom MIUI 8 from (made by _papka)

I hope this information will be helpful for other users facing same issues on Xiaomi Mi Pad 2.

Thanks to the authors and computer enthusiasts on this forum!


Don’t know why it wasn’t possbile to flash PRD file ‘’ via ‘fptw’ tool, it was saying that no PRD region was detected.

That’s great. I’m glad the info here helped you solve your problem. Here are some explanations and remarks though based on what you wrote:

1) At the TXE firmware, “PRD” stands for “Production” as there are also some other releases such as Pre-Production (PRE) and ROM-Bypass (BYP) which do not concern you or any regular user for that matter. It has nothing to do with the “PDR” region of the SPI image which is an area where OEM can place random information. The PDR region is not used anymore so that’s why it’s reported as missing or similar at FPT. That warning shown at FPT is normal and should be ignored.

2) The only reason you were able to dump (fpt -d) and reflash the SPI chip (fpt -f) is because your Intel Flash Descriptor region is unlocked (no error 26 received at -d and -f commands). If that wasn’t unlocked you would not have been able to reflash the SPI image and thus the TXE region within.

3) You must never flash RGN (Stock, unconfigured) or EXTR (dirty, taken from some other system) Engine firmware with the intention to update it, using FPT, unless it is your own dump or you have first customized the firmware based on the OEM settings of your own system set by Flash Image Tool (FITC). To update the Engine firmware, you need to use FWUpdate Tool with whatever RGN/EXTR firmware you desire, not FPT. FPT is a general SPI flasher and not able to update the Engine firmware as it should, that is with custom OEM settings intact.

In your case, you reflashed the whole SPI image (FD+TXE+BIOS) from the official Xiaomi release using FPT -f which also reflashed the problematic TXE region. Thus, all your Engine related problems got solved.

Thanks for detailed explanation! That was very enlightening.

My colleagues on (Mi pad 2 owners) also found this thread useful.

Hello, when I make C: \ TXE> fptw64.exe -d spi.bin or other steps, you get a message that says “can not run this app in your pc”. what should I do???

You are doing something wrong. Maybe you have x86 OS? In that case, use the equivalent tool version.

thanks for your answer. I do not know anything about quetsa guide that I am following, if you can give me the equivalent would be very kind … thank you !!
the system that I’m using on the tablet has windows 10 home x64

Is there any pro guy in 2019? I am happy with Win 10 and want only flash the BIOS (update), because I can´t it switch off. When I plug a charger always switching on and load Win 10. Without charger I can shutdown, but with charger always load the system… I don´t know where is the problem, going try to update BIOS.