jMicron esata driver won't install

Hi all,

I just this weekend clean installed Win 8.1 x64 (and applied all patches offered by WU) and have a couple little problems. The main one is the jMicron eSata driver (R1.17.65.11) fails to install with the message "UpdateDriverForPlugAndPlayDevices: error" which is pretty unhelpful.

This driver worked fine in Win 7 x64. Is anyone using this driver on Win 8.1?

Any help is appreciated.

Cheers

You obviously tried to install the JMicron RAID driver, which I have linked within >this< thread. All the drivers, which I am offering there, are for “normal” SATA ports and not for eSATA ones.
If you are searching for the newest JMicron eSATA driver, I recommend to look [url=ftp://driver.jmicron.com.tw/SATA_Controller/Windows/[/url], where you will find all JMicron SATA (as … WHQL.zip) and eSATA (as … WHQL eSATA.zip) drivers.
As you can see at the JMicron FTP Server page, the latest JMicron SATA and eSATA drivers are R1.17.65 and dated 11/14/2012. This explains, why I do not really recommend to use one of these old drivers with Windows 8.1.
My suggestion is to use the generic Win8.1 SATA driver for the JMicron eSATA ports (pre-condition: no yellow mark within the Device Manager).

Hi Fernando,

The driver I am using is the eSATA one (not the SATA one) from the jmicron ftp site (JMB36X_WinDrv_R1.17.65_WHQL_eSATA.zip). Like I say it worked fine in Win 7 (the driver would install and I could hot plug eSATA drives).

Interestingly, when I plug an eSATA drive, Win 8.1 does not respond in any visible way and nothing appears in Dev Manager.

Stupid question: How do I use the generic 8.1 driver for the jMicroon eSATA ports?

Cheers

Is the JMicron eSATA Controller listed within the "IDE ATA/ATAPI Controllers" section of the Device Manager?
Do you get any yellow mark (means "missing driver"), when you plug in any device?
Is the JMicron eSATA Controller enabled within the BIOS?

It should be installed automaticly during the OS Setup (precondition: the Controller is enabled within the BIOS).


No, the jMicron eSATA controller is not listed in the "IDE ATA/ATAPI Controllers" section of the Device Manager. All I have is "ATA Channel 0", "ATA Channel 1" and "Standard Dual Channel PCI IDE Controller". The "Storage Controllers" section lists "Intel Desktop/… SATA RAID Controller" and "Microsoft Storage Spaces Controller".


Yes, I do get a yellow mark when I plug in my WD USB HDD. Incidentally, the WD SES driver also refuses to install from Windows Update (just says it failed with no explanation) and fails with a "Invalid Data" message when I try manually. The drive still works regardless.


Yes, the jMicron controller is enabled in the BIOS.

This is strange because I used the eSATA port in Win7 to do a backup just before I shutdown to install Win 8.1 from a USB stick (made with rufus).

Could it be the way I did the install? I disconnected all drives except the boot one prior to the install and then reconnected them after. This was probably not required but I read that this is best way to go when installing Win 7 onto SSD when you also have other internal HDD and applied the same logic for Win 8.1.

Cheers

Zitat von JohnM im Beitrag #5

No, the jMicron eSATA controller is not listed in the "IDE ATA/ATAPI Controllers" section of the Device Manager. All I have is "ATA Channel 0", "ATA Channel 1" and "Standard Dual Channel PCI IDE Controller".



Please check the HardwareIDs of the listed "Standard Dual Channel PCI IDE Controller" by doing a right click onto it and choosing "Properties" > "Details" > "Property" > "HardwareIDs".
Which VendorID (VEN_XXXX) and DeviceID (DEV_XXXX) do you see?

Here are the hardware IDs:
PCI\VEN_197B&DEV_2362&SUBSYS_84601043&REV_10
PCI\VEN_197B&DEV_2362&SUBSYS_84601043
PCI\VEN_197B&DEV_2362&CC_010185
PCI\VEN_197B&DEV_2362&CC_0101

It seems that this device is the jMicron controller. I tried to manually update the driver but it failed with the message "The data is invalid". Same message as I get for the WD SES driver. Curious…

It doesn’t only seem to be the JMicron SATA Controller, it definitively is it. That is what I suspected. Everything is fine like it is regarding the JMicron eSATA ports.

This indicates, that the (old) original JMicron eSATA driver doesn’t support Windows 8 resp. Windows 8.1.

This problem has nothing to do with the JMicron eSATA port. Please read >this< article.

Hi Fernando,

It looks like I’m snookered until jMicron release a new driver.

Anyways, thanks very much for your help.
Cheers

Why do you want to use a JMicron driver, when the MS SATA driver works fine?
Furthermore you should consider, that JMicron hasn’t released a single SATA driver this year. So you should not expect the release of an updated JMicron driver very soon.


The MS SATA driver doesn’t appear to hot plug. I plug the eSATA HDD in and nothing happens…

EDIT by Fernando: Quoting corrected.

Zitat von JohnM im Beitrag #11

The MS SATA driver doesn’t appear to hot plug. I plug the eSATA HDD in and nothing happens…



If the generic MS SATA driver really should not support the “HotPlug” feature, I recommend to install the tool named HotSwap!, which you can get >here<.

I’m sorry but I don’t see how HotSwap! can work in this case because windows does not know that the HDD is there. It is not recognised when it is plugged in: it does not appear in device manager or in “This PC”.

Incidentally, I use hot swapping software called “USB Safely Remove” which works really well.

I thought, that your problem is the missing “HotPlug” feature and didn’t know, that the connected drives are not detected by the OS at all.
Does this always happen or just when you plug in the HDD “on the fly”?
Maybe the HDD doesn’t get enough power.

It’s a WD “My Book” powered by its own external power cable. It works fine when plugged in via USB but it’s only USB 2.0 that is slooow when doing backups.

EDIT by Fernando: Wrong quotes corrected

@ JohnM:

Offtopic: If you set the quotes manually, please use a slash and not a back-slash at the end.

Hi all,

Just dropped in to say that I have found the problem. The System Events Broker service had been disabled.

Cheers
John

Thanks for your feedback!
Does this mean, that you have solved your problem now? It makes a difference, if you find the the reason for a problem or if you are able to solve it.


Yes the problem is solved.

After resetting the service to Auto and rebooting I was able to install the jMicron eSATA drivers (and hotplug works!), the WD SES USB drivers (which WU has been offering me) and the latest nVidia drivers. None of these would install before.

It would have saved a lot of time if there had been a useful error message, but then it probably wouldn’t be windows and we’d all get bored!

Anyway cheers!