Jump write/read permission to allow modified BIOS being flashed into a dell chipset

Hi, I have acquired the proper bios.bin file and deleted the Intel Manager system using me_cleaner without a problem but when trying to flash it into the chipset using a efi shell or freedos and Fpt it sends an access error, so it means the bios system hasn’t rights of reading writing. I red at the me_cleaner online how-to documents that if the BIOS system hasn’t read/write permissions the flashing should be done externally pinching the pins of the microchip and a physical programmer. I also tried to downgrade a unmodified bios file but it gave the same error. It seems my laptop has a sky lake chipset and it happens even when I deactivate at the bios settings the write/reading permission.

Is there a way to flash the modified BIOS even when the system has blocked the reading/writing permissions?

You either have to do pinmod (url=https://www.win-raid.com/t3553f39-Guide-Unlock-Intel-Flash-Descriptor-Read-Write-Access-Permissions-for-SPI-Servicing.html]See “E1” here[/url]) to unlock the FD, or get a flash programmer (CH341A + SOIC8 test clip w/ cable) Especially since you want to re-write the ME Region with a disabled ME
Check the BIOS chips on the board, make sure both have 8 pins, some have one chip with 8 and one with 16. If one of yours has 16 pins then you’ll also need SOIC16 clip w/ cable.

My laptop is a dell Inspiron 5559, I had noticed, before knowing about the existence of Intel Management Engine, the use of a remote third party administrator system against my laptop because it randomly and suddenly started crashing or the ram memory was being reseted and the computer was being set at the login screen while I was using it, or like when there is a Trojan horse installed in the system and remotely somebody could click on the buttons to close the windows, like if there would be a retard in the other side playing with my computer just to delete my job on the software I was using before ram was reseted or the browser was closed. And that has to be a different kind of access compared with the kind of access the NSA should have, because they wouldn’t let you notice your computer can be manipulated remotely. I live in Mexico and somehow a bounch of retards gained access to systems created at the USA and the NSA ordered computer vendors to factory install them on their new machines, accordingly to what I recently red about Intel Management Engine. So in the case of Mexico its retards allowed to turn on my computer while I’m away because my laptop turns on randomly when I just turned it off and then it turns off again, or randomly playing this noisy beep the bios uses while the operative system is started. For those who are interested of tracking and studying these systems of mass surveillance should figure out the Mexican case. It seems these systems have direct access to the ram memory, can control and inject remotely code into the ram memory and work exactly like Trojan horses do when installed in the operative system. So… I uninstalled the wifi card and it kept working like being controlled remotely, so there should be an additional antennae or it works transmitting with ultrasound or something. So it should be a interesting research job to track how Intel management system transmits and which components of the board uses, I was asking myself if by uninstalling microphone, webcam and speakers could work to stop these systems transmitting because they do it in parallel of the wifi card, now they don’t need root kits to track computers, now even a monkey could find your computers in these systems like finding a user in a social network and then start clicking like idiot pre configured buttons to reset your computer. A very dangerous situation at Mejico and it could easily escalate to systems at USA being monitored from Mejico. I can’t imagine what could happen the day governments were able to develop and implant micro-chips at our brains able to control our behavior, retards could start mass shootings remotely at the USA from Mejico. XD

Well but the main topic is:
-Is there a way to disable these systems just uninstalling some components like the mic, the webcam, the speakers, wifi card or finding an additional antennae at the board?
-I had opened my laptop but broke some plastic parts while re ensambling, so I will open it again when I have acquired the components to physically flash the bios, so do you know if the dell Inspiron 5559 has both bios with 8 pins or one has 16 pins? If that’s the case, could you post a link to learn how to SOIC16 with cable (in order to figure out which components will I require)
-If I flash the bios using a raspberry pi what apps could be useful in this case of unlocking FD and SOIC16
-which method should I apply, unlocking the Realtek card (FD) or the bios-8-pin/16-pin. And which apps should I install at the raspberry pi?
These systems work like if there was installed aguacate Remote Desktop but in the bios.
These kind of illegal access from Mejico to NSA systems should be vetoed, I guess the USA sells these surveillance systems to Mexican government and corrupt agents just sell these access to criminal retards. A dangerous situation for both countries.

Thanks and best regards

Yes, sounds like you had some virus. Best to not disable ME in the future to avoid this, but rather to be sure you always have latest up to date BIOS and ME, and then install a good anti-virus, anti-malware, and firewall.
Yes, NSA wouldn’t play around, you wont know when they are looking around.

If you do not use Mic, Webcam, and WiFi, yes you can disable those by either not installing the drivers for them, or by disabling the device in device manager. Or physically disconnect the item’s ribbon cable inside the laptop (going overboard here)
Speakers are output only, those you don’t need to disable, no one can listen with a speaker only output.

Sorry, I don’t know what kind of BIOS chips or how many are used in this system, you’ll have to inspect and or show me images of the actual board. Some systems of the same model may use different chips too, so best to look at this in person on the item in your possession.
Unlocking FD is done on the source BIOS before you program it back in, using a hex editor, here’s how that is done, see second spoiler in Section B, first or second image (you’ll have to look at your dumped BIOS before you know which applies)
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

If you do the pinmod, at RealTek card, you to dump FD without reboot, via FPT software, then edit it, then flash it back via FPT. If you reboot in the middle of this process FD will lock again, and you will have to redo the pinmod.

Sorry, I know nothing about Raspberry PI, but if you search around this forum I’ve seen users discuss using this to dump and reflash BIOS.

Remote desktop can be disabled at windows services and at “Properties” of My computer, advanced system settings, remote.

Nothing you mention sounds NSA related Sounds more like a bored hacker, a random virus designed to just annoy or bother someone (which I’ve never heard of), or someone that you’ve upset just playing tricks on you.

Yes maybe is that. But the thing is that I was booting my recently installed Linux without the wi-fi card being recognized by the installer, then it was disabled. The retard “boring hacker” started playing the beep the BIOS uses when starting the system and resetting the ram memory or closing the Programms I started at the recently installed Linux.

So this in hands of thiefs could be dangerous because they could steal my money of my online bank account interacting with my computer even if it’s Linux the OS I’m using. Or share the amount of the money I’m saving at my online bank account.

There was a case with the Italian company “hacking-team” who developed root-kits and the vectors to root systems, but the target was the operative systems. But in this case according of what I red at the web page of core boot, the Intel management system was kind of ordered by the NSA to computer vendors to be installed in every board they sell. It could be a measure of counter-terrorism so there should be some other governments partnering this measure and should have had acquired these systems. So in the Mexican case what could have happened is that corrupt agents just receive extra money to allow acces to third parties which are retard criminal theifs. It could be the case of this “bored hacker”. What they are doing with this corruption is devealing American-before-unknown capabilities which before were only noticed by genius genuine hackers who noticed the existence of this systems in their chipsets and figured out a way to disable it, like the developers of me_cleaner.

Does unlocking the FD is enough to flash a modified bios.bin disabling ME?

Read here ->NSA Intel Management Engine, about the NSA ordering computer vendors to install malware at their chipsets as a surveillance program of governments agencies. A system discovered by Russian hackers.

If your WiFi was not installed, thus not connected, then no one outside the room you were in could be doing anything to your system. There would be zero ways for anyone to connect… Unless you have a Wired Local Area Network and you had an Ethernet cable connected and someone else in your building had access to this wired network.
BIOS beeps could be caused by any motherboard error, or something wrong with the board or BIOS etc.

If you unlock FD, then yes, you can FPT flash any ME FW you want. You read that article wrong, it’s about NSA wanting an option to disable ME FW on their end, in a system, to cut off possible outside access (by Intel, MS, or anyone that has hacked ME in various ways)
NSA doesn’t need to do any of that, they can access whatever they want directly through the internet systems that are all routed through (and copied at) their hubs at the Prism building.

Since my laptop keeps restarting and slowing down and turning off the screen randomly and changing bios settings as every time I restart the computer, im modifying the bios to acquire a home brew working bios.

Then I just acquired a ch341 programmer and was able to dump the bios, the file size i get when reading the bios is about 16 MB, I’m using me cleaner to deactivate Intel ME for spi servicing. But the file I get after using me cleaner is about 2mb, then when I try to flash that 2mb file back it makes a error when verifying the 2mb.bin file, anyway I was able to unlock writing/reading through the software I found to control the ch341 programmer, so one way to flash the bios should be using a Efi shell and fpt to flash the bin file, or through dos the same way with fpt.exe. What could be the command to flash the .bin file once I unlocked reading/writing using fpt at the Efi shell or dos? I red something about fpt -grep after flashing the bios or something.

But it seems easier to just flashing the 2mb bin file using the ch341 programmer but it comes this error message when clicking to start the writing, it seems the software verifies the size of the bin to be flashed and the id of the bios chip the motherboard has and maybe compares with a inside database the size and structure of the bin file and to start flashing it must be equal, so how could I flash a modified 2mb bin file if it originally is 16mb using this method.

My computer specs:

Brand: Dell
Model: Inspiron 15-5559
Motherboard: Compal LA-D071P, Rev.: 1.0 (A00)

APU: Intel Core i7-6500U (SR2EZ)
GPU: AMD Radeon R5 M335 (216-0867020)
KBC: Microchip MEC1404-NU
UC5 Winbond W25Q128FVSG (128Mbit = 16MB)


I was able to Flash the BIOS with this technic on a different DELL laptop, once I restarted the laptop, It won’t boot, and the BIOS file written on the BIOS chip, was unlocked without the spying modules, but it didnt start, then i wrote the original BIOS file without modifications, I previously backed up the original BIOS. Then, unlocking the bios went wrong at some point, that could be deleting the spying module on the bios file with the script. Do you know if this script works on every Dell laptop?

Since it is very unlikely, that anybody has tested the script with all available Dell laptop models, you may net get an answer.
By the way - our BIOS modding Guru Lost_N_BIOS hasn’t been online since several years.