Just brough used MSI Z77A-G43, problem with ME

I’m new here and I’m also not a native english speaker, so sorry if something I say sounds stupid.
I recently brough an used MSI Z77A-G43 with i5 2400 processor (the best I could afford for now), instaled in yesterday to my case, it’s now running under Windows 8.1.
I didn’t tested it deeply yet, but everything seems to work fine, only one thing makes me wonder.
When I tried to configure fan in my CPU cooler (Cooler Master TX3) I installed MSI Control Center, and after runing it I’m getting the message “Please replace ME version!”, but then everything works OK.
I never before heard about ME. I’m semi-experienced PC user, but it’s the first time that I see ME term. Did a little research (really hard to find any info about ME at all), finally found this forum and I seen some of you guys got really big knowledge about ME.
I found Mr. plutomaniac article about ME and downloaded the MEInfo to check what’s going on, but info I found there isn’t telling much to me. Heres the screen:

Should I be worried? Is my mobo damaged somehow? Can I fix it?

Sorry once more for any potential spelling mistakes, and thanks in advance for any help.

From this MEInfo screen, the ME looks ok. You should check MEManuf as well but from a hardware standpoint, it looks just fine. That message is seen at MSI’s software so it depends on what they mean “replace” the ME. I think they mean to update the ME driver. So try the latest v11.0 driver from the ME thread (MEI-only or INF for more advanced users). If the new driver shows the same error you can also try updating the ME firmware to the latest ME8 1.5MB from the ME thread once more. Other than that, it might be a software bug from MSI or just something else that only makes sense to them. If updating the driver and/or firmware do not help then you will have to ask them what that message actually means.

Thanks for the reply!
I will update the driver in a moment, and I got a question to the ME firmware update. Version that suits for my mobo is Consumer System Intel ME 8 1.5MB Firmware v8.1.65.1586, right?
Is it hard thing to update the firmware, or at the same level like updating the BIOS?

Yes, you need 1.5MB. It’s as easy or easier for ME. You just have to use the FWUpdate tool, check the ME thread for more info and “-?” parameter at FWUpdate to learn how to update.

I can’t find any information about ‘-?’ parameter in ME thread. I assume I can preform the update by running FWUpdate Local-Win64 from cmd and then point at 1.5MB?
Or there is some more detailed guide how to preform the update but I just can’t find it?

No, I mean run FWUpdate -? (with parameter "-?") to learn how to use it. The actual parameter is "FWUpdLcl -f me.bin" where "me.bin" the firmware name.

Ok, updated both the driver and the firmware succesfuly but still getting “Please replace ME version!” info on MSI Control Center. So I’m posting on thier forums what does it mean. Thanks for all the support :slight_smile: