Legacy PCI sound cards on Modern Motherboards

This is some recent experimentation the last few days using legacy PCI cards on modern motherboards.

I was testing out most of my PCI sound cards I could find on my Z370.

I tried using the PCI to PCIe riser adapter and it works to detect the card and let you install the drivers successfully. But everything shows it is installed correctly and working but no audio output comes from the card.

I tried using the PCIe x1 card to USB 3.0 cable to Dual PCI Slot adapter.
The card is detected in Device Manager. As soon you install the drivers and as it is about to finish it freezes the computer system. You have to shutdown manually and reboot. After rebooting the drive has to repair itself the damaged files and so the end result is no you can’t finish the driver installation so the device cannot work. I also noticed that it makes some other devices in the Device Manager into an exclamation mark so avoid this adapter.

I tried using the physical PCI Slot. Does not trigger the motherboard to power on accidentally.
I got the Ensoniq PCI to work for audio.

I tried some other Yamaha and Aureal Vortex cards and it doesn’t see the card in Device Manager. One major issue to warn about is when sliding the card into the slot it powered on my motherboard. This is not good but luckily none of these cards fried itself.

I tried an Asus Xonar DG. The card is detected in device manager but as soon as the driver installs it crashes.
STOP 0X00000019

I tried a Sound Blaster Audigy 2 ZS and the motherboard powered on as the card was being inserted. Then I started seeing smoke and I shut off the computer using the power supply. I looked at the sound card connector and the metal traces on the bottom of the card were burnt black. The card was totaled and after even removing the damaged traces it would not recognize the card and the computer would not POST.

Since some high end audio PCI sound cards are probably very expensive I recommend you turn off the power supply using the switch and then hit the power on button to drain of any residual power. Then you can insert the PCI sound card into the slot. But be warned I don’t know whether the PCI card fried because the power was on when inserting the card at the same time maybe causing a short or there is some incompatibility in voltages that exists with some PCI sounds cards on modern motherboards. So be careful and do a full power supply power off using the switch and hit the power button a few times to power drain it before installing your PCI sound card and make sure it is fully inserted into the slot before turning the power supply switch back on. Hopefully it will work and won’t fry the card. On my Ivy Bridge I never had this problem of a fried card or it powering on when inserted into the slot.

This is why a better alternative is going to be either PCIe or USB based for your sound device on modern motherboards. I’m sure there’s one that can handle XLR inputs for audiophiles that need it.

Good luck.


I’ve had success with this - http://eshop.sintech.cn/pcie-express-x1-…le-w-p-933.html

I install a YMF744 PCI sound card and VIA USB 2.0 card in it with success.

I can say that I am using a Startech PCI Express to PCI adapter to be able to use my RME HDSP 9652 PCI soundcard with my Z390 board,
and it works perfectly, super low latency and zero stability issues for months :slight_smile:
But, I had to customize the chassi to be able to safely secure the full height PCI card in the adapter.


Damnation can you find the chipset used on that adapter?


What is the chipset on that adapter?

I found a weblink that says.

Chipset ID:
Pericom - PI7C9X118SL

Can you confirm on yours?

Mine is showing Asmedia ASM1083. Possibly yours is different and higher compatibility due to higher cost.


It’s a XIO2001 Texas Instruments PCI Express-to-PCI Bridge

Sorry for the delay, yes it is pericom chipset.
I don’t know about higher cost though, this one was very cheap, 279 SEK.
But like I said works perfectly :slight_smile:

Which OS are you using this adapter on without issues?


the USB 2.0 card
worked in win98, winXP and win10

worked in win98, winXP, ISA emulation did not work in DOS, no driver for win10 64bit, did not try win10 32bit

ESS Solo1
worked in win98, winXP, infinite loop on driver load in DOS, BSOD win10 even without driver being installed


Use it with win7 & 10 64bit, dualboot.

Quick tip, that might help in some cases:
Due to being forced to use PCIe to PCI bridges, the BIOS settings "Native PCIe" and/or "Native ASPM" can be problematic.
As far as I know, the setting makes the bridge "transparent" for the system. System will only look at capabilities for the root port and the end device.
However, if the bridge itself has some limitations (e.g. no or only partial ASPM support), this can lead to problems.

Disabling those settings might help make devices work behind PCIe bridges.

I’ll have to locate the adapters again and run them in MPS Multiprocessor Mode. I think the modded ACPI.sys might be the reason why it is not functioning. I’ll update later when I locate the adapters for a retest.

Just would like to report: the pictured ASM 1083 chipset adapter in my Asus P9X79 Pro motherboard was unfortunately not working reliably with my RME HDSP PCI card (Rev 1.3) + Multiface 1 under Windows 7… Unpredictable operation, sometimes booted sometimes not. Might work with different motherboards or with later revisions of the HDSP PCI card - but my combination was definitely not lucky.


Forgot to ask, what is the Brand and Model of the motherboard that you used your PCI -> PCIe adapter on with the sound card working on those operating systems?

Forgot to ask, what is the Brand and Model of the motherboard that you used your PCI -> PCIe adapter on with the sound card working on those operating systems?

If i remember right, the first MB with this audio setup was a Asrock Z270 Taichi, then i have also used it on a Asrock Z390 Taichi and now Asrock Z490 Pro4.
I tried it on a MSI Z490 gaming plus, but i had problems with crashing that MIGHT have been audio related.

I have tried lots of PCI sound card in my computer (Ryzen 3900X/Biostar X470) and they all work perfectly fine in Windows 32bit:

Aureal 8820
Creative CT4740/ES1371/5805 (I use this for Windows 3.11 - with 3rd party drivers)
SB Live!
M-Audio Audiophile 24/96 (works from NT 3.51 to Windows 11/64) → In NT 3.51 and 4 - not so good compatibility with Unreal, Quake II.
ALS4000 - this one has good working drivers for NT 3.51, including sound in Unreal, Hexen 2.

DOS is a different story for AMD boards. Aureal 8820 works on a Haswell configuration with an ASMedia 1083 - but not an AMD X470 with the same bridge chip. AFAIK AMD chipsets are not getting any sound in DOS since AM3 socket…

I’ll will try a PCI-E to PCI bridge with subtractive decoding support, not all PCI-E to PCI chipset bridges have support for this.


Is such an adapter safe to use in a laptop with the EXP GDC. I mean powering everything up.
The laptop has its own PSU, EXP GDC is powered by an external ATX power supply, and now I would like to connect the PCI sound card - is it safe, there will be no ground loop and nothing will burn ???