LEGACY/UEFI Boot BIOS settings

I just noticed that in the BOOT section of my BIOS I have an option to choose between “Legacy ROM” and “EFI Compatible” for the PCI ROM setting. When I tried to choose EFI compatible, I cannot boot into Windows and can’t go inside the BIOS setup since there was no screen display. I had to reset the BIOS through the motherboard jumper to get into the BIOS again and choose Legacy ROM and the problem went away. What does that mean? If I install Windows 8.1 in GPT/EFI mode, can I use the EFI compatible option?

EDIT: I see that this is a common problem. This guy experienced the same: http://www.rage3d.com/board/showpost.php…73&postcount=25

@ kevindd992002:
I suspect, that there are at least 2 reasons why you cannot use the “EFI Compatible” BIOS option:

  1. Your current system doesn’t contain any device, which is bootable in UEFI mode. The OS had been installed in LEGACY mode using the MBR instead of the GUID Partition Table.
  2. You are using a discrete graphics card instead of the on-board Intel iGPU. The BIOS of your graphics card may not have a suitable “GOP Driver”.

It is easy to test the “EFI Compatible” BIOS option by temporarily removing/disabling the discrete graphics card and inserting an USB Flash drive, which contains an UEFI bootable image.



Those are the things that I suspect also.

1.) My current OS is really using MBR which explains why I can’t boot. But what I don’t understand why is there no option to enter the BIOS? So let’s say I already install the OS using GPT and it boots fine with the EFI Compatible option, how then would I enter the BIOS to change some settings?

2.) Well, my cards are Gigabyte GTX 670’s with the latest UEFI BIOS so I was assuming they should have a GOP driver inside them? How do I confirm for sure?

Please have a look into your mainboard manual. There should be an option to enter the BIOS even after having chosen the "Fast Boot" option.

Do a Google search for "Gigabyte GTX 670 Gop Driver".

Please have a look into your mainboard manual. There should be an option to enter the BIOS even after having chosen the "Fast Boot" option.

Do a Google search for “Gigabyte GTX 670 Gop Driver”.





1.) So EFI Compatible is the same as Fast Boot? The weird thin is that my motherboard’s manual do not show anything regarding PCI ROM Priority. It seems that that option was added in the latest BIOS revision of my board and it was not reflected in the manual.

2.) I’m not seeing concrete results regarding that search but if you check here, its BIOS is already a “UEFI BIOS”. I’m assuming that already has a GOP driver in it, right?

No, but an UEFI boot is much quicker than a LEGACY (=non-UEFI) one.

What do you mean with "PCI ROM Priority"?
The BIOS setting options within the "BOOT" section usually are "Fast Boot", "Option ROM Messages" and "UEFI/Legacy Boot" (or "Compatibility Support Module").
By the way: You should think about another (better) thread title like "LEGACY/UEFI Boot BIOS settings".

I am not sure about that. Please read >this< discussion.

1.) Here’s a good picture of what setting I’m referring to:
https://communities.vmware.com/servlet/J…82/DSCF5295.JPG
It says PCI ROM Priority and has two options: Legacy ROM and EFI Compatible

2.) I’ll give the link a read first to check if my cards’ BIOS are already GOP-ready
EDIT: I’m not sure where the link is going but I did see a link saying that they were to boot in UEFI mode with the same BIOS that I have for my cards.

How do I edit the title of this thread?

EDIT by Fernando: Fully quoted text deleted

Ok, but the name "PCI ROM Priority" given by ASUS is misleading, because it suggests a priority order of the different Option ROM modules.
EFI modules like the Intel SataDriver or GopDriver are no PCI ROM modules.

Please stop quoting the full text of a previous post. It is absolutely dispensable to have each text twice within a thread.

I agree. What do you think about that option then? Is it the same as the UEFI boot and non-UEFI boot setting on other boards?

I’m sorry, I got used to do this in OCN. I didn’t know it’s not allowed here. How do I edit the thread title?

EDIT: I’m not sure where the link above is going but I did see a link saying that they were able to boot in UEFI mode with the same BIOS that I have for my cards.

No, this BIOS option is only valid, when the user has chosen the option "EFI Compatible" or "CSM Enabled" and for the on-board Controllers both usable "Firmware" modules (Legacy and EFI) are present within the BIOS.

Just hit the "Edit" button of the first post.

I thought when you set it to “EFI Compatible” that’s the same as “CSM Disabled” as it will be a native UEFI boot? I’m not sure I’m following here.

Since I don’t have the “EFI Compatible” option within my UEFI BIOS, I cannot test it, but I doubt, that it means the same as “CSM Disabled”.

Ok. So technically, even though I set it to EFI Compatible I should still be able to boot into the BIOS setup page?

I think you encountered the same issue I was asking now here: http://www.overclock.net/t/1244232/asus-…0#post_19670274 . It seems that the EFI SataDriver was inserted in our BIOS in this post.

And you were also discussing this same question from this post: http://www.overclock.net/t/1244232/asus-…0#post_19853638 onwards.

What do you think?

Let me explain this a bit.

This “PCI ROM Priority” is in fact a priority setting that works that way, if implemented correctly: if set to “Legacy”, BIOS tries to start Option ROM before EFI Driver (if any), and if can be loaded, EFI Driver will not. If set to “EFI”, and EFI Driver is available, Option ROM will not be started, but EFI Driver will. If the set option is not available, another will be tried, so this setting is really a priority setting. Other priorities like “Storage OROM” and “Network OROM” my have another options besides “Legacy” and “EFI”, i.e “Don not launch” or “Launch both”.
This settings are nothing to do with CSM except they are disabled if CSM is disabled, because CSM core is the only loader of Legacy OROMs and if it’s disabled, it will be either EFI Driver or nothing, no priority settings needed.

If you system is somewhat current, i.e. GPU supports GOP and has EFI Driver available, you will see BIOS setup with disabled CSM. In fact, I would recommend disabling CSM and enabling SecureBoot and FastBoot to any user that will not use old OSes from DOS to Windows 7, because CSM consumes memory and boot time, and Legacy Option ROMs can’t be verified to be non-malicious, so no protection from so called “evil maid” attack is possible with CSM enabled.

@CodeRush

Thanks for chiming in.

That was my thinking also regarding it being a “Priority” setting. In my case, how do you explain why when I choose “EFI Compatible” and then save and restart the system, I only get a blank screen (there’s even no option to enter the BIOS setup screen)? I have to clear CMOS all over again just to be able to boot normally. Shouldn’t it use the Legacy OROMs if ever it does not detect EFI ROMs?

My board is the ASUS P8Z68-V/GEN3 and it doesn’t have the option disable CSM, enable SecureBoot, and enable FastBoot. It is one of the first UEFI boards that don’t have these settings. The vBIOS of my two cards (Gigabyte GTX 670) say they are UEFI BIOSes though.

Yes, the Intel 6-Series mainboards were the first ones with an UEFI BIOS, but they have only very limited support of booting in UEFI mode. The original BIOSes of my ASUS P8Z68-V do not even contain any EFI module (GopDriver, SataDriver etc.).
By the way: It would be a good idea to create a signature with the most important informations about your system (Mainboard, Chipset, CPU, Disk Drives, SATA mode, OS).

Then it’s just a BIOS bug that you can’t use your graphics in GOP mode. I think the BIOS version you have is based on very old AMI tree, so it’s no surprise that that time there were no SecureBoot, pure UEFI mode and other stuff like this. You can do nothing about it and have to use CSM with this board. You can sure use UEFI-bootable systems and GPT partitions, but the whole point of both is disabled CSM, which is not possible, so I recommend to do nothing at all - it’s simple and rewarding. :slight_smile:

As I told you some days ago, to my experience 6-series motherboard cannot boot in true UEFI mode which requires a disabled CSM. There is some EFI module support but is limited. My best guess is that CSM is automatically enabled on such a motherboard with no option to configure. You are getting a back screen when choosing EFI modules because your BIOS has no EFI modules inside but only oROMs.

Maybe you could insert manually EFI modules but I don’t know how dangerous that really is, especially if you don’t have Dual BIOS, Asus BIOS Flashback or a programmer. Even if you do that, CSM will always be enabled on that motherboard and thus no true UEFI boot can be achieved.

Ok. Why then would ASUS even have that option of changing the PCI ROM Priority? That option wasn’t there in the initial revision of the BIOS. It appeared just after upgrading the BIOS to the latest revision.

If my card has a UEFI BIOS, shouldn’t the board detect it when using EFI Compatible? Or is this still because of the BIOS bug?

There were already others successful in inserting a SataDriver in my BIOS but that won’t give mich of a benefit if I’m just using AHCI, would it?

I suspect, that ASUS wanted to give the users the opportunity to use special EFI "Driver" modules instead of the Option ROM one. Maybe ASUS has simultaneously inserted some EFI "Driver" modules into the latest BIOSl. Have you already done a deeper look into it and searched for a "SataDriver" or "GopDriver" (for the iGPU) module?

Both options seem possible for me.

No, your system cannot use any Intel RAID ROM or SataDriver module as long as you are running your Intel SATA Controller in AHCI mode.