Lenovo E530 - BIOS Startup menu with boot options missing

– I am new to this forum and I could not figure out where to post this, please forgive me if it’s not in the right section.–

I found this forum because of the information available in the following post about DUAL SPI BIOS chips and Intel Engine Management :
Yoga 2 Pro shutdowns every 30 minute
On the first page, a user called Dman8777 reports issues with his Lenovo E430 ME-region, I have a similar configuration (difference is 14’’ vs 15.6’’ screen) and will maybe also replace the two BIOS chips (from same eBay Taiwan seller) and thus could have exactly the same issues with the ME-region as he had.

At this point all options are still open for me, and I would like you’re input on what I could & should do to fix my issue before I act.
Summary of my issue: my laptop gets to the POST screen and then gets stuck, I can access the BIOS (UEFI mode) and diagnostic screen but cannot boot anything AND the Startup menu is missing from the BIOS options, so no boot menu and no way to go back to legacy mode.
This happend during a regular Windows 10 update, I did not flash my BIOS since 2016 with the latest version.
More information on my issue and what I tried can be found on the Lenovo Forum: ThinkPad E530 not booting - no more startup menu in the bios

I now have the following options:
- replace system board (quite expensive, min. 100+ euro’s because I have a dedicated GeForce onboard)
- replace the SPI CHIPS for 25 euro if the BIOS is indeed corrupt, they are Winbond W25Q32 & W25Q64 flash chips DUAL (main bios + EC), but I will probably have the same issues as Dman8777 had with the Intel ME-region that was not included on the newly programmed chips or not?
- buy a cheap SPI programmer and try to reset the BIOS settings*, I know basic electronics (I study as an electrical engineer) but have no experience with this, and will need advice because the BIOS file is a .FL1 of 12Mb so it has to be split first for the main bios and EC.

*I already tried this to reset the settings:
- remove all batteries, including CMOS battery
- short-circuit the NXP EEPROM (it is the security chip I think because I could reset the UUID, Serial, password (not set but tried and it worked) but not the BIOS settings
- recovery flash with Crisis tool, pressing Fn+R puts the laptop in a blackscreen + fans turning at max but the USB sticks are not being accessed only powered-on

I can see there are people with a lot of experience and knowledge on this forum, what do you think I should do/try?

Picture of the three chips on the motherboard:

Thanks in advance!|addpics|g80-1-d6fe.png-invaddpicsinvv|/addpics|

This looks like a broken NVRAM issue, you need to dump W25Q64 chip and fix NVRAM in there. It could be rather difficult because there are no tools for doing it besides hex editor, but if you could attach the dump and the .FL1 file, I will try to help.


Thank you for your answer, so you think 1) it can be solved 2) the issue is in the main BIOS chip.
I can also just order that one, I have found a seller in Germany where I can order specifically the preprogrammed W25Q64, it would be faster but how sure are you this could solve the issue?

When you mean the NVRAM is broken, you mean it is corrupted?
Settings I can change in the BIOS are correctly saved, it’s just that I cannot reset them completely at this time.

In order to provide you a dump I would need an SPI programmer, I do not have one/access to one at this time.

An EC of 32Mb (4MB) size is quite big. I think it contains Flash Descriptor and ME FW, since I have a P655SA, which has dual SPI chips (Gigadevice GD25Q16 and GD25Q32) too.

Both chips are “main” on this platform because .FL file is 12 Mb exactly. There’s a little sense in splitting ME region in half, so I think that Descriptor, ME and NVRAM are in the Q64 one.
If you don’t have SPI programmer, you should definitely get one instead of buying pre-programmed SPI chips (which cost a lot and have unknown firmware in them).
The state of this system is definitely fixable, it looks like a corruption of some NVRAM variables required for booting (BootXXXX, for example).

Do you recommend a CH341A or EZP2010 SPI programmer?
These seem to be most common.

The CH341A is smaller and cheaper but it does not support in-system programming?
The EZP2010 often comes in a kit with a so8 clip so I suppose it does support ISP or at least I have more chances to not have to desolder (I have experience soldering SMD’s so would not be too bad but I prefer not to).

Anything else I should have or know before ordering?

You can get either of them, as both don’t really support ISP. Try it if you like it, but I would desolder the chip, because it’s much more reliable.


It took some time because the first programmer was defective and I had to solder it myself (inversed caps and resistors) and I bought a second to be sure but here they are, the dumps from both chips.

Can you please check if the content is corrupt, indicating the NVRAM got currupted in one or both chips?

Thanks a lot!

I also add the original BIOS file from Lenovo, it has a *.FL1 format and is 12Mb (there is also a FL2 but was told it is the first one).

It is the actual version installed on the laptop and the latest release from 09/2016.
2.58 (H0ET98WW) 2.58 (H0HT98WW)


How do I start checking for corrupted variables (in the BIOS region I suppose?), which tool do you recommend for this and do I get it?

I found several guides on the forum, but most are for editing the Intel ME region.
Can you give me a hint?


Thx for the help on the forum, I only needed a small push and nobody cared.

I managed to extract the UEFI BIOS from Lenovo with CodeRush application and flashed it on the 25Q32 chip and voila.