Lenovo M900 Tiny Bricked


I’ve a Lenovo M900 Tiny that is bricked due to a BIOS update failure in Windows. The computer now boots to a black screen, and the recovery procedure is not working (Putting the jumper on CLR CMOS with a BIOS recovery DISC inserted)

My last hope is to flash the BIOS via a hardware programmer, I’ve ordered a CH341A programmer and located two BIOS chips on the motherboard 25L12873F and 25L2006E.

From what I see from the specs the 25L2006E is 2Mbit and the 25L12873F is 128Mbit. The BIOS rom I can find on the website of Lenovo is 8MB which doesn’t seem to be in line with those chips?

Could you help me out how to flash the chips? The only informlation I found is to read, write and verify with the programmer, but I found it strange the size is not matching?

If it can help I have an exact same working computer, but I guess that If I read the chips from the working, and flash them to the bricked one, the bricked one will get all the info (MAC, Serial, Windows Key) of the working right?

Make at least 2 backups of the 128MBit chip. Lenovo normally has just the bios region as update, not the complete firmware.

Thanks a lot for your awnser, I’m assuming that I’ll need to replace the first 8MB of the 128Mbit read with the with the one of the BIOS from Lenovo’s website, is that correct?

Assuming = Bricking

Well that’s why I’m asking :slight_smile:

Could you guide me on how to identify the BIOS region, and how to fix my bricked backup?

There’s lots of information regarding bios recovery and the tools which can be used/ are needed in this forum and of course other places, too.

The basic steps are described for example here (simply the first pick when searching bios repair on youtube)

Of course transfer of machine relevant data is different for Lenovo.

@lfb6 Thanks a lot for the follow up and guiding me to some basic steps, I’m learning a lot here :slight_smile:

I’ve read the the 25L12873F chip 5 times and made sure the dumps where all equal, by hash and also compared with HxD.

I’ve opened the dump in UEFITool NE and now it’s clear what the BIOS region is, however i’m not sure what I need to do from here?

I see some errors, but I don’t know what it means:

I’ve also dumped the working machine, to compare, but it seems it’s using another chip (W25Q128FV), so not sure if the compare is relevant?

You can find the dumps here.

Could you guide me in the next steps to unbrick my machine?

Edit: I’ve edited the BIOS Region with the one of Lenovo and now the complete rom seems to be ok, I’ve uploaded here, could you validate this was the right thing to do and if yes, can I just rewrite this image?

Good work so far!

Bios update started with last UEFI volume but stopped at F73000, below that and (other UEFI volumes) it’s still bios version 41, from 870000 to F72FFF it’s version B5. Problem is that some information is stored in PEI (pre efi initialization), that’s a little unusual. See picture for this area, also a Windows code is there (last line). There are other small areas which seem to contain data one voluem up, unclear if this is configuration or machine specific data. (first pic stock on the left, second pic on the right)



I’d propose you try the attached bios region, that’s a restored 41 version => UEFITool 0.25, right click on bios region 'exchange as is’

Please be careful when writing, verify isn’t always reliable. Read the content of the chip after flashing, compare to original file, files have to be a 100% identical.

New_BIOS_region.zip (5.44 MB)

@lfb6 Flashed the chip with the Bios with the region you provided and the computer is now unbricked!

I’ve flashed the BIOS to B5 after it via USB Drive and everything works fine as expected now!

Many thanks for all your tips and help, it was a very interessting subject to learn and do!

Good to hear, thanks for the feedback!

You might want to update your ME firmware, too. Lenovo offers (click), but latest is CSME 11.8 Corporate H D,A v11.8.83.3874.

A recent Windows 10 update applied a UEFI firmware update on reboot and borked one of our M900 tiny’s as well.

What was the chip location that you used to repair yours, could you possibly point it out on the logic board for me to save me having to break out the magnifying glass :wink:

Dear All,

I have the same issue. Can someone please upload the dumps of a working machine? The ones above cant be downloaded anymore…

I appreciate any help!


Dump your own bios and attach it. Updates will normally not destroy other regions than bios region, it might be possible to recover the original firmware.


windows 10 brick my M700 Thinkcentre Tiny, when i reboot screen stay black no bip, fan cpu on.

i try with no result :

-clear cmos

  • iso burned to cd with recover jumper procedure

i find on motherboard chip W25Q128FV, i backup it, but i don’t have knowleage to fix it.

anyone to help me to fix it ?

backup chip

Try, last efi volume in bios region was begun updated.

W25Q128FV M700rec.zip (8.7 MB)

1 Like

thanks for your help, i burned your repair file, it didn’t start right away, i tried a clear cmos jumper, i got the beeps :slight_smile: it’s alive.

and i updated with the previously burned dvd for bios recovery.

I remove the chip again and make 2 backups of the new bios, I disable the option for windows to update the firmware in the bios

Thank you for helping me, you took a thorn out of my feet :slight_smile:

1 Like

Thanks for the feedback :+1:

1 Like


I have Thinkstation P350 Tiny, when i try to update bios using bootable cd image, it seems to bricked my machine. Power on for several seconds and then shut down.

could anyone help me??



When using CD boot image, did you move the CMOS/Maintenance jumper to recover mode?


EDIT: Then all that remains is SPI programming by CH341A or similar programmer.
Corrupted SPi should be dumped anyway and you gonna need a full dump donor image

tried already, no luck