Lenovo M93p Tiny BIOS dump request


I have surfed and learned from Win-Raid for a very long time(Thanks guys for a lot of best stuff about BIOS modding). Today, I am encountering an issue and I decided to register and ask for help.

I have a M93p Tiny, model 10AA. I am trying to whitelist my network card for it. I have dumped the 2 BIOS for backup using CH341A and SOIC8 Clip. Then, I am using the UEFI tool to modify the BIOS. After several trials, I suddenly deleted the original BIOS backup. I have tried to recover the backup files from disk but got no luck, they have been overwritten by my wife’s pictures (LoL).

Therefore, I would like to ask if anyone here has a m93p tiny, could you please help me dump the bios (this M93p tiny has 2 bios chip, one is MX25L6473E which is 64Mbit, the other one is MX25L3273E which is 32Mbit). It would be much appreciated!


I have grabbed the bios dumped of someone else on the biosmod forum, clean the Intel ME following this guide: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Then, I have desoldered and programmed the 2 chips and confirmed that the data is written correctly. However, my M93p is not booting. When I power up, the power light flashes very fast and off. The CPU fans is spinning and nothing else happens.
Anyone has any idea about this? Thanks.

@johnprinceton - Hopefully you dumped both of you chips, and it’s a valid dump, before you erased and wrote anything to the chip. Otherwise you’ve lost your serial, UUID, windows key etc, and possibly LAN MAC ID too
Ohh, sad to see you did, but then tossed the files!

This is split 12MB BIOS system, you have to dump both chips, append the files, then edit, then split and program back. You cannot edit or program just one chip because the split happens right in the middle of a compressed BIOS volume.
Please link me to the thread where you grabbed this dump, so I can see what they are discussing and how it was dumped etc. It may not be complete BIOS file that you need, or you may have done the ME FW stuff wrong, or you may not be splitting the file correctly etc

* Edit - You can try BIOS from post #18 here, or from post #1 or #2, depending on which board version you have IS8XT for #1 files and IS8TX for #2 files. You will have to pay for one day access

Is this what you used?

From #17 - https://www.bios-mods.com/forum/Thread-R…53307#pid153307

If yes, you need to append those files first in hex editor (8MB first), then edit, then split back

There is also this dump you can try, post #40, split the files first 8MB first half and then 4MB rest


Thank you very much for your completed answer. I would like to describe more about the situation:

- About the old BIOS dump: I have dumped both of the BIOS but the dumped files are deleted accidentally.
- I know that I have to dump both chips and join the 2 dumped files and edit them then split it back. But the PC is still not booting.
- Thank you for your reference link to vinafix. My version is IS8XT but it seems my IC chips are different. The dumped files on vinafix are named after W25Q64 but my IC chips are MX25L64 and MX25L32.
- There is also this dump you can try, post #40, split the files first 8MB first half and then 4MB rest => These are exactly the dumped files which I am working on. I have attached the file that I have joined and removed the ME below. If you have free time, I would much appreciate if you can take a look on it for me.
- Otherwise you’ve lost your serial, UUID, windows key etc, and possibly LAN MAC ID too => I didn’t know it yet :D. Now I have lost all the old dumped files. I am not running Windows but Linux so no Windows key is lost. But if I lost serial, UUID, MAC ID, will the PC still boot?

Thank you.

Here is the files I got from bios-mod and I am working on it to remove the ME.

If you have any free time, please help me take a look on it. Thanks!