Lenovo P70 ME SPI lock failed, reboots instead of loading OS

Lenovo P70, (model 20ES S1RH00 6700HQ, M600 Quadro) works like a dream, when it boots, but I need to recover the BIOS or ME section, or do an ME delete, whatever will work. I have CH341a and know how to use it.

It will not even load the diagnostic tools, Win10 Install USB, Linux Mint live CD or Lenovo BIOS flash ISO on a CD-ROM. It gets to the point the OS would load and then just reboots.

I can see the BIOS settings, change them, but no OS load. I have tried 2 different good memory sticks, and it was booting until I tried the ME update tool for P50 P70. this is the ME version that shows in the BIOS screen now.

The Story:
I got a “broken” P70 for a good deal, in very nice condition, had battery, 4k screen, even a 16gb RAM chip.

It would only boot if I manually selected the NVMe drive, never would boot automatically or with the “Windows boot manager” Sometimes would quickly display an ‘me Spi lock failure’ message, I did not capture this message, as it did not show every time and I didn’t think to video it.

Reading around I tried the latest 2.40 bios and the ME updater tool. The 2.40 Bios from Jan/2022 PC still worked, but only boot by pressing Enter/ f12 and choosing my NVMe Drive. I tried the ME update, which claims to have worked, but upon reboot no OS will load at all, not even bootable BIOS flash CD.

Edit: I took a picture of the BIOS Screen when it booted the first time, looks like I had a blank ME section, EC version of 1.17 and was on BIOS 2.24. Now am on EC 1.18, ME like I said above, and BIOS 2.40

If a system has a broken ME FW image, no bios update or ME update will fix it.
Repair the ME

Thank you, I followed the guide and rebuilt the BIOS with the ME image from the link.

Intel Fit threw a window up so I chose Boot Guard level 0 (It was Level 4 FVE). I am not excited about secure boot, so it should be fine.

I am not sure if the BIOS was the fix, or loading the default values (which I obviously forgot to do before).

Either way it is up and running with a $25 “broken” M4000m and a $50 Aliexpress 00ny300 heatsink replacing the joke of an M600 Quadro.