Lenovo ThinkCentre M90z problem: - ME N/A - Shuts down after 30 minutes - No MAC address - Fans 100% spin

I flashed BIOS with firmware from post #29. The PC started from the third attempt, but even then it restarts after 10 seconds of working, so I can’t get into BIOS. The fans are running on full speed.

I’ll try to run my bios through the guide, but I’m not sure that I’ll be lucky in my attempts

There is still something wrong with the ME Region.

Try these, they have the correct MAC address now:
sawfly_macDT.zip is same file as sawfly_clean2 but with correct MAC address
sawfly_macMB.zip is same file as sawfly_clean but with correct MAC address (this worked for your but fans still 100%)
sawfly_macMB_FPTchecksum is same as sawfly_macMB but with the FTP checksum value modified. (this is a part of the ME region)

The original poster had the DB SKU, so I’m not sure why the DB SKU ROM didn’t work (sawfly_clean2) maybe I patched it wrong.

The original RGN’s I used from the repository were: (I noticed this is one is larger sized)

I was unable to find any RGN .BINs for

Also remember there are two 5MB SKUs, I’m not sure which SKU firmware update you downloaded which gave you that SKU mismatch error and which firmware you had.
There are DT and MB SKUs for that that you tried to flash.

sawfly_macDT.zip (3.72 MB)

sawfly_macMB.zip (4.3 MB)

sawfly_macMB_FPTchecksum.zip (4.3 MB)

nikey22, thank you for the firmwares!

I flashed them one by one, here is the result:

sawfly_macMB_FPTchecksum - ME version is N/A in BIOS, both fans (cpu fan and power supply fan) are running on 100%.

sawfly_macMB - ME version is OK, MEinfo works normally. But fans are running on 100%. I performed -greset, I tried to start PC with ME jumper on, I turned off AMT in BIOS - the fans are still running on 100% of speed. I tried to flash ME with the original firmware from lenovo support centre, but I got error 8704 - SKU mismatch.

macmb  clean.jpg

sawfly_macDT - the fans are still running on full speed, ME works normally: ME version presents, MEinfo works normally. I performed -greset, I tried to start PC with ME jumper on, I turned off AMT in BIOS - the fans are still running on 100% of speed. I flashed successfully ME with the original Lenovo firmware (see screenshot) and flashed BIOS - the fans speed doesn’t change in bios/dos nor in Windows.

macdt after me update.jpg

It seems to me that with sawfly_macDT ME FW works as it has to, but the problem with fans is present.
I really got no ideas, what else could it be?

Fans may always run 100% if jumper on, usually that would disable ME FW too, but seems you can detect it. Are fans running at full speed without jumper?
Does your BIOS have a fan speed control setting, that maybe was accidentally set to full speed? This probably due to stupid QST part of ME FW, it’s a mess, and I see this is only thing that controls fan speed in your BIOS setup settings… So probably QST Config missing in the ME FW you flashed in
There is a huge thread about that here somewhere, and if you find it, you can PM the guy who we were talking to it about, I sent him all the QST tools and PDF’s etc, and he figured it all out on his end. So, I’m sure he can help you with making a QST config file for your ME FW

If jumper is on, first 10 seconds when Lenovo bios logo is on the screen, the fans are working in silent mode.
Then the fans are start working on full speed and appears error 0135 - fan failure.

There is no mention of fan speed, Intel QST, etc. in BIOS. I can get to Intel QST configuration in Intel me bios extension, but there is only one option - enable and disable. And after changing it to “disable” I couldn’t boot the PC until I disable ME with jumper.

I found this thread (not so large but with the same device and trouble) - is that it? If yes, I have the same one m90z on my work, but I can get dumps from it onle after awhile due the quarantine.

Try to update the ME Firmware now with the FWUpdLcl.exe FW6.1.30.1074.BIN command that you used before. I think the SKU problem should be fixed since you are using the "DT" ROM now.
check the file "FW6.1.30.1074.BIN" with MEA and see if it truly shows a "DT" SKU.


nikey22 , thank you!

Yes, I can successfully update the ME firmware. I have updated up to from Lenovo official site.
Both and show "DT" SKU.

ME analyze.jpg

So the only trouble left is 100% fan speed

@sawfly - yes, that was the thread I was thinking about. PM that user and ask him to send you the tools and PDF, and then ask if he will help guide you or tell you how to create file and fix what you need.

Lost_N_BIOS, thank you for your advice, I’ll try to contact ADAMK101 and solve this annoying trouble.

Thank you all very much for your helping!
I’ll keep you in touch about it.


I am in the game again :S When @nikey22 helped me, the PC worked as well. Although when it went to sleep mode, it couldn’t come back again. I used Windows 7 on it.

A couple of days ago, one of my relatives used it. I think he switched off with power button instead of start menu procedure. On morining he tried to turn it on and it showed something. After it he switched it off and it showed blank screen.

Now when I switch it on, green led is on, fan works normal, but nothing else. No sound, no screen, nothing. When I take out the memory module, it start to beep. When I short ME pin, fan spinning 100%, but no sound and it shows blank screen.

@nikey22 I promised that I share bios file to you but I forgott :frowning: Sorry.

So my Lenovo M90z is dead…

good day sir, i have the same model AIO pc and i have had the same issue since 2019, 30min shutdown,no MAC address,ME N/A, fan runs at full speed, in 2020 i tried flashing a new bios i downloaded from the internet and my computer went blank, i could only use it as an external monitor, later yesterday 12th july in 2022 i manged to repair the Pc by changing a capacitor on the Vcc core Supply, and reprogramming the bios chip with files i downloaded online…so now the machine turns on , but the same problems are there…30 min shutdown and fans runs at full speed,no mac address and me is still N/A… Please help

That problem has stayed there because its no HW issue, so your repairs wasnt suppose to repair it.
The ME must be cleaned/reset…as you can see in this thread, its a resident FW image on the motherboard, guide here:https://winraid.level1techs.com/t/guide-clean-dumped-intel-engine-cs-me-cs-txe-regions-with-data-initialization

thank you i will try to clean the me region. but how do i get the mac address , and serial number back.coz i have even lost the old original bins, i only have the printed figures now

Valid/Part corrupted dumps or OEM stickers on the chassi/motherboard, other than that…not possible anymore.

i have the details on the covers , any software i can use to put them in the bios file

Some details may be edited in bios…or part or none, but theres tools from Lenovo for it, search it on forum, Lenovo and around the web.


I managed to repair my machine it doesn’t shutdown anymore. But I can’t install video drivers.on any Os 7 to 10 any help is appreciate

“Cant install a driver”… “and fails on ALL OS” …dont you think thats a bit vague to understand whats happening when youre trying to install… should we guess what steps and error messages you get???

EDIT: And what is the package driver your loading? Intel cpu iGPU or PCIe GPU?
“Sam driver” wtf is that?
A failure like described can happen if the chipset (Q57) has an issue and/or iGPU vrm offended, if iGPU used.
Is the PCI ID of the device correct on the device manager?

When I try to install the drivers , installation will run until it finishes, then it request for a restart once I restart the machine it will get stuck on the windows loading logo for about 3 to 5 minutes then when the desktop appears drivers won’t show on the properties or in the device manager…the Os will just be using the basic display driver…I have tried to use the driver pack and Sam driver, official Lenovo graphic drivers still no progress