Lenovo ThinkCentre M90z problem: - ME N/A - Shuts down after 30 minutes - No MAC address - Fans 100% spin


I am new here and I have a big problem. I have a Lenovo ThinkCentre M90z All in One computer (Machine Type: 5205 Modell Number: E3G S/N: S4HZ517). There is problem with bios/Intel Management Engine I think… I tried to slove the problem, but I couldn’t :frowning: I have spent many many hours, but it’s complicate problem for me. If anyone could help me, I would be grateful.

So the symptoms:
- shut down at exactly thirty minutes;
- fans spin 100%;
- ME version is N/A in BIOS;
- MAC address is not available in BIOS;

I downloaded tools from this URL and I started to use “Intel ME System Tools v6 CCK r1”: https://www.laboneinside.com/tag/how-to-…egion-software/

I updated newest BIOS too, but it didn’t help (“flash” and “ec” command): https://download.lenovo.com/ibmdl/pub/pc…s/9bjy42usa.exe

The previous owner doesn’t know what is the problem, what happened with computer.

1) I used “Flash Image Tool” and I dumped bios.
2) I tried to analyze outimage.bin (8192 KB), outimage(1).bin (4096 KB) and outimage(2).bin (4096 KB) with ME Analyzer but it said “File does not contain Intel Engine firmware”.
3) I tried to dump bios with Intel Flash Programing tool (fpt -me -d me.bin) under DOS but it said “Flash Descriptor: Invalid” and " Address 0x0000000 is not within any region." and “Error 26: The host CPU…”. I have a “ME_DISABLE” jumper and I tried once open and once short jumper but same result was.
4) I tried to use MeInfo under DOS but it said "Error 9255: Fail to read FW Status Register value 0xFFFFFFFF.

Fail to read FW Status Register value 0xFFFFFFFF.JPG

firmware update.JPG

fpt -me -d me bin.jpg

fptw under windows.JPG

me analyzer - outimage.bin - doesnt contain IE firmware.JPG


Thank you and sorry for my bad English.


Why did you choose that version ME Tools, vs the other V6 one? Do you have one of these systems in running order? If yes, please confirm what ME FW version is on it.
Flash Image Tool does not dump BIOS, this only creates BIOS files.

Do you have flash programmer? If not, please put on ME Jumper, then use FPT (from inside Flash Programming Tool folder), then run this command and send me the file it creates >> FPTw.exe -d SPI.BIN
If you do have programmer, find both chips and dump both, name them to something so you know which dump was on what chip.

I checked the ME FW downloads for this system, and you need to use this package, from section C at the link below >> Intel ME System Tools v6 IBX r2 - (2018-02-09)
Intel Management Engine: Drivers, Firmware & System Tools

Since ME FW is currently corrupted, you can only FPT flash the ME FW, but DO NOT use the ME FW they provided as it’s blank/not setup for this system, it’s only meant to be used with FW Update tool (which you cannot use)
I will make you new ME FW and show you how to flash it once you send me the SPI.BIN dump i requested above.

Thank you for your reply and help. I don’t know why I choosed this version ME tool… I have just this pc. I don’t have flash programmer.

I downloaded and used Intel ME System Tools v6 IBX r2 - (2018-02-09) package.

It wasn’t succesfull. I tried on Windows 7 and on DOS what you told me. There is a “ME_Disable” jumper, of course I tried open and close state too. So it was four attempt…




In windows, you must run FPT from a Admin CMD prompt, you cut off the window so I can’t see if that is Admin prompt or not. Please be sure it’s Admin prompt, or use DOS.
Also, that jumper looks small, be sure you are using a jumper small enough to contact both pins securely, maybe one from old HDD would work best.
Then with jumper on, reboot twice, then do the following three commands and send me all files created >>
FPTw.exe -desc -d fd.bin
FPTw.exe -me -d me.bin
FPTw.exe -bios -d biosreg.bin

Yes, I always run power shell with administrator privilege. When I open or short the pin, I always shut the computer down and disconnect the power cord.

I have a lot of jumper somewhere… So I did the following:


It is under DOS:




It is under Windows command:




I send you the bios settings too:




I hope it’s possible to repair… :S


Always show: "Address 0x00000000 is not within any region."

There is an almost same case, same PC from Alcoholic user, there are dumped bios, maybe could it help? Broken Intel Management Engine (2)

don’t run powershell; only use administrator MS-DOS.

Your flash descriptor is invalid. Look at the screens you uploaded, they all say “invalid”.
location 0x000000 is the base of the flash descriptor, it can’t read it.

I can see the EC chip in your picture, the BIOS chip is underneath your fan. Both will be printed on the motherboard “EC” and “BIOS”. They are right beside each other.
Get a SPI programmer + SOIC8 clip.

@nikey22 - Thanks! ^^ Right, this must be done from Admin CMD Prompt ^^
@bszabii - I can’t tell from those images, does that say “Admin” at top left corner of CMD prompt? If yes, then good, that is Admin CMD prompt [wink

To short the pin, put jumper on there, then boot to system (Windows, or whatever OS), then shut down, then reboot back to system to do the FPT stuff

I can help you fix BIOS with programmer, or FPT maybe, but you have to dump first with either, and it must be possible to dump with FPT or you can’t write either.
Other users BIOS will make you loose your serial UUID and LAN MAC ID etc, so we need to use yours, but none of that matters right now since you can’t read/write with FPT anyway.

Alcoholic users case is not same situation you are in, his FD was not messed up, so he could read/write with FPT.
I think you will need flash programmer as mentioned above, I can’t think of any other way you can fix this. We could blindly try to write new FD with FPT, but since current one is messed up that may break the BIOS worse than it is now.
I would not advise this until you have programmer in hand and confirmed OK dumps made from both chips.

@nikey22 - Thank you for your helping too. Sorry for my mistake, I tought Admin commander, not powershell. It is Admin CMD: Rendszergazda means Administrator. So no other solution, only SPI programmer? :S

@Lost_N_BIOS - Thank you again :slight_smile: Ok, I will buy a programmer. Do I need to buy new SOIC8 chip or could I use old chip? It is necessary to remove chip(s) from motherboard? What do you think about this: https://www.vatera.hu/soic8-sop8-program…2798295851.html I think I need this too: http://caxtool.hu/aa182_ch341a_24_25_ser…driverrel_19791

Could you help me to chose devices from this page? http://caxtool.hu/elektronika/programozok

Last question: I read about “pinmod”. What do you think? The audio chip is Realtek ALC269Q-VB2 (Realtek High Definition Audio).

I have already ordered the following items:
- CH341A SPI Programmer/Flasher
- Soic8 Sop8 Flash Chip Ic Test Clips Socket Adpter Bios/24/25/93 Programmer

I have found this guide: [GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)

You need to look at your motherboard and find a MAC address sticker if you can and write down the MAC address.
I noticed you scribbled out the UUID in one of your pictures. The last part of the UUID is actually your MAC address, so hopefully it is there, please check?.
You will need a Gbe region with the MAC address entered into it.

Like @Lost_N_BIOS said, a new FD region can be written using FPT -desc -f desc.bin, but it is risky without the flash programmer.
You could use the descriptor region from Plutomaniac’s SPI dump that he helped Alcoholic with, like LNB said, it is a valid one.
You can also use the GBe region from Plutomaniac’s SPI dump, but you must edit in your MAC address.

@nikey22 Thank you, firstly I try to use programmer device. I have already ordered it.

@Lost_N_BIOS Hi! I have successfull dumped both chips (BIOS and EC). I hope it was successfull :slight_smile: I used CH341A program v1.29 under Windows 10.

BIOS -> Winbond 25Q64BVSIG 1127 - 201911212305_w25q64bv_bios_read.bin - 8 388 608 byte
EC -> Winbond 25Q16BVSIG 1120 - 201911212257_w25q16bv_ec_read.bin - 2 097 152 byte

How could I send you two files?

Thank you for your help!

@nikey22 Do you know what is the next step :slight_smile: I duped BIOS and EC. Thanks!

@Lost_N_BIOS I attached files:

flash-ec-and-bios.zip (3.82 MB)

Thank you!

Looks like UEFItool is not parsing the SPI dump file properly, I don’t see a ME region there. I think its inside “padding”, because I recognize some elements of the ME region there.
Do it again, this time dump the same file 3 times, and compare each file with HxD to make sure they are the same.
label it bios1, bios2, bios3.
If they are all the same, then for sure you have a corrupt ME region as well as a corrupt DESC region, and it will need to be rebuilt.

Also, try version 1.18 for the CH341a_spi flash program, for me, this is the only version that seems to work reliably, experiment with different versions.

Leave EC chip alone for now.

@nikey22 Thanks, I tried CH341A Programmer 1.18. I dumped the bios three times. Always run the program admin rights, after the read finished I used verify too. It always showed "Chip and buffer same!". I dumped once with 1.29 too, and this file equal the others…

So I compared files each other(three files with 1.18 and one file with 1.29), HXD alwasy said "The chosen files are identical.".

I attached one file:

bios2.zip (3.8 MB)

It is possible to repair? :S :frowning:

before you do anything, see if you can hardware flash your dumped file back into your machine normally, just to make sure it is possible and you are comfortable with it.

Once you have proven that to yourself, then try this file. I think the problem is in the desc region. I’m hoping the ME region is actually ok. We’ll see
Your MAC address is present and intact
Your ME version is :

bios2fix.rar no checksum fix
bios2ch.rar is with checksums repaired

bios2fix.rar (3.68 MB)

bios2ch.rar (3.68 MB)

@nikey22 I used this guide: [GUIDE] Flash BIOS with CH341A programmer

Now I am writing back the dumped bios file.

One queston: which file do I use? bios2fix.rar or bios2ch.rar? (I think I have to use bios2ch.rar file)

Thank you!

@nikey22 So I flashed bios2ch.rar back. After it I started the computer. Abut two or three times the computer started but inmediatley shut itself down (fan not spin). After it the pc started. I entered into bios and I saw MAC address :smiley: It is a good sign :slight_smile:

But ME Firmvare Verison is still showed N/A. It is ok?

I set the clock, I enabled ME after I restart. I tried to use Ctrl + P, the PC showed me fan error. After it restarted, but it tried several times to restart, finnally started and fan is spinning but blank screen :frowning:

I will try the bios2fix.rar bios…

Thank you!

@nikey22 You are genius :slight_smile: With bios2fix the pc started normally, I see MAC address and ME Firmware :slight_smile: Fans work normally.

Are there any steps that I have to do? For example update bios to a newer, disable AMT controll, ect. Of course I don’t want to use AMT…

What was the problem?

How could I promote/donate you if it’s possible? Because if you didn’t help me I couldn’t slove the problem myself… :frowning: :S