Looking for a cheap mainboard with Aptio V for i7 8700K


I’m currently trying to patch several information for my bachelor thesis on a Z370 D3H motherboard. I’m using DMIEdit for Win x64 5.21.0057

Overwriting information like Product Name, Version, Manufacturer et cetera work perfectly fine, however the UUID resets itself on every reboot to the original one.
I suspect it’s derived from somewhere or restored from the backup bios?

So yea, I’m just looking for a way to make the UUID persistent, or for a new mainboard where I can patch the SMBIOS as much as I want, especially the UUID. Any recommendations?

Kind regards

Find it via hex, replace all instances then program back. UUID is generally not populated with valid data from Gigabyte, so you can ignore if you want.

In this case it seems like there valid data in the SMBIOS UUID. I’ve tried to set a new one using AMIDEWINx64, however after a restart it just resets itself to the old value.

I’ve also dumped it and looked into it with a hex editor, however I couldn’t find the related part. It looks to me like it is derived every time from somewhere else, I never had such an issue with any other mainboard. If you want, you can take a look at it by yourself:
The uuid it resets itself to: "E0 9B D5 57 5E F0 48 11 3F 09 6B D8 02 0C 09 03"
Current bios (Z370MD3H.F10): https://aggressive.pizza/u/2018-11-24_20…-Lcont-9dd2.F10

It’s just strange to me that I can edit the rest of the data such as product name, version etc without any problems using DMIEdit or AMIDEWIN and it stays persistent, but the uuid resets itself after each and every reboot.

In this one case, of all the 1000’s of Gigabyte BIOS I have looked at? I doubt that, more likely this is non-related or invalid data making you think it’s UUID, this is why it’s not changeable too, it’s not what it appears to be. The rest remains as you set because they are valid (not used, so ignored)

I will check BIOS and see what I can find.

*Edit - DMI data is at GUID - DAF4BF89-CE71-4917-B522-C89D32FBC59F (SMBiosStaticData), and is all unpopulated as I expected (DefaultString used, usually this is left or 0123456789 etc, since Gigabyte does not utilize these for serial or UUID ect)
I cannot find the string you mentioned, E0 9B D5 57 5E F0 48 11 3F 09 6B D8 02 0C 09 03, it may be in your board BIOS only and would need to be located from a BIOS dump. Please dump the BIOS with FPTw, BIOS region only is fine, it should be in there.

FPTw & FPTw64 both fail with the following reason: "Error 201: [FPTw.exe] cannot be run on the current platform. Please contact your vendor."

I just used the backup bios function of the bios itself, I hope it’s sufficient: https://aggressive.pizza/u/2018-11-24_21…tisray-7d7d.bin

Thanks for your effort btw :>

Yes, you have to get the correct version of FPT for your system, matching ME version (11.8), and Intel ME drivers must be installed too (Get those from Gigabyte download page)

FPTw.exe -d bios.bin

I checked the above file, nothing found there either not even in the full populated NVRAM of this file vs a download, this isn’t going to be found since it’s not used. The tool you are using it showing you incorrect information, not a valid UUID

Instead of using DMIEdit from American Megatrends I just compiled the following tool: https://github.com/KunYi/DumpSMBIOS

It shows the same UUID after each PC restart: https://aggressive.pizza/u/explorer_2018…thworm-a78c.png

However, if I use AMIDEWIN64 from American Megatrends and assign a new UUID, the upper tool shows the same new assigned UUID: https://aggressive.pizza/u/cmd_2018-11-2…ckbird-1755.png

It’s just not persistent for some reason. It gets resetted each and every time I restart my PC. I >need< to fill that specific string with a custom value which needs to be permanent though.
I don’t really think that it’s incorrect information tho, since multiple tools always show the same UUID.

As you can see with your app too, none of that is populated, this is not something gigabyte uses. AIDA64 shows me my UUID is 00020003-00040005-00060007-00080009 on a Gigabyte board too, but I know it’s invalid, not used, not UUID etc.
I assume you might find that same string on yours in AIDA64 (Computer, summary, at the bottom).

I don’t mean it’s incorrect info, I mean it’s not valid or used UUID info by Gigabyte for ID purposes. If you really want to change that and need to do so permanently, get a programmer and force the change, or you can try via grub/shell

Can your tool tell you this strings exact offset in the BIOS?

Opps, just realized I posted in the wrong thread…meant to post in the other thread for nvme mod.

AIDA64 is showing the same UUID, I assume it’s legit.

May I ask what mainboard you have if you have such a placeholder UUID? I rather get a new mainboard which supports patching the UUID / has a placeholder UUID than spending more time on it.

E: I already tried to edit it with dmicfg from DOS. Same issue as with every other tool: the uuid resets on reboot.

Part of that is your LAN MAC ID e0 d5 5e 48 3f 6b 00 08 (every other digit) / What is this boards serial, maybe these are combo of LAN/Serial?

Maybe it is legit, and since Z370 Gigabyte started using UUID now? If so, it should be changeable via programmer or FPT BIOS flash, but we need to find the location in BIOS first.

Sorry, forgot to reply about board with no UUID like mine. This one is Z87, but I’ve seen this always for Gigabyte since 965P-until today with your Z370, serial has never been stored in BIOS either only LAN MAC ID.
I have not looked much at Z270/Z370 to notice if all still same as before, maybe Z170 too. Maybe they start this at Z370, or possibly Z170 too I’ve not checked.

I might be overlooking something but I don’t see the LAN MAC at every second digit in my UUID.

4719331802349 | SN175150020358

I’ve contacted the support of other mainboard manufacturers as well (only MSI answered so far); their answer was the following:
“Regarding your concern, about the UUID and S/N information in BIOS, we are really sorry, these information can not be filled by user.

About the MAC address, in theory, if you have an available MAC address, you can flash the MAC address by some tools, but every motherboard has an address, we don’t recommend you to change the MAC address.”

E0 D5 5E 48 3F 6B, maybe you don’t see it? I do, check image showing MAC vs every other letter


E0 9B D5 57 5E F0 48 11 3F 09 6B D8 02 0C 09 03

Well, it’s not a mix of EAN or serial + LAN, not sure what the other characters are, often it’s LAN+Serial or some combo of the two

What does MSI, or other manufacturers have to do with Gigabyte BIOS?

Nothing really, just trying to find another motherboard with the same chipset where the change of the UUID actually works.

Asus should be one this works with. Gigabyte too where you are doing, but seems like your current tool does not work properly, you can either do this with flash programmer (hardware, $3-8) or by using Intel FPT program.
If you change it in BIOS file and flash in with FPT it will stick I’m 99.9999% sure of that. Did you ever figure out how to make your tool give you the BIOS offset/location that it pulls this value from?
If you can get that value I can surely locate in BIOS dump, I’m not sure why it’s not easily locatable via normal search methods, I tried several tools and one that looks inside compressed modules as well.

It querys GetSystemFirmwareTable from the Windows Sysinfoapi. So, no, unfortunately I am not able to get any offset or address where it gets the values.
I’ve tried several tools already, and if I’m not wrong, the one I’ve used are designed for the specific BIOS I have. (American Megatrends Aptio 5)

I’ll look into the flash programmer tho, thanks for the tipp.

E: flash programmer looks like too much effort. I’ll try to find the address(es) in the following days using another method.

Flash programmer is simple and cheap, you’ve already put in more effort here than it takes to use those tools.

I will keep looking too. I know it’s combo of MAC + Something, Asus uses serial + MAC or DTS Key + MAC.
Maybe asking Gigabyte directly (MAC + What?), or which module it’s stored in, or for some/any info will help find a solution?