Looking For A Modded Bios For An Asus Maximus VI Extreme

Hey all,

First time post but I’ve been using the guide found on win-lite.de for years now.

I upgrade my rig back in June to a Core i7 4770K, currently running at 4.8GHz. Only problem is it comes with an older OROM then what I had modded my old Maximus V Extreme too. After reading the old thread and finding out a new site had been created I attempted to use the guide to mod bios 1203 for the Maximus Extreme with the OROM of But I’ve had no luck, I attempted to use the EZFLASH Utility and the USB flash method as described in the bios. Back in June I attempted the same thing with a 12.7 OROM but got a message that it was not an authentic bios or security error and I gave up.

Is there a site or is it possible that someone can link the latest Bios for the Maximus VI Extreme with the latest Intel OROM for Raid? I know once on station drivers there was a guy modding every bios as the OROM was released but I can’t find the link anymore.


@Hapatingjaky :
Welcome at Win-RAID Forum!

You cannot flash a modded .CAP BIOS file by using EZ-Flash, but the USB FlashBack method should work with your mainboard.
Maybe you forgot to rename the BIOS file according to ASUS’ FlashBack rules.

Why don’t you just flash the original ASUS MAXIMUS VI Extreme 1203 dated 01/03/2014? It contains the Intel RAID ROM v12.7.0.1936.
By the way: I do not recommend to flash the Intel RAID ROM v13.1.0.2030 as long as there are no final IRST drivers v13.x.x.xxxx available.

As far as I understand your report, the problem is not the modification of the BIOS, but how to get the modded BIOS flashed. If I am right, any BIOS modification done by anybody else wouldn’t really help you, because you may not get it flashed into the BIOS chip of your mainboard.

Enjoy the Forum!

Thanx Fernando, I was used to the old way and I tried the new tool that you’ve provided but couldn’t get it updated with either the USB Flashback or the Asus EZ Flash. I’ve since given up and just flashed the latest 1203 bios and installed the beta 13.x RST driver, I am used to using beta’s don’t really care as everything I need is on QNAP NAS.

Which name had the modded BIOS, when you tried the USB FlashBack method?

ME6.CAP. Both USB Flash Back and the Asus EZ Flash 2 gave me an error of Security Verification or Validation failed.