Looking for Intel / /C216 AHCI "uefi module" for my MSI Z77A-G43

Hello friends, i’m new here to this great forum!

i successfully modified my MSI Z77A-G43 bios to integrate the nvme-dxe module, so i can boot from my wonderful new SM961 pcie SSD and it worked! Thanks a lot for this!

Now when booting in UEFI mode, i cant access my SATA drives, which is a bit bad since UEFI mode boots so fast.
When using Legy+UEFI mode, i can still boot, and get the SATA drives to appear.

So my question is - and i didnt find out by browsing the forum and googling - is there a UEFI module for my “Intel(R) 7 Series/C216 Chipset Family SATA AHCI Controller” that i could try integrating like the nvme module and then have both kind of drives available in UEFI mode?

That would be great!

I dont use RAID, btw.

@calav3ra_de :
Welcome at Win-RAID Forum!

No, there is no such EFI module available, but on the other hand the Intel 7-Series SATA AHCI Controller neither needs nor uses such EFI module.

Dieter (alias Fernando)

Fernando, thanks for your answer.

I wonder how to get my SATA/AHCI ssd’s to show up, then. I cant see the devices/controller in the Windows Device-Manager and there is no unknown or problematic device either?

Have you already tried to insert the SATA cables of your SSDs into other SATA ports of your mainboard?

I am so sorry.

It works now in UEFI mode. They are visible under windows. No change needed at all.
Weird. I swear there was no controller, no driver, no drives anywhere.


Thank you, though, Fernando!