Looking for Thinkpad X1 Carbon 6th gen working Thunderbolt bin file

Hey as of mid December, my ThinkPad X1 Carbon 6th gen i7-8650u 16GB 1080p started with no HDMI output problem. This happened right after Lenovo Vantage pushed an Intel AMT update.

I had updated Thunderbolt firmware in 2019 and 2020 so all latest patches had been applied as a preventative measure by myself since I was aware that there were some problems with Intel AMT effecting Thunderbolt controller which also messes up the HDMI port.

Also my 2 Thunderbolt ports don’t do display with external monitor either. I have a 32" Thinkvision T32h-20 monitor with USBC Thunderbolt connection with 75W charging and also a USB data hub. USB hub for data and charging work but still no display (tried with multiple high quality USBC Thunderbolt cables which work with other laptops).

No Thunderbolt under Device manager system devices either. Thunderbolt Service has been changed to auto and started.

Different HDMI and different high speed USBC cables, different monitors including an LG 4K display with USBC Displayport, charging and USB Hub, multiple operating systems (fresh win10, fresh win 11, Ubuntu 20 and heck even Hackintosh etc.) and still no go.
I even rolled back the BIOSes to previous version(s*) to test and still no change.
Multiple times I did a hard reset. Paperclip first, then open cover, remove battery, disconnect bios battery. Press power button for longer than a minute to clear capacitors etc.

Both HDMI and USBC display ports were working fully before mid December 2021.

All BIOS settings are correct.

Since the machine is out of warranty I bought anEprom programmer to flash the Winbond chip near the ports. I disconnected all batteries including the CMOS one and pressed power button for more than a minute to release any capacitor curent.

I was able to fill in with 1M nullbyte and reboot (it then starts with a underpowered charger message that I saw for the first time which is expected according to my Internet research) and then second time I flashed the TB.bin file that I downloaded from official Lenovo website version 20xxx which was released on March 29, 2021 according to file properties. There is also an assisttb.bin file of the same size and same timestamp and metadata in the same extracted folder. Later I tried that one too. Neither worked.

The issue is the Winbond 25Q80DV NIG eprom chip is 1M and the TBT.bin file is litlle less than 260Kb. I can flash the 260kb file no problem and the low powered charger message is gone but still no DP through either USBC or HDMI. I am back to where I started.

I can use USBC devices and the machine charges normally (so no damage on either connector) it was the same before the flash.

I tried to “pad” the original Lenovo update firmware tb.bin to 1M and still no go. I used linux and used online tutorial as to how to pad.

dd if=/dev/zero of=tbt.bin bs=1 count=1 seek=1048575

I had to change 1048576 to 1048575 to make sure the file fits to the chip.

After reboot I still can’t see the Thunderbolt under Windows Device manager system devices.
The thunderbolt software doesn’t also show the devices.
I did do all the bios settings correctly.
Did the power cycle multiple times.
I installed the OS drivers multiple times.

My last resource is some fellow X1 Carbon 6th generation owner who would kindly provide their dump of working thunderbolt bin file so that I can flash that to see if it works.

I don’t want to buy a USB3 to HDMI dongle since I still want to be able use 4K output on both connection types USBC and HDMI

Thank you in advance

PS: If anyone from Lenovo who is reading this with some sort of technical knowledge:
I now have the ability and somewhat tech knowledge to flash TB firmware externally. Kindly forward me the working firmware so that I can resurrect my computer (in which I make my living) back to its expected function again. Don’t worry I wont tell anyone… TIA

Hi Johnny!

It may be a little bit late however I’ve read this 1M chip by flash programmer from the same laptop some time ago. If you send me a message I can share this file with you. I don’t think there any secrets inside this flash.

Hi Sergey,
I would appreciate a copy since I am trying to eliminate the source of problems and this bin is one fo them. I will send you my email address via PM. Many thanks and happy holidays.