Lost TRIM in RAID0 after upgrade to Z87

Hello,

I have a RAID0 array with 2 Corsair Force GT (firmware 5.05)

I upgraded my Z68-V Pro / i7 2600k (with RST 12.6 orom/drivers) to a Sabertooth Z87 / i7 4770k (RST 12.7 orom/drivers)


On my old board (with rst 12.6) trim was working (according to trim-check 0.4).
On my new board (with rst 12.7) trim is NOT working.

Any idea?

Should I downgrade back to 12.6?

Thanks in advance,

Remco

edit: just tried with new 12.8 drivers. No trim either.

edit2: Ok… this is weird.

For some reason. now trim-check says it’s working consistently. So I guess i’m fine.

Hello Remco,
welcome at Win-RAID Forum!

I doubt, that TRIM is not working within your Z87 RAID0 system.
The TrimCheck Tool is not very sensitive regarding the detection of a low TRIM activity.
There are at least 2 ways to force the TRIM detection:

  1. Do the manual TRIM check procedure using a Hex Editor according to chapter B of >this< start post.
  2. If you want to get a better TRIM detection by using the TrimCheck Tool, you should send a big amount of TRIM commands into the RAID0 array, before you start the Tool. You can do it either by running the Win8 “Optimizer” or - if you are using Win7 - by running “Anvil’s Storage Tool” and using the “TRIM Trigger” Option of the tool.

I am pretty sure, that you will detect TRIM activity within your RAID after having done that.

Regards
Fernando

It gets weirder…

Now it stopped working again. Even after a reboot. The data is still there.

Tried with anvil trim trigger as well.

edit: Could it be ‘garbage collection’ that is kicking in, instead of TRIM… cause 1 minute after reboot. data is now gone again (0x0 0x0 etc)

edit2: and now it’s working correctly again. Tried 5 times, without reboot. both using trim-check and hex editor… weird. I’ll keep an eye out

As you have verified yourself, TRIM is working within your RAID0 array.
Nevertheless you should keep in mind, that your Corsair Force GT SSDs have a Sandforce Controller, which is extremely problematic regarding the TRIM support.

So I’ve noticed :slight_smile:

Anyway, tx for the help. I guess i’m fine then.