Making Windows 7 64bit working on Dell 5590 (Coffe lake + Geforce 2060) Laptop + Searching for Device drivers

im trying to make booting Windows 7 on Dell 5590 laptop, it has only M.2 NVME slot, so Sata disk is not possible.

I have old installation from previous Laptop, where i had also Windows 7 on NVME disk and i need to port it to new hardware, i already ported it to Virtual machine - where it is booting fine. Cleaned drivers, but when i port it back, im getting Windows 7 boot logo freeze (infinite animation loop) and Safe mode free at classPNP, im guessing that is because of NVME controller driver / chipset driver.

In Windows 10 is this driver:

If exist WIndows 7 64bit compatible driver for this controller i would need it in *.inf file form, because this is only one which could be used with Paragon boot correction tools, where i can inject drivers through some wizard…

Notebook has also:
Intel HD 630 - if im not wrong my old laptop - MSI GE62 7RE -Kaby Lake (Core i7 7700HQ) had it too and it worked.
Geforce 2060 - it has Windows 7 drivers

Killer E2500 lan
Intel Wifi + Bluetooth…
but here in worst case i can use USB one or replace Wifi card… but its not problem of this thread…

It would help to know to which HW is boot freeze related, WinXP had at least some bluescreens, here i dont see anything, but if someone had similar boot free with NVME im on good track.

Bios is set to AHCI mod, only other is RAID… but i dont understand, because it has only one M.2 slot. I had to fix Win10 to boot in Sata mode, because it was installed in RAID mode… and wasnt booting with Sata mode, because Linux wasnt able to see my disk at all.

Some more info, i UEFI /Bios i can disable lots of thing only not Videocards - so i cant select between Intel HD and Geforce 2060, so whole Optimus thing is still active… Only MSI laptop has such option - it was Intel HD 630 + Geforce 1050 Ti.
I disable everything what i could, and i still have some boot problem, so its really probably related too one of these things:
- chipset drivers
- Storage device - most likely
- Videocards

M.2 NVME is WD Blue SN550 NVMe SSD 1TB if this is matters… I also have working WIn10 partition, if there is some way to use it to inject something to Windows 7 parition… its already in EFI mode from old Laptop.

I also can install some drivers in advanced to virtual machine, before copy disk image to physical partition, but im not sure if it helps, if installation of some package will help, if such device is not actually here is virtual machine.

Here are more Hardware iDs:
PCI\VEN_15B7&DEV_5009&SUBSYS_500915B7&REV_01 // Intel NVME controller
PCI\VEN_8086&DEV_3E9B&SUBSYS_08EA1028&REV_00 // Intel HD 630
PCI\VEN_10EC&DEV_2502&SUBSYS_08EA1028&REV_1F // KIller E2500 ethernet
PCI\VEN_8086&DEV_A370&SUBSYS_42348086&REV_10 // Intel(R) Wireless-AC 9560
PCI\VEN_10DE&DEV_1F11&SUBSYS_08EA1028&REV_A1 // NVIDIA GeForce RTX 2060
USB\VID_8087&PID_0AAA&REV_0002 // Intel(R) Wireless Bluetooth(R)
USB\VID_0BDA&PID_5521&REV_8511&MI_00 // WebCam in Windows is using some MS default driver from 2006, so it would be probably compatible, but i need it mainly for microphone…

Here is also HWinfo report for Laptop:
- MB is some Intel HM370 (Cannon Lake-H)

Here are some Fernando Intel drivers, but i not sure it these will help, or not?
Intel RST/RSTe Drivers (latest: v18.30.1.1138 WHQL/v7.0.0.2286 WHQL) (15.3 KB)

Ok some new discoveries.

PCI\VEN_15B7&DEV_5009&SUBSYS_500915B7&REV_01 // Is not Intel Disk controller driver what is thing, this some Sandisk = Western Digital NVME
I though that NVME would have some disc controller devices nice Sata / Padat disc, but it seems that its works other wise and there is not "mother" controller device, but only NVME device, which probably has controller integrated… So i need SSD disk WD Blue SN550 NVMe SSD 1TB Windows 7 driver if exist, or some univertal Win 7 NVME driver, when i set Vmware virtual to NVME boot, its booting, so Win7 NVME boot drivers are installed… but its not working when i close partition to physical machine.

I also find out that there is still some Sata device, which has not connected device, or visible ports when i opened NB, but device is there… and it could maybe block booting its:
PCI\VEN_8086&DEV_A353&SUBSYS_08EA1028&REV_10 // Intel(R) 300 Series Chipset Family SATA AHCI Controller
DEV_A353 was device which was typical for Z370/Z390 desktop boards and i made it working with WinXP + Win 7… I only dunno if SUBSYS matters and it will work out box with Fernando Intel Sata drivers, or it needs some modifications?

Here is Windows 7 boot log, it looks that drivers loading is looped… so could be something with unavalaible boot drive…

ntbtlog.txt (955 KB)

Ok, i won somehow… there is magic Legacy settings in bios and with that it Windows 7 is now booting even from NVME but there was some warning about Windows 10 booting and… Linux which is installed in EFI mode now getting black screen on logon screen (fixed problem was elwhere i really hate that Linux fstab is not seeing device problem handling… especially with combination with partition softs which are changing pariition ids during resize - im pointing to you Minitool)
Solution is switching EFI settings on / off depends on booted OS, but its lame… and there eve not bios profile settings like on proper EFI desktop boards…

When i tried to set thing up and comeback to normal boot not legacy settings, im still getting that boot logo freeze, so Bios magic is needed, or Windows 7 would need some fix, to boot in full EFI mode which is avalaible on these Notebook.

LAN is ok, now i have classic problem with some missing drivers:
- main Nvidia made shortcut and Geforce 20xx si supported on Windows 7, but only desktop ones, when you select its online driver selector and select Mobile Geforce 20xx only Windows 10 driver is here :frowning: So its dead end or some workaround needed. I also have to make working Intel HD 630 what is same as on kaby lake, but dont have old driver, which i used years ago make it working. If Nvidia will not work and Intel HD will, its good enough for work, but not for gaming… and i would like to game on WIndows 7 too.

Details are here:…comment-1191520

I made special thread for videocard drivers:
There not Geforce RTX 2060,2070,2080 Laptop/Notebook drivers for Windows 7 64bit, official drivers are for desktop only! Mod needed.

Geforce is working, so i really need somewhere to get that Canonkong moded nvidia usb 3 controller driver for Windows 7… and after that only Goodfix finger print driver is missing.
USB\VID_27C6&PID_530C&REV_0100 So far i wasnt have to find some driver, willing to install for it, maybe some inf mod is also needed, but i dont know anything about Finger print reader, is is Goodix only some need branding, or some Dell only stuff etc…