Marvell Avastar Wireless Composite Device/350n Wireless Network Controller Driver for Windows 7

Hi, I need Marvell Avastar Wireless Composite Device/350n Wireless Network Controller drivers for Windows 7 as I had recently installed Windows 7 on my Microsoft Surface Pro that originally had Windows 8. I had tried to find drivers that would work for Windows 7, but I couldn’t find any drivers for the device as all the other drivers only work with 8, 8.1, and 10. The device IDs are: USB\VID_1286&PID_2043&REV_4000 and USB\VID_1286&PID_2043.



Extract the ZIP and install manually.

The Microsoft Windows Catalog has ur device, try the CABS.
Not many but some Win8 and even 10 drivers can work in windows 7
Is this? a MS Surface…there were some models that MS supplied Windows 7 drivers for downgrade
And just keep trying them all…u may get lucky

Sorry, I already tried that driver, and it failed.

@SamsungASUS :
>Here< is a link to the requested Win7 driver, but I don’t know whether it works or not.
Tip: If you are searching for a driver, you should mention the exact OS Edition. 32bit drivers don’t work with a 64bit OS and 64bit drivers are not compatible with a 32bit OS.

@MeatWar :
Your links were ok, but the driver name indicates, that Win7 is not supported (despite the words “os=windows-7” within the links).

Sorry, but the download links are fake, they only lead to a trial software.

And I’m searching for 64 bit drivers.

@SamsungASUS :
The only Marvell AVASTAR Family Wireless Network adapter drivers for Win7 I could find are attached.
Although the HardwareIDs do not match your specific Marvell device, the driver may work. If you want to test it, you have to force the installation by using the "Have Disk" button.
Good luck!

Marvell AVASTAR Family Wireless Network adapter drivers for Win7.rar (965 KB)

Sorry, but when I tried out the drivers, it got stuck on Installing Driver Software. I also believe I had tried to install the exact same or similar drivers to the ones you posted, and they didn’t work. Can’t you make Windows 7 x64 drivers?

@SamsungASUS :
I generally do not modify drivers on request.
When you want to force the installation of a driver, which natively doesn’t support the HardwareIDs of your device, you have to do the following:
1. Right-click onto the missing driver device.
2. Choose the options “Update driver” > “Browse my computer…” > “Let me pick…”
3. Click onto the “Have Disk” button, navigate to the driver folder and click onto the matching INF file (here: mwls87w7.inf).
4. Choose any of the listed Network adapters.
5. Disregard the warning you will get and let the driver be installed.
After the next reboot you will see, whether the device works or not.

The driver doesn’t work. Believe me, I tried. First, when I tried to install the drivers by force, it hung at the Installing Drivers window. Then once I got back to the Surface Pro, the screen was black, so I had to turn it off by force. Afterwards, I turned it on, and Windows 7 hung at the boot screen, so now I’ll have to reinstall Windows 7.

@SamsungASUS :
That is a pity.
Why didn’t you set a “Restorepoint” before starting the installation of a natively not matching driver?
This should always be done before doing something, which may not work.
By the way - your test result verifies, that the driver itself (= the *.sys file) doesn’t work with your specific system. A modification of the *.inf file wouldn’t solve the problem.
My tip: Ask the Marvell Support for a solution.