ME Reflash Help

Hi, (this is my first post in this forum)

I come to you today to ask for advice as I don’t know what else to do. The situation is this:

I’ve an ASUS H87-Plus Motherboard, which I bought like in December 2014… after like 6 months of usage I noticed the:

1st symptom which was all of the sudden the computer started with a double POST (turning on for a few seconds, turning off and turns back in as “normal”) and this happen every time since.

2nd symptom which was when the PC was set to sleep, never came back from it, which will result in a hard reset in order to be able to use the PC.

After these symptoms, I looked in the Support page of ASUS and looked for the latest BIOS version for the motherboard and found out the 2002 version was available, so I downloaded the BIOS from the website and the update using the EZ Flash utility in the BIOS. The BIOS version being used before the update was the 0804. The BIOS update completed without any issue or so I thought, when I noticed the:

3rd symptom which was under the Device Manager in Windows the Intel Management Engine driver was flagged with a yellow marker, after looking at the Properties menu the message was and still is “The device cannot start. (code 10)”. Tried installing a new version of the drivers, uninstalling completely, installing under Safe Mode, everything, but nothing seem to change the state of the driver, even tried doing a Windows 7 Fresh install and driver looks the same.

After going through this Forum for a good while and found something similar noticed the:

4th symptom which was in the BIOS screen where component information is; in this screen I’m able to see the following items as N/A: ME Version, Memory Frequency and the CPU Speed.

After this, when back to this forum and looked for more answers related to the symptoms, which lead me to believe the ME section of the BIOS got corrupted somehow and needed to be re-flashed. Keep in mind, I tried to use the tools to see the ME information under Windows but all of these return an error like the ME was not able to communicate with the driver or something like it. Then I tried to use FTK to reflash the ME section only using CodeRush’s tools and instructions but the result was the infamous error 26, meaning the Flash Descriptor is locked.

Also, its worth to mention during this time I tried to downgrade the BIOS and even update to the latest version of it but nothing has solved the issue so far. I’m currently using the BIOS version 0804 and have it moved from it for a long time.

From what I understand, the last option is to unlock the pinmod the Realtek audio chip in the motherboard to be able to reflash the ME section, (of course, all of this information I gathered reading the posts and replies from this forum). Now, I want to try this as a last resort before buying a new motherboard, but I’m not really sure how to do the pinmod move (every place I found the instructions to do it, there is a picture which I imagine is showing how to this but the picture is not displayed), I’ve already located the Realtek audio chip but not really sure which pins need to be shorten.

Any ideas how to do this? is there another option am I missing to try? should I forget all about it and buy a new motherboard? (already tried to contact ASUS, but after a year got no response and neither the chat nor phone people handle this type of issues as they always cut the communication to them)

Thanks for the help in advance! :slight_smile:

Here are my hardware specs in case you are wondering:

Motherboard: ASUS H87-Plus
CPU: Intel i5 4570 3.2 GHz
RAM: 16 GBs DDR3 (1333 Mhz)
GPU: nVidia GTX 980 Ti
PSU: EVGA Nova G1 750W
OS: Windows 7 (64 bits)

PS: sorry for the long post, just wanted to be really clear.

No problem in long posts. You need to short pin 1 (3.3V) with pin 5 (HDA_SDO) on your HDA chip, the rest is described here. Another option is to buy a cheap CH341A-based SPI programmer and use it to reflash your ME region despite of any descriptor locks present.

Thanks for the quick reply CodeRush, that was exactly what I needed… I’ll give the pinmod a try then and report back.

Just wondering from the symptoms I describe in the first post, do you think the ME being corrupted might be the cause for most of them?

Exactly, all of them should be gone after your ME is restored.

CodeRush has already told you what to do exactly so the only things that I’d like to say are:

a) BRAVO for having done proper research before asking for help. Seriously, great job. The post might be lengthy but when you see someone that has done so much already, you automatically wish to help him/her succeed.

b) Your motherboard has a socketed SPI chip. You can get yourself a cheap programmer and never have any issues like this again. Depending on what you choose to do (pinmod or programmer) I will give you (if you want) instructions on what to do and what exact files to flash to repair the ME which, as CodeRush told you, is exactly what you should expect from a malfunctioning one.



Thanks for the reply plutomaniac! really appreciate the help, like they say “the more the merrier”…

I’m going to try to do the pinmod first, if that for some reason doesn’t work, then getting a cheap programmer will be the next step.

Just to be sure, this is the Realtek chip I found in the motherboard and from what I understand the pin 1 and 5 have to be shorten using a paper clip or some tweezers in order to unlock the Flash Descriptor. From the picture attached will the pin 1 and 5 be the ones with the red arrows?

pinmod.png

Based on the logo orientation, I think so. You can usually find the chip datasheet online which has a full pinout schematic at one of the first pages. But it should be those two you have marked. Keep these sorted, boot the system and release them after post. Test with fpt -d spi.bin and it should be successful, meaning no error 26.


Seems like those are the same pins are mentioned in the thread link CodeRush replied earlier; here is the diagram I found about the specific chip my motherboard has:

pinmod.png



I gave it a few tries using some tweezers yesterday, but I was still getting the error 26; I forgot how little tiny the chip was and because I didn’t have too much time to spend trying to short those two pins I stopped as it was kinda challenging to know if it was being done correctly.

I’ll be giving it another try this weekend, because I know I’m going to be well rested and have enough time to unscrew the motherboard from the computer case and do the pinmod in a more comfortable manner and using a paper clip instead because my wife’s tweezers were a little too much, I think. LOL

In any case, will report back if I was successful or not.

Always thanks for your comments and suggestions!

Performing the pinmod successfully is indeed very hard nowadays with such small chip pins. Try it again when you have time and more space to work with. If still no luck, you will need to get a cheap programmer and flash the socketed chip directly.

Well, after spending a lot of time and effort to do the pinmod; unfortunately I was not able to do it successfully. :frowning:

Tried different methods or tools (if you will). Tried using 2 needles, using a mini cable from a LAN cable, a paper clip… well, you name it I tried it. Every time, did the pinmod wait for the POST and boot to a Win98 bootable USB with the FTK for DOS, but only got the error 26 after doing the “fpt -d spi.bin” instruction.

In the meantime, I’m looking for a programmer in local store before ordering from Ebay, Amazon, etc. as it will take longer time to arrive. I live in Guatemala, so anything I buy from any internet site takes around 1 or 2 weeks to come in. Will order it from any of those sites if I don’t find a store selling the programmer.

Is there anything else I might need when having the programmer? anything like special to take out the BIOS chip and re-flash it using the programmer? (don’t think you can take out the chip using your hands or a screw driver, right?)

I know what you mean. Personally, I haven’t been able to do the pinmod in the past as well. Way too difficult with today’s realtek chips unless the OEM has implemented a jumper or at least exposed pcb trace terminations. As far as the programmer is concerned, your motherboard has a socketed SPI chip which can be easily removed and reinserted without any special tools. A small prying tool (tweezers, screwdriver etc) will do the job just fine. Note down the orientation of the chip on the motherboard, align it with the programmer’s and you’re good to go. So a programmer is all you really need.

Capture.PNG

How do i flash just he ME region please with the CHA341 programmer software ? Just load in the dumped? me.bin and press program?


No, you need to prepare a full SPI image (FD, ME, BIOS etc) just like the one you dumped. You can use UEFITool, if you want, to easily replace the ME region at the dumped SPI image and then flash it back via the programmer.