Microcodes update for ASUS CROSSHAIR IV FORMULA

Hello, I downloaded the latest bios from the asus website for this motherboard: https://www.asus.com/SupportOnly/Crossha…/HelpDesk_BIOS/

I noticed it had 6 microcodes but 3 of them aren’t the latest version.

I got them from the repository and then tried to open the bios with mmtool (from version 3.19 to 3.26) but when I open the CPU PATCH section of the program I get this message: CPU MicroCode Patch Module does not exist in ROM image.

Is anyone willing to help me to update the microcodes? I attached the original bios plus the microcodes list.

Thanks in advance for any help.

BIOS.rar (926 KB)

Well, all newer microcodes do have the exact same size and aren’t compressed- there’a a chance that simply replacing the correspnding microcodes in a hex- editor would suffice.

If you want to play it completely safe buy yourself a CH341 programmer and some 25q16bvaig chips (that’s at least what I can see on this picture), make a dump of your own bios, replace the microcodes, burn it into the new chip and try. If it doesn’t work you have a safe way back and it’s not too much money burnt.

Thank you for the tip, I already have an eeprom programmer (tl866ii plus) so I could try as you advise, but i’m not confident to update the microcodes with an hex-editor, I did it once and the bios obviously didn’t work.

Edit: I tried to paste the updated microcodes in the place of the olders, but I get the bad checksum error when I try to flash it.
So there could be some kind of protection at least from hash point of view.

If it didn’t work- how did you recover? Do you still have this bios you tried?

It refused to flash the bios

It maybe always will… That doesn’t necessarily mean that it wouldn’t have worked.

The microcodes are in this volume (marked in left window), extract it, change the microcodes with a hex editor, generating a new module. Replace the existing module with MMTool 3.xx. The module itself won’t be changed while inserting. If there are other checksums that are changed when replacing the module- I don’t know…


Do at least a backup of your bios before you try to flash! And 25q16bvaig are still quite cheap…