Microsoft Surface Pro 4 No Touch after ClearME

hi guys
i have a surface pro 4 that came with battery problem
it doesn’t charge more than 46%
i replace battery with new one and in also doesn’t charge more than 46%
i flash bios, charging problem solved

but now i have touch problem
it doesn’t work even in bios menu
surface Touch Firmware in device Manager has error
windows update not help
i tried two more bios but same problem

this is my dump file with battery problem

i7 dump.rar (3.37 MB)



can someone make Clear ME Region of my file please?
i try to do that but when i drop bios file to ME Analyzer it cant detect version of file


It works just fine. MEA shows many CSME File System errors, because the latter is probably corrupt, but you can see all the relevant firmware info at the top:

Capture.PNG



Thus, you can follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization to repair the CSME firmware and flash back the output full SPI image.

i create this file

outimage.rar (3.31 MB)


i flash it , now device turnes on but there is no display
what is wrong here?

any idea about that?
i rellay need to solve it

i still not solve this problem
i made Clear me from my original file
it boots normally but there is no touch firmware and touchscreen not work
i update from windows update,ME firmware and ToucScreen Firmware donloaded and installed
but there is still error sign for them in device manager
is there any way to get touchscreen firmware from original file?

@R_EZ_A - What does “Clear ME” Mean to you, and how did you create the “Clear ME” and why? Touch may require ME FW to be functional, so if you disabled ME FW (if Clear ME = Disable ME to you) then this may be the issue
You probably messed up ME FW. What is your actual goal or reason to touch the ME FW here, and please explain in detail why (don’t say to “clear ME”)

Give me your original dumped BIOS, before you touched ME FW, I will clean and update it for you


thanks for your help
i use instruction here
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
replace ME Region file with one in Firmware Repositories
this is my original
with this file everything works, except battery that not charge more that 46%
after flashing bios with another dump file , battery fully charged but ME FW and Touch FW damaged

i7 dump.rar (3.37 MB)

@R_EZ_A - Sounds like maybe you did something wrong using the guide then? OR, ALL Those errors in original dump, some may carry over, not sure? Maybe this, since for V11 there is not much to do when updating/cleaning ME FW
Due to this, when I redo ME FW too, it may be same as what you did Can you link me to stock BIOS for your exact model (not the 200MB+ general BIOS Update file, I mean one for your exact model)
Here, clean updated ME FW using BIOS from post #7 - https://ufile.io/i966s4m9

plutomaniac - IF R EZ A says issue persists, would you please check these files (this one from me (edited from BIOS at post #7 ) + from post #3 above + BIOS at post #7. #7 BIOS (orig dump) = ME FW with HUGE amount of errors when dropped into MCE, I’m worried some of that is carrying over when we clean/UPD ME FW


If the cleaned image does not show the aforementioned errors in MEA, they have not carried over. Who knows if those dumps are proper in the first place as "R EZ A" has flashed dumps from other systems with their own BIOS etc. If the cleaned CSME does not help, the BIOS is problematic.

thank you guys for help
it looks that i’ve done something wrong because with your file there was no error in device manager and all version numbers in bios was good
but same as other files that i program, there was no touch
there is no touch even in bios setup page

i dont get what you mean of Stock Bios
i have more working devices if you need working dump file

@R_EZ_A - Sounds like ME FW is good now then! You either need to use correct BIOS for your device, or correct drivers. Be sure to install all drivers on the driver download page for your model.

Stock BIOS I mean stock BIOS, no other way to say that.

There is MANY variants of "Surface Pro 4" so you always have to be 100% sure you are using correct BIOS per your particular model.
If you have other EXACT Model systems, that touch works on, then dump those BIOS and send to me and I will swap BIOS region and system details for you.
While you are messing with other EXACT Model system make sure you have same version drivers in those as your current problem unit.

i tried updatibg drivers with windows update and drivers on microsoft website
surface pro 4 has active touch in bios page but thsi one doesnt work even in bios setup page
i have same model of pro4 with same motherboard that touch is working
im not sure about drivers of this dump file

i7-read ok.rar (2.95 MB)


but ill update drivers and read and upload today

this is dump file with updated drivers and FW

i7-read-update.rar (3.34 MB)

@R_EZ_A - So, above file at post #13 is from same model, same exact motherboard, and has working touch?
If yes, and I put this into your other dump and touch does not work then it means bad digitizer or digitizer cable is broken or not attached properly, especially if you find the same when swapping hard drive from the working-touch system to this other one for a quick test.
Please confirm the above is true, and I will swap BIOS region and system details etc. Or, wait, please confirm this first! Program this dump into the other system, then test as-is, and if no touch still, then swap in the working ones HDD/SSD and see if it works or not, if not then what I mentioned above must be true
If it works, then let me know and I will do the swap stuff I mentioned

i have this problem too
touch not working after writing bios

Hi, see this post only now after send similar questions to another topic.
I have a surface pro 4 with similar problems on bios under touchscreen firmware I have 0.0.0.0.0.0 .I tried also to change the phisical touchscreen board but same result so do not think is an hardware problem, .On windows I have have the two yellow icons on firmware of touchscreen and surface me with code 10.
Could I solve with bios ? What I would do?

Thanks in advance for suggestions

Someone can help me , please

Up, try again for help

UP

Hi, I have similar problem too.
Here is my hypothesis. Intel Management Engine and touch firmware include in bios chip. The revision info could be checked by Surface UFEI. The firmware revision depends on hardware. If bios chip have wrong information and data, windows reports errors on device manager. Touch feature could be confirmed on Surface UFEI also.

In my case,
My Surface lost any flash data. And I tried to replaced bios data from the other boards. Programming was success, However, it could not recovered.