Mod bios for Gigabyte GA 970A-D3P

No friend, I have to rollback an original bios firmware using @bios software and it worked fine entering boot menu.

it seems that unlocking option cause problem.


I have a GA-970A-D3P Rev 2 and am after BIOS mod to version FD for NVMe boot functionality.

I note the BIOS mod mentioned earlier in this thread by @Lost_N_BIOS is for the DS3P board, not the D3P like the poster was asking (and which I’m after).

I tried that modded BIOS file anyway, and sure enough Qflash gives an ID check error which isn’t surprising as the MBs are quite different (DS3P has Crossfire, different IO, different RAM types supported etc).

Attached is my BIOS (version FD) which loads and unloads ok. Is there a NVMe mod for this available?


970AD3P_bios_FD.rar (2.68 MB)

@80s_hackster - See post #2, follow link (to post #54) on other thread
The link is for DS3P thread, but that thread has many variants posted in it, including the D3P Rev 2 at the link I provided in post #2 here
BIOS file extension may need fixed, if the file I uploaded matches what I have in folder (ROM), rename back to .FD if Qflash does not accept it << If this happens, let me know and I will re-up that file to fix this for next person grabbing it

1 Like

Thanks @Lost_N_BIOS that worked first time :slight_smile:

@80s_hackster - You’re welcome! So, did you have to rename the extension on that file, or was it OK as .rom?

@80s_hackster I change the file name and it worked. I didn’t try it with the .rom extension.

@80s_hackster - Thanks!
I think I will go ahead and fix that now, and reup, in case anyone in the future runs into issue with .rom and has file extensions view disabled so can’t see what’s going on.

help me for bios f6f 970A-d3p v1.0 mod m.2 nvme, pls


Very easy mod, follow the links and present ur final work, someone can check later if the mod OK and help.

[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

[Guide] How to flash a modded AMI UEFI BIOS

Before any flash with mod files, the system should already be with the same version of the bios file that will be mod.
As usually, not the mod itself but the flash operation of the mod, envolves some risks that only u decide it, whenever possible a software backup of the entire SPI bios is advisable, preferably if possible a backup with a CHA programmer is the best and most reliable.

mod for me, pls ? i do it (h.t.t.p.s://…-UEFI-BIOS.html) but when boot pc nothing happened. NVME not detect in bios and windows like not yet mod. it’s my moded bios, Thanks for your help

970AD3P.rar (2.68 MB)

Ur mod file is OK.
Now follow the procedure explained in the guide for OS install and boot from the new NVme drive.

can you reupload please f6f?

Previous post…wots the problem?

EDIT: Blind? Thats the mod in post #26

just wanted modded f6f bios for my motherboard to add nvme support

3 posts were split to a new topic: [Request] GA-970A-D3 BIOS with NVMe Boot Support

I have GA-970A-DS3 ver 1.0 motherboard with latest beta bios F7d and a AMD R570 and have plugged in a M.2 drive into a PCIe. I managed to use Clover with windows installation USB and succefully installed the first part of windows upon reboot I have to use DUET/Refind so that the drive picks up and when it starts to compelete the installation upon windows logo and the dotted circle half way it crashes with ACPI BIOS ERROR. Now heres the strange thing When I use my old graphics card Nvidia GTX 560Ti it works no errors. However when I plug in the AMD graphics card it crashes at the same piont. I belive maybe issue with drivers or something. Coudl you help and advise. I have turned off S2 and using S1, have tried AHCI, Raid, IDE same results.

@Lost_N_BIOS I have a GA-970A-D3P rev. 1.0. that currently has F6f installed. I’ve searched this forum but I haven’t seen a request for that UEFI to be modded by you, so I was going to ask if you could mod for NVME access and any hidden items to be unhidden?

Here is a link to all of the bios files for this board…

NOTE: If I am wrong and you have already modded this BIOS, I apologize and would just ask for a link.




The user Lost_N_BIOS is no longer an active forum member since 2021.

Use the available linked NVMe mod files or you can do it yourself following the guide:
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (

By Lost quotes “Thanks for follow-up image, nothing hidden in there anyway
Seems theres nothing to unlock on this bios, so all that remains is NVme mod or updated modules with UBU for ex.

I just found this forum a couple days ago and wasn’t aware he was no longer hangin out here! Thanks for letting me know.

@MeatWar I was curious about the other part what Lost_N_BIOS was doing for people. Unhiding hidden BIOS options. I’m guessing that’s a rather specific set of skills one has to get to do that, am I correct? No tutorials for that? Or, is there someone else on this forum that has taken over helping people with that sort of thing?