Mod Bios to Raid Non intel SSD?

Is it possible to modify the bios to raid non intel SSDs using Intel RST?

I have 3 Samsung PM963 NVME SSDs that show up in the bios as Generic Samsung NVME drive. I am able to install windows on a single drive and boot. But I’d like to raid them. Is there any way to get the bios to recognize them and be used with Intel RST?

I also have an old 970 that shows up fine in the bios and can be raided. but the PM963 are only recognized as generic.
So how can I get the bios to recognize them properly?

I am okay at flashing the bios if necessary

The motherboard is Asus rog strix z370-e gaming running a modified 3003 version with updated raid drivers.

@Jkfde : Welcome to the Win-RAID Forum!
You can create an Intel NVMe RAID array with non-Intel SSDs as members without modifying the BIOS.
>Here< is a video, which shows you what you have to do, and >here< is the related thread.
Good luck!
Dieter (alias Fernando)

My problem is that they show up in the Bios, but not under IRST. On desktop, IRST can see them, but can’t create an array. I’m using the hyper x m.2 adapter in my x16 slot with bifurcation. The link you provided is only good for linux distros I think. I want to run windows 10. Any suggestions?

@Jkfde :
Please check the BIOS settings. What does the "Intel Rapid Storage Technology" settings show?
Have you tried to create the RAID array from within the "Storage Controllers" section of the BIOS?
Which version has the Intel RAID EFI BIOS module?
Do the BIOS settings allow booting in UEFI mode at all?

Yes, I’ve tried creating a Raid array, the drives don’t show up there. Using the Hyper X card, they show up in the menu option above IRST. I can install and boot to a single drive. Although it doesn’t show in the boot menu until windows is installed on it. I can raid is using other software, but not IRST. My motherboard is UEFI with CSM turned off. Its a 300 series intel chipset.

Right now I have 4 m.2 drives attatched. the 970 shows up and is compatible with IRST, but I don’t want to erase that. The other 3 are PM963 drives by samsung. IRST can’t see them in bios, But on desktop can see it, just has the raid option grayed out.

Here’s some shots of my Bios config.





@Jkfde : Thanks for the pictures. It is not easy to read the details. Why didn’t you take screenshots via F12 and saved them on an USB Flash Drive?
Since I never have used a Hyper M.2 x16 adapter, I cannot really help you. Nevertheless I recommend to look at >this< video, which states, that such card are only usable with “High-End Computers” with an X299, X399, TRX40 or WRX80 chipset. You PC have an Intel 300-Series chipset, which is rather new, but not an high-end one.

By the motherboard manual, the use of 3 SSD/NVMe drives must be in the most top (GPU) PCIe3.0x16/x8_1 slot, the use of only 2 can then be in the next slot PCIe3.0x8_2.
Doesnt have any notes regarding the use of 4 drives, on Asus Hyper M.2 v1 (2017) it states Z370 motherboard/cpu with VROC support and INTEL drives only, number of drives depends on cpu installed (Lanes)
Indeed it supports bi-furc… the question here is the Z370 with VROC/CPU support/Brand drives or non retail Samsung as ur using OEM PM drives and wot Hyper u have…lots of details and
still a mess of info users…and maybe a no go for u, maybe trying RAID modules version v16/17…
On QVL devices theres no mention to Samsung PM drives or regarding tests with Hyper V1 card but there is the PM961 on the V2 card QVL list.

In the Hyper M.2 V2 (2019) again the mentions CPU VROC only and INTEL drives ONLY… “…Unused CPU PCle® lanes can be assigned to storage, allowing you to create a bootable RAID array with multiple M.2 SSDs”
"Hyper M.2 x16 is designed specifically for Intel® Virtual RAID on CPU (VROC)"
In techspecs… "Intel® RAID on CPU function ready for some X299, Z370 and Z390 Series Motherboard models. (It supports Intel® SSDs only.)"

Presumably u already read this:…e_EM_V4_WEB.PDF (same user guide V1 or V2)

Yeah, I only have the 3 pm963s in the Asus hyper x card. The 970 is in the motherboards m.2 slot. I am able to raid them for Linux installs using mdadm.
I only intend to raid 0 these which doesn’t require a key. I believe that’s what you’re limited to unless using Intel drives.
Also, my motherboard is on the list of compatible boards.

It’s the hyper x16 gen 4. Just trying to make use of extra parts. Was hoping there’s a way to mod or work around some of this to make it work.
I’m not sure if my motherboard has the option rom. I’ve tried ctr + I on boot and nothing happened.