Mod-ing Bios for NVME

I’m trying to get my Asus Q87M-e to boot from an m.2 drive located on a PCIe adapter. Once booted, Windows 10 has no issues accessing the drive. My goal is to boot from the drive, rather than just use it. The NVMe drive is six times faster than my SATA SSD.

I’ve tried booting though both Clover and Duet with no luck. Neither can see the drive, even though I cloned the entire system drive and marked it as Active. I’ve also toyed with bcdboot with no luck. I tried modifying my BIOS with UEFITool (v.26), adding nvmexpressdxe_small just after the last module before free space. Because the saved file no longer has a valid capsule signature, I tried AI Suite, and when I flashed the bios, EasySetup (or whatever the AI Suite flash module is called) crashed before completing. Luckily, I had the original utilities disk and a copy of the unmodified bios on an accessible drive, and was able to restore the Bios, thanks to the robust Bios recovery functionality (whew!)

Edit by Fernando: Thread moved from the “Storage Drivers” into the “BIOS Modding Requests” Sub-Forum and thread title customized


Is this till actual for you?
Let me know!


Still an issue. I’ve pretty much surrendered.

@jimg :
Which is your issue?
Where is your modded BIOS?
Did you read and follow >these< advices?

I followed the cited instructions to the best of knowledge. The modded BIOS is long deleted, since it didn’t work. Since I nearly bricked my motherboard, I quit trying. I use the NVME drive for pagefile.sys, so it might be speeding things up a bit.

@jimg :
Ok, but why don’t you retry it by following >this< guide? To use an NVMe SSD just for storing the pagefile is wasted money.
The BIOS modification is very easy. According to my just done test the AMI MMTool v4.50.0.23 inserts even the bigger sized NvmExpressDxe_4.ffs into the latest BIOS 3801 without touching any Page-file.

I’ll give it a try next chance I get. Might be awhile…

Are you on the latest bios? If so, could you dump the bios by using intel flash programming tool (i cant post link here)? The parameters for the Flash Programing Tool is fptw64 -d <bios name.bin> -bios

Send it here and we might help you :smiley: