Modded Intel AHCI and RAID Drivers (digitally signed)

yes
sorry

@Fernando : thank you for the reply.


Yes, I’ve followed all these advices but nothing worked unfortunately (SSD firmware is up to date, I’ve tried all bios possible settings combinations, SSD reset with Samsung secure erase, and everything OS side).


It is my based deduction supported by the fact that I own a HP 2570p with same AHCI controller and with another Samsung 850 evo 120gb and under windows 10 I got very similar results. Furthermore I came across similar benchmarks on internet from other users with Intel(R) 7 Series/C216 Chipset. An example comes from @Hvngskts as you can see inside his #1325 reply of this thread. I don’t know but something makes me think it isn’t a mere coincidence but the result of an interference of some kind beetwen this specific hardware and Windows 10/11.
Let me know what you think about this mistery

Nobody?

@ole258
Your last post regarding the missing signature of my mod+signed Intel RST driver v11.2.0.1006 hasn’t yet been transfered to the new Forum home, but I have read it.
Which OS are you running, which Intel chipset has your mainboard and to which mode (AHCI or RAID) has the on-board Intel SATA Controller been set within the BIOS?

OS: Win11 Pro x64
Chipset: i5 2520m
Mode: AHCI

@ole258
You are right - Windows 11 doesn’t accept the old digital signature given by me on 05/11/2021.
Attached is the same “Universal 64bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by me”, but with a renewed digital signature.
This is what you see after having done a right-click onto any *.cat file and chosen the options “Properties” > “Digital Signatures”:


Universal 64bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando.rar (290.1 KB)

1 Like

Hey,
Looks like links died again

@bt1
Which links died? Which message do you get?

@Fernando thx for reupload

Hi! Fernando

Can you mod Intel RST AHCI+RAID+NVMe drivers v18.37.1.1003.

Thanks! :slight_smile:

@Kr13
Your requested mod+signed Intel RST driver v18.37.1.1003 is now available within the start post.
After having successfully installed the driver please post your feedback about the impact of this specific driver on your system into this thread (don’t forget to mention the chipset of your mainboard and the OS you are running).

1 Like

Well! Intel RST driver v18.37.1.1003 doing good so far. Performance wise, margin of error I guess.

@Kr13
Thanks for the feedback, but you forgot to mention your in-use chipset and OS.

Damn, my bad. Using Windows 11 and the chipset is Intel 300 series.

1 Like

@all
The start post has been updated today by me.

Thank you @Fernando for this mod Intel RST drivers v18.37.4.1007!

What drivers are suitable for X79 SATA controller? I tried several from this topic - they cannot be installed

Provided, that you have imported the Win-RAID CA Certificate, you may be able to get several Intel AHCI or RAID drivers installed, which I am offering within the start post of this thread.
If you want to know, which driver version is recommended to install, you should look into the start post of >this< thread.

How did you try to get the driver(s) installed and which error message did you get?
Is the Intel SATA Controller running in AHCI or RAID mode? Which OS ar you running?

@all
The start post has been updated today by me.
Any feedback is much appreciated.