Modded Intel AHCI and RAID Drivers (digitally signed)

Everything became clear. Thank you. What do you think, if you use Intel RST Software v12, which version is better to use driver v.11 or v.12 (my intel bios is v.11)?

Before I start speculating about the possible reason for the error message you got, please answer the following questions:

  1. Why did you try to “downgrade” the in-use Intel RAID driver to a driver, which belongs even to a different RST platform (from v12.9.4.1000 to v11.7.4.1001)?
    Note: Look into the last sentence of >this< post.
  2. Which version has the Intel RAID Option ROM module, which is within your mainboard BIOS?
    Note: You can see the version after having run the Intel RAID Configuration Utility (CTRL+I) while booting.
  3. What sort of Intel RAID Array have you created (a mirrored or a striped one)?
  4. Is your system drive (drive C) on your RAID Array? If yes, how did you get Win10 x64 installed onto it?
  5. Have you ever tested any Intel RST RAID driver, which belongs to the v15 platform?
  1. I’m trying to “downgrade” my Intel RAID driver to driver version v11.7.4.1001 based on your performance recommendations. Unknowingly, I used v.13 before. I had a GA-EX58UD3R motherboard installed in my computer. And everything worked. Not so long ago, the board broke down and I replaced it with a GA-EX58UD5. When connecting the RAID created earlier, I had terrible friezes. On this RAID array, I had Windows 7 installed and data. I no longer use this version of Windows (now I have Windows 10 on Sata3 SSD and Marvell 9230 controller). But on the RAID I still have 1.5TB of data. Even when watching a video while moving along the timeline, there were delays of more than 5-8 seconds.
  2. Right now, the Intel® RAID option ROM that is in the BIOS of my GA-EX58UD5 motherboard is v. Earlier on the GA-EX58UD3R board, I modified it and it was v.11. In the coming days, I plan to update it to v.11 and on a new board.
  3. I have an Intel RAID set up striped (2x WD 1TB Raid Edition).
  4. At the moment, the system drive (drive C) is not included in the RAID array.
  5. Previously, I used the Intel RST RAID driver, which belongs to the v13 platform.

Where did you see this performance recommendation for your Intel X58 Series RAID0 system?
For an old system with an Intel ICH10R Southbridge and an Intel RAID0 Array I have always recommended
a) to insert the Intel RAID ROM v11.2.0.1527 into the BIOS and
b) to install the “classical” Intel RST Driver & Software Set v11.2.0.1006.

According to my own test results this is by far the best OROM/driver combination for a system like yours.

Maybe I missed something somewhere. Sorry. Most of the BIOS modifications were higher firmware than v11.2*, which led me to a higher version of the drivers. I just tried to install “Universal Intel RST Drivers+Software Set v11.2.0.1006 mod+signed by Fernando” and everything went well. I don’t see any freezes. Now I will look for BIOS best matching Intel RAID ROM v11.2.0.1527 to flash it into the motherboard. Thank you.
But it’s still strange that the older version v11.2.0.1006 installed without problems, but the version v11.7.4.1001 does not run setup.exe (most likely the problem is not in the Windows version).

Just to help finding out the reason for this issue, please run the setup.exe of the original Set named “Intel RST(e) AHCI/RAID Drivers & Software Set v11.7.4.1001 WHQL”. You can find the link within the start post of >this< thread.

Runs without problems!

Ok, that is interesting!
Please try to run the setup.exe of the freshly made attached Set.

(Attachment removed on 06/25/2023, because it is now available within the start post)

Great. Now it also starts without problems!

1 Like

Thanks for having tested my freshly composed Drivers & Software Set! That was a big help for the interested users of this Forum.
I will replace instantly the related links within the start post of this thread.
Nevertheless I recommend for your specific system the Intel RST RAID driver and software v11.2.0.1006 WHQL.

Thank you for your help!

I want to make an adjustment to better understand the situation. “Universal Intel RSTe Drivers+Software Set v11.7.4.1001 mod+signed by Fernando” now really runs and installs without problems. But Intel RST Software v11.7.4.1001 doesn’t work on my Windows 10 22H2. There is an error in the Windows Event Log when running a DLL file from this software suite. Hovering the mouse over the Intel RST Software icon indicates that the service has not been started. Exactly the same situation with the original Intel RST Software v11.7.4.1001. No miracle happened. Perhaps on versions of Windows 10 below 22H2 or LTSC it will be different (no way to check).
I installed v11.2.0.1006 mod+signed by Fernando and I’m happy with it.

1 Like

Just for information. I think that the use of low versions of drivers on new operating systems is still undesirable. I will probably look towards Intel RST Software + Drivers v12. Today a BSOD popped up on v11.2.0.1006:
Dump: 062723-12953-01.dmp (6/27/2023 2:30:54 PM)
Code: 0x9087 - Unknown bug check code
Process: System, probably caused by: iaStor.sys
Third party modules in the stack: iaStor.sys
FAILURE_BUCKET_ID: 0x9087_iaStor!unknown_function

According to my own experience and the feedback I got from a lot of Intel RAID users the Intel RST driver v11.2.0.1006 is not only the best performant, but a rock solid one as well. So I suspect, that there is another reason for the BSOD you got (you should check your system regarding critical software/tools).
A big problem for Intel RAID users is, that neither Intel nor Microsoft have taken care about the stability of Intel RAID Arrays running with Win10/11/12. Since a good NVMe SSD ist much faster and less fault-prone than any RAID0 Array, both Companies don’t invest time and money into the development of newer/better RAID drivers.

@ all interested users:

The first part of the start post has been fundamentally updated by me today. The rest will be done tomorrow.

These are and will be the main changes:

  1. The “pure” mod+signed Intel RST drivers v11.2.0.1006 are now offered as generic ones. This means, that they will support all current and future Intel SATA AHCI/RAID Controllers. By the way - I had no problem to get the 64bit AHCI driver installed onto my Intel Z170 system running Win11 x64 v23H2.
  2. To make it easier for you (no guess about the correct *.inf file) and to avoid a “wrong driver” BSOD I have split the natively merged AHCI and RAID drivers and offer them now separately. This has no effect on its functionality.
  3. All offered drivers have been freshly digitally signed by me with an SHA-256 stamp and will hopefully be supported by all Windows Operating Systems.

Please test the drivers and give me your feedback via PM.
Thanks in advance!

1 Like

My modern motherboard is an ASRock Z790 PG Sonic with socket LGA 1770. Are there any drivers for the Z790 Chipset for 32bit and 64bit Windows XP? This is my very first comment here.

@minipicc95 Welcome to the Win-Raid Forum!
Contrary to all newer Intel RST drivers only the v11.2.0.1006 ones do support old Windows Operating Systems like XP (32/64bit).
Good luck!
Dieter (alias Fernando)

My hardware id for my Standard SATA AHCI Controller on my Z790 PG Sonic Motherboard are. PCI\VEN_8086&DEV_7A62&CC_0106

The HardwareIDs of all Intel SATA AHCI Controllers are supported by the “Generic 32/64bit Intel RST AHCI drivers v11.2.0.1006”, which were mod+signed by me and offered within the start post of this thread.
Try it and report here about your results.

Just refreshing: question: which management interface to use for managing disks and raids and M.2?