Modded Intel AHCI and RAID Drivers (digitally signed)

for x299 what is the best efi and driver?

Since I don’t have an Intel X299 chipset mainboard, someone else has to find it out.

1 Like

Hello Fernando,

I’m really happy to see this site stil going strong. Your efforts as well as everyone else who contributes has really been amazing. Over the alst 15 years I have turned here when I have had issues and it seems they are always resolved…annnnd with that…im here again with a problem that absolutely stumps me and I cant figure out…

I am installing a fresh windows 10 x64 O/S on my old Asus X99 Deluxe, I have Sata controller 1 enabled and in raid mode and Sata controller 2 disabled entirely. I have the updated the bios module for the Intel RST(e) to v14.8.2.2397. I have a samsung NVME drive for my OS and a combo of Raid drives hooked up to the primary controller. While installing windows, I disable the intel primary controller and the install runs fine. Upon loading windows I load up the chipset driver and reboot. Upon reboot, I enter the bios and enable the intel raid controller. I see that in device manager windows auto installs the default microsoft driver v15.44 or whatever that is…
I perform the process to add the certificate to my registry and then click the option to manually update the driver and point it to the directory of the universal signed driver v14.8.18.1066 and it begins the update and nothing happens for the next 5 minutes and i get an error that it found the driver however the is a problem with the device and my drives connected all then show with errors. the driver for the storage controller, is the right version and has your signature in the properties so its going in…

I initially tried loading the driver from the windows install load driver screen and that just locks up and nothing happens…

I’m not certain what is going on. I cant get this computer back online for the life of me. I’m not sure if my bios is causing the issue, or if there is something within windows and the driver.

any help would be greatly appreciated and I will tag @100PIER as well as I know he was the resident expert on the X99 once upon a time. I know its old hardware, but I’m hoping there is an answer here. I’m not sure if its relevant but im having a similar issue on an older Asus Rampage III Formula based on the x58 chipset. I have used the machine without issue for years with the modded bios to allow trim on an ssd raid. Installing a fresh copy of windows 10 has also been a struggle there as it will not allow me to load the signed driver during the install and also just hangs… Is there something simple of obvious im missing or doing wrong? I used to do this every year to clean up my machines, and suddenly I am stuck on the windows 10 installs.

Thanks again for all that you guys do to keep this place so educational and informative.


Thanks for your report.


  1. What was the main reason for trying to replace (“downgrade”) the much newer and freshly WHQL certified Win10/11 in-box Intel RST RAID driver v15.44.0.1015 dated 09/05/2019?
  2. Have you tested the stability and performance of your Intel RAID Array while running the v15.44.0.1015 driver?
  3. Did you ever try to get the original Intel RST(e) RAID driver v14.8.18.1066 WHQL installed? If yes, did you succeed?

Thank you kindly for the response. To answer these questions:

  1. For the last 15 years i have enjoyed the labours of your work on matching rst orom versions to rst drivers as per your recommendations on your legendary post, this goes back to the days trim had to be manually enabled for ssds on older controllers. To be honest, i followed your recommendations as if they were set in stone and never had any performance issues as they were always matched to your recommendations. The default driver is v15 and my orom is v14 so that was a flag for me. And i didnt see this v15.44.0.1015 mentioned anywhere in yojr post matched combos. I was under the assumption that the x99 primary sata controller should be using v14 firmware and drivers. Are you suggesting the i leave the latest v14 orom as is and use this default v15.44.0.1015 driver? If thisnisnthe case which version of the intel rst software should I install for management of the raid…i have a 4 drive raid 5 array on that controller and i feel like the software is important for that purpose.

  2. I have not, i think i ended up with tunnel vision on getting this paired combo of orom and driver working so i have been installing windows and secure erasing my ssd and rinse and repeat trying different ways of getting it to accept the v14 driver. Are the older versions of the driver just not compatible with the latest builds of windows 10 anymore?

  3. I have not, i am assuming you are referencing an unmodified version v14.8.18.1066? I cant seem to find the virgin version of this driver on the forum, do you have a link to it?

Neither here nor there but my other question here is, to switch to RSTe v5.5.4.1036 and use the enterprise version, or will.this cause the same issue? I havent ever used the enterprise version, to donthis, would i have to mod the bios again? Or is there a setting somewhere already in the bios?

Thanks again for all you help.


  1. Times have changed and the latest Windows Operating Systems are very picky regarding third party storage drivers. That may be one of the reasons why many chipset manufacturers have stopped developing new or updated own storage drivers.
  2. If you should be satisfied with the v15 platform in-box Intel RAID driver, you can update the Intel RAID ROM module of the BIOS to a v15 platform as well.
  3. You can find the download links to the Intel RAID drivers v14.8.18.1066 WHQL within the start post of >this< thread.

@dj_groovin , hello,
I do use my ASUS X99 Sabertooth Desktop under W11 23H2,

Hope this help to your configuration. 100PIER

Lol, i guess my old school ways have become antiquated…i know they are not letting us use windows 11 officially on this platform, but cutting down how we use windows 10

I was under the belief the v15 platform rom is not compatible with the X99 chipset, correct me if im wrong. I thought that was strictly for 100/200 series…

If im going to use the inbox version of the rst driver, which version of the software should i use? And how would i go about trying to installmit without hitting this same problem? When i was trying to force the v14 driver, i tried installing the software and it would get ton70 percent and just hang there, assuming because the driver was unable to install.

Yes i found the virgin v14 driver and it gives the same result. I wonder if i should try uninstalling the inbox v15 driver from device manager first and then installing the older driver…

I will update this that on a freah os install i was unable uninstall the inbox raid controller driver, it does the same thing and just hangs at a scrolling progress bar that doesnt go anywhere after 10 minutes…

Would switching to the enterprise.edition RSTe v5.5.4.1036 make any sense, or is it a bad idea?

Thanks again

Hi @100PIER ,

Thanks for the reply. I see you are running raid and using rst driver V17.11.3.1010? I was under the belief V14 was the last generation compatible with our chipset . Which orom are you running in your bios? Is this virgin driver or did you use a modded driver and certificate to install?

This is only valid for systems running their Intel SATA Controller in AHCI mode.


If i test the inbox driver, which version of the rst software should i pair with it…im guessing the latest v15 platiform edition?

However, wont that try and install the latest v15 driver?

Do.i.then switch to the latest v15 orom?

Sorry im trying to wrwp my head around all this…

Hi @dj_groovin ,
I did use the virgin driver.
About the modded BIOS, please can you send me a private mail so that I can offer you all the stuff I had archived for modding the original ASUS v4101. Rgds.

Hello 100PIER,
thank you very much for your instant reply and help!

Did you install the original driver manually the normal way from within the Device Manager or did you force the installation by pressing the “Have Disk” button and navigating to the matching *.INF file?

I did the have disk method and pointed to the iastor driver. it ends after a few minutes with a message that the driver installed but encountered problems. In device manager it then shows the driver version is v14, however all the disk drives attached to it end up with exclaimations in device manager.

Trying to just install the software ends up with it spinning endlessly around 60 percent and nothing happens beyond that

Trying to uninstall the inbox driver results in a lock up as well.

Its strange as x99 is technically supposed to be supported by asus for windows 10 so you would think that the virgin driver and software pack would install without too many issues.

Is there any chance uaing the ntlite method still works? I can open the iso and remove.the in box driver and try and then do the have disk method on install? Or is v14 completely unable to function with the latest.builds of windows 10

Did you follow 100PIER’s offer and have sent him an eMail?
He knows much more about the best storage drivers for Intel X99 chipsets than me.

Yes we have been trading messages…

I may have had a slight break through, albeit its been only in testing…after getting the v14 driver in, i disabled jmit in device manager and rebooted. Now the system didnt shut down and hung so i had to hold the power button…however i re enabled the driver on the boot up and the driver now says its working properly, even more surprising…the exclaimation marks on the drives went away… i tried installing rst software and it hung and i neeeed to hold the power button again and restart…i managed to install rst using command line, “setuprst -nodrv”. It seems to be installed and its allowing me tk make changes on the raid configuration.

Im wondering how i should test it, its not like stress testing an overcloxk…lol. i need to check performance.

My.os drive is a samsung nvme so its not affected but i have a 3 drive raid 5, a 2 drive raid 1, and a single 2 tb sata ssd connected to the 6 ports.

I wonder if i can replicate this without having to powercycle live windows os so i dont have to worry about corrupted system files and what not…i guess i can run integrity checks on that later…but this is a step forward for now i think…

Hello gents, @Fernando and @100PIER

So it seems microsoft drop support officially for v14 drivers as of windows 10 build 1903 based on the research i have done. No matter how i try, windows 10 now refuses to accept and properly work with the v14 driver and the inbox driver does not seem tomfunction correctly either.

However, the rst enterprise driver v5 is not mentioned at all in any of the information i have found. I believe this might still be supported in windows 10.

With the x99 board its been said we can use the rste v14 or the rst enterprise v5 driver for the primary raid controller.

Does anyone know how i could install the enterprise edition driver for my raid setup on the primary sata controller?

Im assuming i would need to change the orom from the rste v14 to the rst enterprise v5 version. Or is incorrect?

Im very curious if this work around may keep the board officially relevant at least until microsoft drops windows 10 all together.

hello dj_groovin,
Here are some HWINFO64 screenshots from my old ASUS Sabertooth configured with 2 SATA RAID0 matrices. I do use W11 23H2. Why you don’t use W11 instead of W10 ?

I have tried to download my modded BIOS X99ST stuff (zipped), but I getan error message athe end of the upload '… try again". But after several download attempts of this zipped this does not work (zipped file is about 47Mo, is it the problem ?).
However, hope these infos help you. 100PIER

Hi i’m trying to install XP on a machine, but i can’t find the right AHCI driver, my hardware id from device maneger are as following,

I hope that someone can help.

Welcome to the Win-Raid Forum!
I recommend to take the “Generic 32bit Intel RST AHCI driver v11.2.0.1006 mod+signed by me”. It should work with your system.
Good luck!