Modded Intel AHCI and RAID Drivers (digitally signed)

@ Moorfowl:

Before it is forgotten: Welcome at Win-RAID Forum!
Since I don’t have any experience with the “Turbo Memory Software”, I cannot help you personally, but odiebugs has given you already some advices.


Check the maker of your laptop for the software and see if same as what you downloaded from Intel, if same, then send a email to the MFG of laptop, tell them that turbo is not allowing the AHCI, they should be able to make you a BETA BIOS with the Turbo not installed. Tell them the problem, hope they can help you.

i’ve just signed up to say “Fernando, you are a superstar”
i have been trying to ‘persuade’ windows server 2003 on my new asus g750 notebook to run as ahci.
didnt manage to install with any slipstreamed drivers under ahci so just installed as ide.
i have tried many combinations of intel driver files but your ones worked great.
i had to select the first disk (i have 2 internal ssd’s) and load your driver
then disable the second
answer ‘add new hardware’ and install then the drivers the same for the second one.

p.s. what i did notice, when i checked the inf file, you have added tabs. i changed them back to spaces. not sure if that matters

@ gazzacbr:
Welcome at Win-RAID Forum and thanks for your feedback!

Which version did you use?

Which "tabs" do you mean?


Hi, i tried a few from direct intel download site and also some modified by a german user. sorry i cant remember exactly which. as soon as your ones worked i deleted all the others.
by "tabs" i mean tab as in the tab key on the keyboard. there was a mixture of spaces and tabs in the inf file. like i said, not sure if it would be a problem but for consistancy you should use all spaces or all tabs (speaking from long experience with database and unix files)
my server 2003 (32bit) is slowly being dragged into the 21st century :wink:
now i only need a proper driver for my nvidia gtx 770m…
thanks again

If you got them at MSFN Forum, this "German user" was me.

Although I doubt, that such modification within the .INF file (it’s just a text and no hex code) has any impact on the installation or function of the driver, I would rather like to know, which part of the INF file entries you mean.

What happened to downloads? All download link are down…

@ tjawasiak:
Welcome at Win-RAID Forum and thanks for the info.

AFAIK only the links to the modded Intel RST drivers v11.2.0.1006 are dead, because I have done some modifications with the INF and OEM files.
Within the next 2 minutes they will be up again.


EDIT: All Mirror links are working now, but the MEGA ones not yet (seems to be a problem with the MEGA server).

HI, ok, just found the file and it was actually not the inf files but the txtsetup.oem from '‘Universal 32bit Intel RST AHCI & RAID driver v11.2.0.1006 mod by Fernando.7z’‘
e.g. line 20 ‘iaAHCI_8AHCI = "Intel(R) ICH8 SATA AHCI Controller (added by Fernando)’’ has a mix of tabs and spaces.
i opened the files in ultraedit just to see what the file did having tried several others and failed.
the most important thing is its working now :wink:
i have also installed windows xp the same way.

@ gazzacbr:
Thanks for your reply and for the info. To be honest I have never modified text files by using a hex editor, because the digital signature has been lost anyway.

Did you replace the mix of tabs and spaces or did it work without any correction? That means: Has the mix of tabs and spaces any negative impact on the installation procedure?
Nevertheless I have customized the TXTSETUP.OEM files according your advice.

Thanks again!

I replaced the tabs with spaces and it worked. i only open txt (or any) files with a hex editor as i have been caught many times in the past converting from unix/windows.
quite possibly the tabs were not a problem but i didnt try.
i have many data/database files i work with which are really fussy about tabs and spaces.
there one (quite old) program which actually dumps the data files in CR/LF format but they have to be converted to LF only to read them back in ???

Thanks for the reply.

That is what I think too, because I am offering driverpacks with modded INF and OEM files since 8 years and haven’t yet gotten any feedback, that the driver didn’t work because of the tabs/spaces mix.
Nevertheless I will follow your advice in the future.

Did you ever mod Intel drivers?

I didn’t find them

Do you want, that I mod and offer them?

Do you not mod "automatic" new releases and offer them at Page 1?

In the past I have done it automaticly, but since I do net get much feedback regarding this point, I wait until there is a demand for a modified version.
Furthermore until now only 2 Forum members have hit the "Thanks" button for the modded drivers. That may either be a sign of not much interest or for bad experiences with them.

I’ll see.

But there is no need to mod the drivers once for me - so I did it myself.

Nevertheless I have updated the start post.

  • new: modded 32/64bit Intel RST(e) AHCI & RAID drivers v12.7.2.1000 dated 07/15/2013
  • new: modded 32/64bit Intel RST(e) AHCI & RAID drivers v12.8.6.1000 dated 09/20/2013

@ all interested users:
If you want, that I continue modifying the actual Intel RST(e) drivers, please give me a sign like hitting the “Thanks” button. Even better would be a short feedback with a statement, if you succeeded with the installation onto an officially not supported system or not.


I am using your modded drivers (12.8.x) without problems with my X58(ICH10R) board. Thank you for your work.

@ arkraider:
Welcome at Win-RAID Forum!

Thanks for this feedback, which may be interesting for other users with an Intel X58 Chipset as well.