Modding BIOS with CSM support for AN515-42


I was wondering if it’s possible to mod the bin file that Acer gives out and then flash it to give ability to use CSM.
Here’s the link to the tool Acer uses to flash the BIOS from Windows computer with bin file included, it’s 10MB so I can’t upload here:…W0hKp4-ju8MBIT3

Can someone knowledgeable take a look and tell me if it’s feasible?

@LordCorvin - Please link me to the exact version BIOS you want from Acer, and don’t reupload, give me their link - or tell me what version # you want me to look at, latest is 1.16, if you want that then no need for link, I downloaded it already

This BIOS package contains two images, which is your BIOS?

In general, no, this is a pain and best done with a flash programmer, to flash a mod BIOS I mean. To change some setting to allow CSM enabled, may be easier done with some software or grub etc, let me dig deeper and get back to you

@Lost_N_BIOS Sure, it is the latest 1.16 Bios from September 4th 2019 release. Although the timestamp of .bin file itself is from August once you extract it.

Thanks, please see my edit above

It’s DH5JV, if it’s a pain to mod the bin file itself, then maybe I’ll abandon this project entirely. As I never used flash programmer. Thanks for looking into it though

It’s not a paid to mod, only a pain for you to flash, however settings can be changed many ways with software.

Sadly though, both BIOS do not contain CSM setting and the only boot mode option choice is legacy.
I even tried manipulating legacy to other options, none presented UEFI option only other settings or remained legacy = BIOS is too old for that and probably would not contain UEFI/EFI modules anyway, so pointless without tons of other mods done too.
Wait, in another tool, now I see Boot Mode UEFI as only option and Secure Boot enabled, so maybe something can be done to disable secure boot mode if you want, but legacy or CSM is not an option

That’s strange, in BIOS it shows only UEFI option for me, no Legacy. I’ll take a video tomorrow. I can also reliably enter the oem “advanced” settings. The BIOS is all red, but settings are all the same as regular BIOS version, and if you try to save and exit in red version the whole thing hangs and I have to force reboot

Edit: Just saw your edit. I can disable secure boot in Bios already. Thanks for looking into it. I guess Acer gutted alot of things

Yes, sorry, see above, it depends on what I was looking at and how. You can disable secure boot, but there is no legacy or CSM, however if you disable secure boot and UEFI is locked in (as it’s the only choice there), then CSM would be assumed enabled.
This can be changed with H20UVE, you dump vars and send me, then I edit and send back, then you program back in. If you want to try this, let me know and I’ll send you compatible version and how to info.

Sure, send me the h20uve. I’ll take a look tomorrow and dump the variables

I can’t find compatible version that will dump vars from the file, so none may work on your end either, flash programmer may be only way.
Here, try both commands below from CMD prompt at each version folder, ignore errors, leave all files in place, zip and return package once you are done. If any vars.txt are created, then we may have a chance
H2OUVE.exe -gv vars.txt
H2OUVE.exe -gs -all Setup.txt…596709096751444

If no luck, then maybe @zr1971jp can mod your BIOS with newer GUI version and disable secure boot (I can’t ever get it to save changes properly)

The worked halfway, here’s the output:

C:\UEFI\New folder (2)\H20UVE_100.00.9.2\H2OUVE_100.0.9.2\H2OUVE>H2OUVE.exe -gv vars.txt
Insyde H2OUVE (UEFI Variable Editor) Version 100, 0, 9, 2
Copyright (c) 2012- 2013, Insyde Software Corp. All Rights Reserved.
Read current ROM start !
Reading Block at FFF2A000
Read ROM Complete
Successful generate variable data to "vars.txt"
C:\UEFI\New folder (2)\H20UVE_100.00.9.2\H2OUVE_100.0.9.2\H2OUVE>H2OUVE.exe -gs -all Setup.txt
Insyde H2OUVE (UEFI Variable Editor) Version 100, 0, 9, 2
Copyright (c) 2012- 2013, Insyde Software Corp. All Rights Reserved.
Can't open data file ""
Error: invalid parameter

I uploaded the archive to the post as it's under 6MB

Here's a video regarding the "Manufacturer" side of BIOS, where it hangs. It also shows some of the options

H20UVE.rar (4.51 MB)