Modding old BIOS to support +1year GPU card

Hello Fernando Win Raid users!

I have bought GeForce Palit 7900 GS PCI-E card for my mother old pc.
She is using AsRock 775dual-915gl motherboard with bios 1.30 2005/10/20
CPU Pentium 4 530 + 2GB Ram DDR / Fortron 350w psu / Windows XP SP3

You can download 1.30 bios from asrock website
(AMIBCP v3.13 can open this bios, but you know better for sure :slight_smile:

So the problem is, bios/motherboard does not detect 7900 gs in pci-e slot.
Bios is from 2005, card released in 2006.

I think PCI-E slot is fine, her old card fx5200 is working.
So i tested 7900gs under my pc build, card is fully working.

I have cleaned her whole build from dust = 7900gs does not work.
I have reset bios, tried to change settings = 7900gs does not work.
I have unistalled all drivers = 7900gs does not work.
I have tried to connect pci-e/molex adapter = does not work.
I have tried to connect my 450w psu = does not work.
I have tried to underclock 7900gs bios = did not help.
I have tried to ask asrock support, but they dont have any beta bios.

There is no video signal from gpu to monitor, tried connect cable to integrated vga,
so all i see is basic bios info (f2/f11 not working), or please insert boot device when it loads somehow)

I dont know what to do anymore,
i dont have much experience with ami bios modding / gpu bios modding.

So im asking here for help

If its possible to mod 1.30 bios to support GeForce palit 7900gs,
please help me, my mother & me will be happy.

In atachement i will include motherboard bios & gpu 7900gs bios

Awaiting answer & sry for my english :slight_smile:

Thank you… (346 KB) (41.4 KB)

@madc90 :
Welcome to the Win-RAID Forum!

Although I am not an expert regarding your speficic problem, I doubt, that you will solve it by modifying the mainboard BIOS.
AFAIK you will have to flash into the BIOS chip of your Geforce card a vBIOS version, which matches the specifications of your mainboard.

Dieter (alias Fernando)

Thank you for the answer, i thought old bios versions store some module/info about cards and thats why its not detected.

Can you tell me what exactly need to be changed in vBios to match mainboard specifications?

For vBios modding i only use NiBiTor & nvflash, do i need to hexedit something in vBios? or maybe use another tool?

Any info/guide would be helpful.

Thanks Fernando

@madc90 :
You should better ask someone, who is really experienced regarding the vBIOS update of NVIDIA graphics cards.

Thank you for the answer.

In my pc build i have 2 pci-e slots (w gtx 760) & integrated intel vga, so its easy for me to reflash bricked vBios/card (i have bricked 7900gs few times :slight_smile:

If you can give me any hint what is responsible in vBios for matching mobo specifications, it would help me alot.

Have a nice day Fernando!

As I already have told you, I am not an expert regarding your problem. The code modification of a BIOS or vBios file should only be done by someone, who knows exactly what he/she is doing.
Why don’t you try to flash different vBios versions, which are available for your specific graphics card model, and then look, what happens?

Well i have tried, almost every verified vBios from techpowerup website, i have tried editing ids, clocks & card is stil not recognized by pci-e slot.
I have only noticed on some vBios’s that fan speed changed.
To be 100% sure i have also checked from bootable usb nvflash --list and no nvidia adapter found…
In my pc build from 2014, card is fully working w/ extra pcie power cable & w/o extra cable (checked in 9dx games as well).

I have also asked people who own/had this mobo and even higher models worked, but some not.

PCI-E slot is AsRock Agi Express Slot (Pci-e x4 w/ support for x16 cards).
In manual i have read that it supports geforce asus 6600 for example, so not a big difference in compare to 7900gs.

Idk, i can only blame pci-e slot, asrock somehow made this agi express slot to work with x16 cards, but latest bios is from 2005, card was released in 2006.

What is responsible for recognize card in pci-e slot? motherboard bios? pci module?
i could try bios from very smilliar mobo with the same chipset, but i don’t have bios programmator in case of failure.

So i’ll just buy new mobo for my mom, its only pc to play music, check something in chrome.

Thank you for your help/time Fernando. Great forum, alot of helpful threads.

You can close this thread if you wish :slight_smile:

Not sure if you solved this or not, but the PCI/AGP slots are controlled by the BIOS and chipset. There should be a setting in your bios options to change from integrated to AGP, or PCI for display/graphics. Try disabling the integrated graphics in the bios and then rebooting with the graphics card inseterted. Look for a setting that says

INIT DISPLAY FIRST or something that suggest a display or GPU or Graphics. Change the settings one by one with the card insterted and see if that fixes it. If not then you likely have a board that for some reason the PCI lane died. There should be no need to update a bios for a graphics card swap on a main form factor board. For laptops it’s a different story (which is why I’m here)

Let me know if you solve this please.