Modification of the bios motherboard Z390 GIGABYTE SLI pour un 6700K


I bought a motherboard Z390 GIGABYTE SLI, I modified in anticipation the bios to receive a Skylake 6700K.
I will also take a Céléron G4900 to be able to flash the bios of the motherboard hoping to then install my 6700K.
I would like to know if anyone has already tried this procedure and if so, does it work well?
For the modification of the bios Z390 I integrated the 6700K + the VGA bios and then the driver IntelGopDriver.efi.
Thank you for your feedback.

J’ai acheté une carte mère Z390 GIGABYTE SLI, j’ai modifié en prévision le bios pour recevoir un Skylake 6700K.
Je vais prendre aussi un Céléron G4900 pour pouvoir flashé le bios de la carte mère en espérant pouvoir installer ensuite mon 6700K.
J’aimerai savoir si quelqu’un a déjà tenté cette procédure et si oui est-ce que cela fonctionne bien ?
Pour la modification du bios Z390 j’ai intégré le 6700K + le VGA bios et ensuite le driver IntelGopDriver.efi.
Merci de vos retours.


I would love to do the same thing. My Z170 board’s memory channel died. Z390 boards are just as cheap new as used Zx70 boards. I would like to get a nice Z390 Aorus Pro and then upgrade to Coffee Lake as used i9/i7 prices come down into the used market. Has there been a reported case of Sky/Kabylake on Z3x0 board?

@Trinergy - I think so, you can, but lets ask the pro’s to be sure @svarmod @revlaay @_haru - Sky/Kaby CPU on Z3xx? Use one of the mod tools and be sure to keep ucodes for CPU’s in question correct?

It will not work. Z390 is a 14nm chipset, and therefore can’t run the version of ME required for 6th-7th gen.

The only reason Z370, H310C, and B365 work is because they still use the 22nm process and that can be downgraded to the right ME.

Thanks @_haru - I think you or maybe chinobino told me before, but since it’s not asked often I forgot

Is there any guide for enabling Skylake/Kabylake compatibility with 300-series boards?

It’s the same as for Coffee Lake on Z170/Z270 etc.

You need to add Skylake (506E3) or Kabylake (906E9) microcode to the BIOS.

You will also need to downgrade ME to 11.6.0.xxxx or or

If the board has a locked flash descriptor you will need to use a BIOS programmer or audio IC pinmod method to unlock the FD and flash the ME region.

I used the EVGA Z370 Classified K and an i3-6320 (Skylake) as an example;

[[File:HWinfo 6320 + Z370 + Speedshift Enabled.png|none|auto]]

6320 2133 15-15-15-32 2T @ 1.2V 28-29-24.png

Note that some Z370 boards can’t overclock the RAM (XMP not working).

There is a list of known boards that work on a chinese forum, I might have a look and post it here.

HWinfo 6320 + Z370 + Speedshift Enabled.png

Don’t forget that the ONLY 300-series chipsets that will take a Skylake/Kaby Lake CPU are Z370, H310C, or B365.

Yep, here is the list of Z370 boards tested by Zntx on baidu;

1. ASUS PRIME Z370-A (no XMP)


3. MSI Z370-A PRO (no XMP)

4. MSI Z370 GAMING M5 (no XMP)

5. MSI Z370 Gaming PLUS (no XMP)


7. Z370 AORUS GAMING 7 (XMP ok)

8. GIGABYTE Z370 HD3 (XMP not tested)

9. ASRock Z370 Taichi (XMP greater than 2666 = boot loop)

10. Colorful IGAME Z370 VULCAN (XMP not tested)

@chinobino - where does Q370 fit into this, I can’t find for sure if it’s 14nm or 22nm. So can it take older ME FW, or only v12? Thanks

@Lost_N_BIOS Good to see you back again!

Q370 is 14nm with ME v12.

Thanks @chinobino ! Yes, almost done catching up at home, and then I will be back into forums full speed again (After 90+ PM’s catch up )
Bad news for @simoutekd

* Edit - @chinobino - We have test system from user with Q370 (Dell 7460) with service mode jumper. When user puts on jumper, he gets ME Disabled message, and i3-6100 SKL CPU works fine, but for now only with dedicated GPU.
I plan to send him ME FW disabled BIOS, so he can test without jumper next. Does onboard GFX require ME FW functioning? Or, if above test works, go ahead update microcodes, vBIOS etc and test again with onboard?

moved to another post.

I tried running Coffee Time tool with the newest MSI z370I (ITX) bios, downgrade Intel ME and add Microcode for Skylake CPU (to test my G3900). Then I used SPI Flash Programmer, but no luck. Nothing seems to boot.
Any advise, or could you provide me some modified bios to test?