MSI P67-GD55 trouble (RAID and UEFI)

Hey Fernando/others, I’ve recently bought a set of 3 TB 7200.14 Barracuda’s with the intention of using them in RAID 0 and doing a clean UEFI install of Windows 7 x64. RAID and UEFI were a first for me and thus far it has been nothing less than a nightmare. The MSI RAID drivers didn’t work for example, so I ended up loading the 12.8 RST(e) drivers in Windows setup (after lots of searching). Still, things didn’t work, then I booted setup in UEFI mode this morning and things were partitioned fine.

Now for my present trouble. Windows freezes for a while during the logo screen, then boots blazingly fast (RAID does seem to work), only to freeze again when I’m running an installer, and ONLY when running an installer so far. I came across this forum earlier today and thought the EFI SataDriver might help (complementing the 12.8 RST(e) drivers). I opened my BIOS file, an entry was already there, I replaced it, flashed and rebooted. After some strange booting loops and reconfiguring RAID in uefi, things are exactly the same as they were before. I even see the CTRL-I RAID screen (although with pink flickers?), and I think I read that wasn’t supposed to be there anymore.

About the MSI BIOS: I can’t see an entry for Intel(R) Rapid Storage anywhere. Things are the same as they were. I also don’t have a CSM setting or Secure Boot setting, nor Option ROM Messages settings. MSI software has been terrible so far in supporting uefi and RAID but I hope I’ve missed something here. Where do these freezes come from? How do I enable the SataDriver? Any help is greatly appreciated!

@ Dropdisk:
Welcome at Win-RAID Forum and thanks for your report.

Regarding the freezes I cannot help you, because there are too many possible reasons for that.
If you have set the SATA Controller to "RAID" and chosen the boot device with the addendum "(UEFI)" while starting the OS installation, you should see the "Intel(R) Rapid Storage" tab within the Enhanced Mode BIOS section. Maybe you have to hit the right arrow navigation key several times.


Thanks for your reply! It seems the entry now IS there. Probably a result of me installing the 12.8 driver set through Windows (although the installer said it failed). My freezing problem persists though, so I’ll look for more solutions. Can keep this thread updated, because it’s an interesting problem at least. The first time I installed the OS on these disks, and found out I had not installed with UEFI, I didn’t have this problem. RAID did already work. So it’s the combination of RAID and UEFI and probably Windows that’s causing trouble here. Still, if you have any ideas, I’d love to hear them :wink:

Edit: Actually, the freezes are no freezes. It’s just that the HDD completely stops showing activity, until a few minutes pass and it just suddenly starts working again. I can move my mouse, but installations freeze and web pages won’t load. Some sort of queueing problem?

I’m still trying to fight this and was wondering, when the SataDriver module is active, should you see the Ctrl-I screen? Because I’m still seeing the Ctrl-I screen referring to something like Intel ROM 1.7, yet the module’s working fine.

Maybe this issue has been caused by your individual power option settings.
Run the "Power Options" > "Change Plan Settings" > "Change Advanced Power Settings" > "Hard Disk" > "Turn off Hard Disk after" > "Setting:" Never.

Enter the "BOOT" section of the BIOS and change the "Option ROM Messages" setting from "Force BIOS" to "Keep Current".
After having done that the CTRL+I pop-up should be gone and the boot time shortened.
By the way: The shown CTRL+I Intel RAID Utility version probably is 12.7 and not 1.7.

Just tested: the power options don’t change anything. HDD activity stops when there’s a lot of activity, or some kind of activity, and not when it’s idle. My last hope is a firmware update but Seagate made that very difficult with their latest drives.

Can’t seem to disable the Ctrl-I message in ClickBIOS, and yes, it’s 11.5. Updating the ROM wouldn’t have any effect, right?

Probably not.
With which mode (LEGACY or UEFI) are you currently running your OS? If it is UEFi, an Intel OROM change would not have an effect anyway.
Another thought: Have you ever tried to install Windows 8.1 (e.g. as Preview)? This OS definitively does support the UEFI mode far better than Windows 7.

I’m running it with UEFI. You mentioned before that it wouldn’t have any effect, but as the screen shows up, I thought it might be interfering in some way.

Installing Windows 8, I hadn’t really thought of that. If it supports UEFI better I’ll try it as soon as possible. Cheers!

Haha, installing Windows 8 solved all my problems. I didn’t even need to load a RAID driver any more during installation. Definitely a better OS so far, especially with the 8.1 update. Thanks for the help!

It’s fine, that you solved your problem this way.

Yes, loading of an F6 RAID driver is not needed, because Win8.1 has an on-board Intel RST(e) RAID driver v12.0.1.1028.
Nevertheless it is a good idea to update the Intel RAID driver to v12.8.6.1000 WHQL.