MSI X470 Gaming Pro MS-7B79 Ver:1.1 DMI, Sata, Lan, USB3.0 problem

I got an MSI X470 Gaming Pro Ms-7B79 ver1.1 motherboard and has weird problems as follow:
1/ I am able to boot to windows 10 with NVME but not SATA3 (failed to install fresh Windows 10 on SATA3, e.g. unable to format partition, hang on installation 0%)
2/ When I boot to Windows 10 on NVME drive, it works fine but couldn’t connect to LAN network. I can see LAN adapter, tried to set statistic IP but doesn’t work at all.
3/ Plug in usb/keyboard/mouses to USB3.0 will hang system
4/ I used tool AMIDEEFIx64 to update /SU auto and /BS to my Serial printed on the box but the same error. Is there anything else I need to update as well?
Do you think it’s a faulty board or just corrupted BIOS/ME or whatever you call it.

I tried my best of knowledge to explain it so please kindly let me know if there is anything I can try out. Thank you so much

Update1: Failed to install UBUNTU on SATA drive as well.
Update2: I think it’s hardware issue. Sent back to manufacturer for further diagnostics

Issues after or before u messed with AMI tools… or any other mods ur not telling us…
The LAN and USB issues humm…on a regular basis… we should point to HW issues on the mboard, but we know that sometimes users dont tell us everything, if u know what i mean…
How about a single sata drive (NO other SATA/M2 drives) , bios defaults and a clean OS install, how does it reates/performs?

EDIT: Did u already updated to latest bios (Depends on CPU)?

I bought this used motherboard and have been told that there was an issue with LAN network but it’s not the whole story I guess.
Single SATA drive doesn’t work as well, I tried 3 different drives and got same result. I just want to make sure it’s not BIOS/Software issue. Thanks for your reply!

UPDATE: Yes, I did upgrade to latest stable BIOS 7B79v1F