MSI Z87-GD65 "Unlock" hidden BIOS Options

Hey there :slight_smile:

I’ve been googling around and messed with a few things but none really worked out for me.
I made some pictures to make it a little bit clearer what I think what the issue is.
So first of all, this is what the main-window of my BIOS looks like.
http://i.imgur.com/cDstmqg.jpg
Which should be this in AMIBCP
http://i.imgur.com/hgctO0k.png
I’d like to get access to the red-arrow one: http://i.imgur.com/68MEn4c.png
Thing is, the green one is the one that is used here:
http://i.imgur.com/Js6A0iz.jpg
which as you can see, does not have the entries or the subfolder to begin with.
Changing permissions to “USER” does nothing.
The buttons on the first picture have no button for “Advanced” instead the one in “Settings” [in AMIBCP] is used.
I assume that I can’t do that with AMIBCP but I probably have to do it with a HEX-Editor?
If so, are there any guidelines?

Link for the BIOS in case anybody wants to take a look at it.
https://de.msi.com/Motherboard/support/Z…html#down-bios
Version 1.C

Thanks in advance :slight_smile:

BTW: “Unlocking” something in the “Overclocking” section does work. Changing the Access of Spread Spectrum for example does make it show up.

EDIT by Fernando: Unneeded blank lines removed (to save space and to improve the readability)

EDIT:
Just wanted to add the overview of the IFR Extractor of the Setup module.

1
2
3
4
5
6
7
8
9
10
11
12
 
0xE4B7A		Settings (0x6C)
0xEC3EC Overclocking (0x6E)
0xF52B9 Green Power (0x70)
0xF5448 Security (0x72)
0xF5CC5 M-Flash (0x74)
0xF5F6B Overclocking Profiles (0x76)
0xF68E4 Main (0x7)
0x109016 Advanced (0x1D)
0x1122E1 Chipset (0x1F)
0x11CCB2 Boot (0x21)
0x11D763 Security (0x3C)
0x11D976 Save & Exit (0x50)
 

Again the Advanced in the root-folder isn't even listed.

Hello my friend!
I want to Unlock the hidden BIOS Options and encountered the same problem as you,
Have you solved this problem?

@June_Da_Pek & @c0dy - I can unlock BIOS menus for you, same motherboard as this thread? If yes, what BIOS version?
Since MSI BIOS often a pain, and tricky or limited as to what you can easily compared to other Aptio BIOS, what is your main goal?

@Lost_N_BIOS Yes,is MSI Z87 GD65 Gaming.
The version is 1.C (last version of MSI official website) It’s really a pain = =
And I want to unlock the “TDP Lock”"Core Limit""Intel TXT(LT)",or if convenient can you help me to unlock all the hidden options ?
My CPU is i7 4960hq, Its voltage cannot be displayed correctly either in the BIOS or in the CPUz, can you help me to fix this problem ?
Can you teach me how to respond the MSI’s motherboard ?
Thank you !
----------

I don’t know how to use this forum = =

You are using forum just fine, but please use edit button if you want to add more info or more thoughts/questions, no need to make multiple replies in a row when no one else has replied yet

Please wait and I will look at that BIOS, find the settings you mention and then let you know what I can do.

Since that CPU is a "Mobile" CPU, it probably does not have correct microcode in the BIOS for this CPU, so that may be why the voltages are not displayed properly.
I checked and confirmed this, 40661 microcode is not there, so this probably reason for your CPU related issue (no microcodes being loaded). We can add it in there, hopefully that will fix it, if not you may need to get desktop CPU, or ignore this issue
Before I add any microcodes is your CPU retail or ES/QS sample?

Just click the "reply" button in the lower right corner? or use "@Lost_N_BIOS " ?

I used to have a colorful h87 motherboard, which can display the voltage normally by adding microcode and updating the ME.
In this MSI Z87 GD65 ,I have added microcode and update the ME to last version for 8-series chipset, CPU stepping can be displayed normally in BIOS, but voltage cannot display correctly.
My CPU is retail version.

Do you need me to send you the BIOS file that I failed to modify?

Reply is fine, I read all messages as time permits, so I’d always get back here eventually (it not after long time - days, send PM or bump)

How did your mod “Fail” aside from the microcodes and ME update not helping about the CPU voltage? Are you sure you did both of those things correctly? Did you fix FIT Table after you added microcode?
And, did the ME FW update when you flashed it in, you checked with HWINFO64 or something else to confirm ME FW version updated? Also, did you check with HWINFO64 to see current in-use microcode, to see if it was the one you inserted?
Voltage may not display properly in BIOS simply due to BIOS not coded for all CPU’s, and especially not for mobile, so might not be able to ever fix that.

I don’t need your file, it’s OK, I will make new one just to be sure all is OK.

Here, for now, please test, just microcode added (all updated) + ME FW cleaned/updated. Flash via M-Flash, this is stock modified BIOS, DO NOT Flash it via FPT or flash programmer
Load optimal defaults after BIOS update, then check and see about CPU voltages and ME FW version in HWINFO64 (in large window, expand motherboard, see ME area to find version)

uCode-MEFW-UPD.png



http://s000.tinyupload.com/index.php?fil…668067365561136

I’m sure that I did both two things correctly,and both your BIOS and my BIOS can display right ME version and CPU micorcode correctly.
BUT neither BIOS nor CPUz can display correct voltage = =
In HWINFO,I found CPU Status’ VID “MAY” get the real CPU voltage,The value in “Sensors” also confirms this finding.
By comparing the values in CPU z, AIDA64, and “Sensors”, I found the Core Voltage from CPUz and AIDA64 is the same as the Ring Voltage in “Sensors”.

Sorry, I can’t fix that, best to get a proper desktop CPU, or ignore this issue

OK,I will ignore this issue.
Maybe MSI uses different feedback definitions

Yes, may be best option if you can’t use proper desktop CPU. It may be possible to change that kind of thing, but I don’t know how any of that is detected or used etc.
Now, on unlocking BIOS, what exactly do you need done?

I just need high level options about “ TDP Lock” \“ Core Limit” \“ Intel TXT(LT)” from

@June_Da_Pek - Pick those from another menu, that is debug folder copy. Sounds like you want switched advanced menu, or 2x advanced menus, but I didn’t check if those three things you mention are in hidden advance (only assume they are)
Yes, I checked, and see all that same at hidden Advanced >> CPU Config.

Can you see “Overclocking” Section? If yes, I can replace “Memory Patch ID” submenu there, with hidden advanced, I’ve done this same mod for user here if you want to see example images
Original work/request thread - msi z97 pcmate unlocking advanced and chipset menu (2)
And, final repost of tested final BIOS in it’s own thread - MSI-Z97M-G43 Advanced Menu Mod + uCode Upd

Yes!!! All I need is the Full, originally hidden, Advanced Menu !!!
I can see the "Overclocking" section from "OC" part.

PS: Intel TXT is also what I need, but I forget where it is…

All three items you specifically named are at the (hidden) Advanced >> CPU Config section, including Intel TXT. OK, I will make you mod BIOS, replacing >> OC >> Memory PatchID Submenu >> To be >> OC >> (hidden) Advanced submenu
There is an image example at links above of how that works/looks, different images at both links. It will be at top of OC section in place of currently Memory PatchID (which may be hidden from you right now too, not sure)
Please wait, it’s a little bit involved, so may take me a day or two, but I’ll get it done for you and method is already figured out by me, proven and tested working on my end before I gave to other user in thread above (So it’s 100% sure thing I can do for you )

* Edit - @June_Da_Pek - Here is 5 hours of work + Previous I think I’ve got it sorted for you, but can’t test on my end I only have MSI Z97.
I tried, but no display, same for this stock BIOS too, but I guess I should have expected Z87 BIOS wouldn’t load on Z97 Always testing
Mod done same as the other, nothing unexpected during edits, all lined up with previous editing examples/notes I wrote down during that edit. Let me know how it goes
Flash via M-Flash, don’t rename the file

OC-ADV-Mod.png


http://s000.tinyupload.com/index.php?fil…115449172946719

Thank you!!! I am downloading.
I want to know what the role of memory patchID is?

@June_Da_Pek - You’re welcome! I’ve been waiting long time for you to reply, I assumed you’d get my tag notification right when I posted and be here in a hurry to test, many hours ago
You can see what Memory PatchID is in AMIBCP, at the stock BIOS, in location shown in that image. It just shows memory stick info, it was hidden from you originally, so you don’t need/use it anyway
It shows part number, memory patch checksum Manufacturer ID etc - if/when all that is programmed into the SPD/XMP, if not then it probably shows nothing

Thank you !!! It worked!!!
I just flash it what you mod for me,and saw "Advance" from OC space, you are so GREAT!!!
but… the TXT option is greay,is inoperable… and TDP problem still not solved…

@June_Da_Pek - Great, thank you for report back! And you’re welcome!
Please show me image of what all is grayed out or missing for you, and I can fix. Sorry something is grayed, I can’t see/test on my end, so could not tell what is missing after this, or gray etc, until I see image.
Don’t worry, we can make not-gray!

What about TDP, it’s locked still too, or gray?

The TXT option like this
The tdp is settable either in or ,even in aida64 is ,but when I run FritzChessBenchmark, the real-time power consumption of aida64 is , I confirm that this power consumption is wrong.