NB Asus X540SA - TXE driver trouble (code 10)!?

Hi, I have a trouble with notebook ASUS X540SA - try to update BIOS v.207 with the latest v.300 (EZFlash) and it freeze when erasing, after force power off notebook dont power on. <br /><br />Ill find the SPI dump for the MB rev.2.0 (my NB have MB rev. 2.1) and flash it with programmer, notebook started and have BIOS v.204, after that I successfully update it with latest BIOS (v.300).

Now I cant install TXE driver (before flash SPI its work), get the error - This device cannot start. (Code 10) STATUS_DEVICE_POWER_FAILURE. Why is it and what can I do for recovery TXE!?

@TechnicsKuzya :
Welcome at Win-RAID Forum!

The problem can be driver related (look >here<) or BIOS related. If it should be the latter, I recommend to contact the ASUS Support.

Regards
Dieter (alias Fernando)

EDIT: If the link shouldn’t work, go >here< > Notebooks > Hardware and search for “Intel Trusted Execution Engine”

100% it`s not driver trouble, may be I can do correction of BIOS dump (unlock flash descriptor) and reflash, than flash updated (or same) TXE region?

What makes you so sure? Have you already tested all options, which were recommended within the linked discussion?

If you can use the programmer or have an unlocked Flash Descriptor (no error at fptw -d spi.bin command), we can reflash the TXE region with another which is clean/configured/updated, just in case the dump contained system specific dirt at TXE’s DATA firmware section. Do you have your own chip’s dump while at 2.1, so before flashing 2.0? If yes attach it, otherwise attach the 2.0 version to create a new TXE region based on those settings, assuming that ASUS didn’t change anything from revision 2.0-2.1 which is TXE firmware related.

No, I dont have full chip dump for MB v.2.1. Attached dump for 2.0 (TXE version same for 2.0 and 2.1). <br /><br />For Unlock Flash Descriptor I only need change &quot;00 00 <b>0B 0A</b> 00 00 <b>0D 0C</b> 18 01 <b>08 08</b>&quot; to &quot;00 00<b> FF FF</b> 00 00 <b>FF FF</b> 18 01 <b>FF FF</b>&quot; in the chip dump? Or checksum need correction too?<br /><br /><br />P. S. How I can change MB SN and MAC in this dump? Im find MB SN|MAC in the dump - can I simple change it in HEX-editor? Real MAC in Windows - correct (as NB BOX), in the BIOS - 2C56DC7D4AA8.

x540sa_dump.zip (3.72 MB)

Do some modification to SPI dump: change SN, PN, MAC with Hex editor, than Unlock Flash Descriptor and replace to clear TXE region.bin by Intel utility - now flash chip with programmer - TXE - Worked! SN - changed, MAC - not changed (why)!? BIOS Unlocked - can do full dump from Windows.

P.S. Now update BIOS from 204 to 300 by EZFlash - TXE worked.

So the TXE indeed needed a reflash because of leftover junk at the DATA section from the dump you found online. If I understand properly, you followed that guide to create a clean/configured/updated TXE region for your system, correct?

The SN and MAC are found at the BIOS and are OEM specific as far as location is concerned so I can’t help there. If you know their values, you should be able to find where they are by using UEFITool and string/hex searching.

plutomaniac, yes, I followed that guide for clean DATA section. Thank you!

PN, SN and MAC I`m find in the dump, change it by HEX editor, after flash check it in the BIOS and PN, SN - all OK (changed), MAC - not changed…

P.S. Attach my mod BIN and dumps after flash it.

X540SA_DUMP_300.zip (3.54 MB)

X540SA_DUMP_204.zip (3.53 MB)

X540SA_BIN_204_UNLOCK_clearTXE.zip (3.49 MB)

I can verify that you followed the guide correctly and that settings between 300,204 and Clean TXE regions are correct.

OK.