Need advice with Gigabyte Aorus 15p XD Bios Unlock

if there is no difference in GEN1 and GEN2 ,.must first enable downgrade option “if still exist”
bios/advanced/bios downgrade - enabled

but I think GEN1 / GEN2 - mobo is different “not bios version mark”
or variations for UEFI “win10 /win11” - FE02 probarly “win11” ,…afuwin works under “win10” - FB07 ?

try contact manufacture for correct info :smiley:
,.,.or try RU.EFI for unlock “manually” or not unlock “no need unlock” and try recommended offsets above for repair OC “undervolt”

edit"what i mean"
open your update “for FE02 or FB07” it doesn’t matter

  • ,.,.and open TASK MANAGER - SMART FLASH - open file location*
    *and here is problem GEN1/GEN2 folder “contains both files” *

that’s why I think it’s more about HW selection than bios version mark.

It would make sense if the install program had both bios and checked for the latest. I did try to download the FB06 installer and ran that, it didn’t even try to update the bios, just pretended like it was going to try then restarted the PC. I can also give FB01 a try, but it’s the oldest so I’m not sure if it’s risky to go back that far for the downgrade

Hi, i have the same laptop with same specs and i am facing identical problems and errors as @kev1 . My bios version is also FE02 and as others have said reflashing bios doesn’t work. Tried to downgrade bios to any version possible even FB01 but no success. Is there any option to unlock that annoying FE02 bios?
Or I’m wasting my time.
Asking for any advice or help !!! Thanks!

:sweat_smile: ,.,try RU.EFI + unlock
or on locked state - try only enable OC “offsets is above”

edit “RU.EFI example”
example

Alright.
Did you disable secure boot in the bios before using a grub shell?

  1. Go to Bios → Security → Delete all Secure Boot variables or try to toggle Enroll all Factory Default keys/Delete all Secure Boot variables.
  2. Boot the usb pen drive as uefi mode(you can make a bootable usb drive by rufus or just try to create needed folders with a grub shell file) at the root it looks like…yourdiskletter:\EFI\BOOT\bootx64.efi(rename your grub shell file to bootx64.efi)
  3. So, reboot your laptop and press F2 to enter bios, you need to enter/choose your usb drive.
  4. In the grub shell type commands(without quotes):
    “setup_var PchSetup 0x1C 0x0” and press Enter, you’ll receive a msg with changes… Then type a second command “reboot” and press Enter again.
  5. After that you can try to flash your bios mod via FPTW tool: fptw64.exe -f biosmod.bin -bios
    6. Check hidden menus in your bios and let me know about it(take a bios shot).

If you get an error 167 - your bios is still locked. However, we can try to change locked variables via RU.
Do the same steps. Make a bootable disk via rufus, but this time rename RU.efi to bootx64.efi.
…ignore step 4, do it yourself. Change variables(PchSetup) 0x1C 01 to 00, then check next address 0x683 → 00 means that’s ok.
https://winraid.level1techs.com/uploads/default/original/3X/5/d/5deed7ee21ed81820ac5ea6361ac913c3c19d205.png
https://winraid.level1techs.com/uploads/default/original/3X/a/3/a3cbdf5e3d9d887f487bb72ec8b8ac5c82fdf57c.png

*In your case after step 4 make a new bios dump and try to flash it for a test. If it is successful, I will do a bios mod for you.
@Trelow Where did you buy the laptop? What is your OS? Did you try to unlock your bios via grub/RU?

@Zentsi
Thank you for this write up, very helpful. I followed your steps and realized a lot of this was done though the nifty script I had downloaded from the start, but I went through manually this time. So I tried again to install update the bios and unfortunately ran across the error 176 again. So I downloaded RU.efi and set it up in a boot drive. Went in and checked in PchSetup and found 0x1C, but it looks to me that it’s already set to 00. Here is my screen shot:

I couldn’t find 0x683 to check if it says 00, I messed around for a bit to try to find it but couldn’t figure out how. But finding 0x1C already being set to 00 makes me wonder if there is something else I’m missing. Now that I’m in RU.efi, I could make changes elsewhere.

It is very odd.
This string was taken from your IFR file - " Flash Protection Range Registers (FPRR), VarStoreInfo (VarOffset/VarName): 0x683". We do not have another FPRR hex-address.
You still have the same error because something block FPRR…even you unlock “Bios lock” hex-address(0x1C) 01 → 00. FE02 is a fresh version, nobody knows all details.

edit
repair “different FE02 - FB07”
try google !
RaceConditionResponse Policy - this is new FE02 “but setup look good” try verify offset in RU.EFI

RaceConditionResponse Policy | VarStore: CpuSetup, VarOffset: 0x249, Size: 0x1
      Disabled: 0x0 (default)
      Enabled: 0x1

// old

BIOS Guard ??
Enable Tools Interface | VarStore: CpuSetup, VarOffset: 0xE1, Size: 0x1
Disabled: 0x0
Enabled: 0x1 (default)

or this for compare
Downloads.rar (82.9 KB)

edit: windows compatibility
if you using Win11 ? try FPT in EFI / no secure boot ,.,.or win10 or latest system tools for you chipset :slight_smile:

:thinking:
FTP -f -BIOS that won’t work here !
check bios structure FB07 vs FE02

or you must try disable bios guard or all new protections - and try new DUMP file
and must looks identical like old FB07 or is risky flash this file / or is incompatible !!

it can be about encryption / new look of UEFI bios,.,.etc
,.but extreme risky for MOD ! “like old FB07 - looks like million others AMI bios-es ,.,.OK”

edit
or find more info about new flash-tool “from FE02” AMI BIOS Guard Firmware Update Tool

It has been a while, but I got bored and started trying to unlock this bios again and ended up finding a solution. I followed this video exactly and I am now able to unlock voltages in Throttlestop and change every value: Unlock undervolting in any laptop with a 10th or 11th gen Intel cpu!! | Locked BIOS no problem! - YouTube

I’m still playing around with the numbers and running tests, so no results quite yet but I’m already seeing temp drops with higher clocks. Hopefully this will help anyone who is looking to do some undervolting on this laptop.