[Need Help] Another bricked motherboard? ASUS Z87-A


Tried to add NVMe support to my old ASUS Z87-A with a 4770K processor.
Followed the guide and flashed the bios with ASUS EZ FLASH by exchanging the original file with the modified Bios CAP file.
I didnt see that the flash finished. I started the flash and then went away and when I came back the the EZ Flash program was closed. The computer seemed to work good so i rebooted.
After reboot I have a black screen and it doesnt boot or POST. First the mouse and keyboard worked but now it seems like they are dead to. When I opened the chassie I see that the CPU_LED are red.

Reset Bios settings.
Remove Bios Battery both for 5 min and 24H. (at the same time I was reseting the settings).
Replacing Bios Battery.
ASUS Crashfree BIOS utility (but since I cant see anything I cant do anything).
Removed all nonessential hardware.

Is there any other suggestions of things to try before I start saving for a new MB, Processor and RAM?

Best Regards!!

Went away… thats nice!!! EZ Flash on Windows OS or EZ FLASH2 bios utility?
Witch guide did u follow to flash the mod file?
So no access to bios/post? Then its time for buying a CH341A spi programmer…

Besides this… have u tried recovery procedures stated in chapter 2 of the manual, DVD or USB only with the Z87A.CAP file?
There were some Asus 8 Series motherboards without Asus BFB button, that responds to a 3/5secs reset switch pressing, in stand-by power, in order to do a similar action like Asus USB Bios Flash Back.

EDIT: Usually doesn’t matter DVI-VGA as long as the processor has iGPU built in. Now the CPU led it could be pins on socket or the lack of bios load due to mcode/post.

EDIT: Then im afraid ur only option by this point is only re-programming the SPI again. The CH341A is cheap.

Yeah it worked for a while. But a few reboots, memory clearings later it died and doesn’t light up anymore.

Used this guide Guide-How-to-flash-a-modded-AMI-UEFI-BIOS where I choose the AI suite option. (Can’t link it)

And yes I tried the instructions in the manual but it doesn’t state any specific USB port so I have tried a few… maybe it goes into some flash mode but since I can’t see anything on the screen I don’t know. Maybe I should fiddle with this some more. But I’m kind of bothered with the cpu led. If I remember right I had to upgrade the bios when I bought the MB to get it to accept the Haskell CPU. Does it matter if I connect the monitor to the MB with DVI or VGA? Don’t have a old VGA cable at home right now.

Ty for the suggestions!

Now that I tried with another USB stick that has an activity LED I see that it doesnt lightup when I connect it (in any port). Just like my USB KBD and mouse.

Did you mod yourself or did you use a bios already modded? Please opst/ attach the bios you flashed.

Myself… So I have noone else to blame.

Z87A.zip (5.22 MB)

Well, the mod itself looks OK at a quick glance, but you got the capsule in the beginning copied back twice, so that will possibly give a brick.

Buy a programmer, dump your firmware if you’re interested in serial.

Hmm ok thanks for looking. So I misunderstood this step?

Only for ASUS BIOSes, whose capsule had been removed by extracting the “Body”, but shall be flashed by using the ASUS USB Flashback feature:
Don’t forget to re-insert the original capsule and to save the modded BIOS as *.CAP file according to >this< guide written by Lost_N_BIOS.
I shouldn’t have used the hex editor to paste the code at offset 800?

Now you are starting to convince me to buy a programmer and try again.

But what model to buy?

Would this one be ok?


Also reading up a bit I realize that I don’t know witch chip that I need to program.

It couldn’t be that easy that it is the one in the socket on the second photo?

8 pin.jpg


That programmer will do or Any "Black" version of it.
Thats the correct SOIC8 SPI chip (Winbond 25Q64FV), its socked so its an easier task to program as it comes off and can be directly inserted in the programmer.

Ohh that’s nice. No clamp or soldering needed.

That settled it. I’m ordering a programmer.

If you remove the capsule you’ll have to re-insert it again, if you did work on a file wirh capsule you don’t.


Size difference and loss of / change in structure are never good signs.

So if I just had renamed this first .rom file to .cap it probably would have worked?

Im attaching that file (if you have the time to take a look) since I might use it with the programmer when it arrives.

Z87-A-NVME.zip (5.22 MB)

Yes, possibly you did the mod with UEFITool, so you still had a file with capsule. But for flashing with a CH341 you’ll have to cut the first 0x800, file should start with

5A A5 F0 0F 03 00 04 02 06 02 10 15 20 01 21 00

and have exactly 8.388.608 bytes.


The motherboard is up an and running again!!

With NVMe boot support. (and USB)

SO happy couldnt have done it without your support!!

Thats so nice of you, congrats… indeed we r all a bunch of useless helpers here, oh well we’ll keep on trying to be better.