[Need Help] Corrupted WINBOND 25Q128FW BIOS

my hp all in one get a corrupted bios ill attached bios and please somebody can help me
thanks in advance

Edit by Fernando: Thread title specified and customized

WINBOND 25Q128FWSF - Copy.rar (5.88 MB)

Yes, looks like corrupted volume hidden in padding. Well, volume was written properly but not ‘activated’, error is in padding

EDIT Congratulatoins, you seem to be an new offer of Windows Update offering and applying firmware updates. Even if HP just states they’re on F25 (can’t find anything newer on their pages) Microsoft is already on F33

https://www.catalog.update.microsoft.com…aspx?q=hp+15.33 sort newest up, the first item is F33 for your SSID


4F1C52D3-D824-4D2A-A2F0-EC40C23C5916 would get updated first, that worked out, but then the update stopped in the padding between volume 4F1C52D3-D824-4D2A-A2F0-EC40C23C5916 and first 61C0F511-A691-4F54-974F-B9A42172CE53 volume, thus bricking the bios:



Fix would be easy, just replace all from 0x70000 to 0x7BC000 with the corresponding part of the original/ same old version stock bios, flash back with programmer. If the filename is the type spi chip you’d need a 1.8V adapter (no further information about tools, models, versions … given)

Thanks for take your time and explain me the best way u can do, ill do everything u tell me but got an error and file not working,
get a message the data you are trying to program is bigger than the chip size. thanks in advance

bios prog.jpg

Post/attach the file you tried to flash.


WINBOND 25Q128FWSF.rar (5.88 MB)

Try the attached file. (removed)

thanks for your help, got the same msg but anyway let me write and the computer stays on black screen its a non working file

If this file gives you the size warning again you got the wrong file or another error. The attached file is exactly 16MB = size of an 25Q128FW.

Please read the chip again and post/ attach the content of the chip after last flash.