Need help flashing previous BIOS version on OMEN by HP 15-dh0007na

Hey guys, my laptop’s bios got updated yesterday (f40->f45, plundervolt vulnerability = I can no longer undervolt) and I can’t seem to be able to downgrade it to the previous version. The win+b recovery just recovers the same, post update version, and the usb recovery with the previous version gives me the Unable to open BIOS Signature file error. In most places on the internet they say it’s impossible to downgrade bios on hp notebooks, but some people here were successful - could you help me please? This is driving me absolutely nuts. Thank you very much in advance.

Stuff I tried but only got some more emotional damage:
-recovering cmos and bios with either f2 menu or win+b - nothing new, recovers the latest, updated version
-disabling sgx completely in bios - os (win10) still asks me to disable sgx apps (I have none) for whatever reason if I want to use undervolting
-hp_tools - recovery usb gave me a bunch of .bin and .sig files - can’t flash them, either missing signature file or tells me the version I’m trying to flash is older than the current one
-insydeh20 - doesn’t recognize those files
-universal bios backup toolkit - said it couldn’t identify the bios
-contacted hp support - rollback should be possible - it isn’t, the firmware management tool (when you boot from f2) says correctly that the current version is f45 and after the process it’s going to be f40, but then just doesn’t work, saying something about not finding signature file
-tried cinebench20 without my undervolt settings since I’m stuck with that, and got even more emotional damage as I lost 700 points on my cpu (3200 to 2500) : )

Same issue here but with an Omen HP 15-dh0005la. Temperatures drastically increased making the laptop almost useless.

Yep exactly that, I think I am going to try to send mine back under warranty, that update absolutely broke my laptop’s performance, not to mention the noise levels. I don’t know what they were thinking not letting any1 downgrade a bios at least to the previous version, something that should be easy to do has been driving me absolutely mad for a week now.

bump