Need help getting KVM on ECS Q470H6-M6 to work


Got a nice Q470H6-M6 with i5-10400, enabled and configured AMT with no issues.
Can connect to 16991, do all the stuff except KVM… Spent some days trying and then realized that CPU has no vPro support :slight_smile:
Got i5-10500 but still same issues…

Dumped bios with fwpt64, took it through FIT and MEAnalyzer - seems that KVM is enabled (see attached screenshots)
Dump is here on mediafire/file/dwaqfawlqktanse/ecs.bin/file (can’t paste links as noob).

Please enlighten me on possible cause



configured how? methods? commands?
have you tried completely updating Me firmware,and while at it also driver?
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

Configure was straight forward - ME enabled in bios, then Ctrl+P and enabling there all I could + network settings.
In ME setup I saw only SOL/Storage redirection features, no KVM was mentioned there.

ME firmware could be updated separately? Wasn’t aware, please show me the direction!
Is it “How to use FWUpdate Tool at CSME v13+:” section from the link you gave?

I could not find any bios file in support.therefore i am not sure,if kvm is a part of bios or even ME.
Use meanalyzer with your bios dump to find out the required tool and files.looks like v14,so CSME Corporate H A and system tools v14.also MEI Drivers and Software v2107.15.0.2173

Now I can post external links… bios dump is here

Went through the steps and collected FW parts, stuck on this:
Input “FWUpdate.bin” file into ME Analyzer tool and make sure that “FWUpdate Support” is reported as “Yes”. - for me it says “No”.

BTW, I’ve run MEInfo tool and got this:
Intel(R) Active Management Technology
Intel(R) AMT State Disabled
IPv6 Enablement Disabled
Configuration State Completed
Provisioning Mode PKI

AMT Global State Enabled
Trusted Device Setup Supported Disabled
Intel(R) Standard Manageability State Enabled

Post complete output of “MEInfo -verbose” (in a spoiler or as attached file), post a screenshot of CPUZ- cpu- tab, try to connect to PC with Mesh Commander and post the tab ‘system status’


Your SPI dump indicates that all AMT/MEBx related options are enabled in the CSME firmware via Flash Image Tool (FIT). Try a global (CPU + CSE + PMC) reset first by running Flash Programming Tool with parameter “fptw64 -greset”. Alternatively, power down the system, remove all power for 1 minute (AC/Battery, not RTC), try to power it on a few times and re-connect power. Check MEBx for any new options, re-configure it and check if the problem is solved. If not, you will have to follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on your SPI dump and flash the output back via whatever method you used to dump it originally (i.e. fptw64 -f spi_fix.bin) followed by another global reset.

GRESET Magic worked!!! Many thanks plutomaniac!
So my mistake was that I haven’t done this right after replacing i5-10400 with 10500.

Thanks for the help!

Now remains to get "Headless display emulation" somehow…

Good. At Corporate systems, a simple shutdown does not reset the CSE, only the CPU. In your case, the CSE had not realized the CPU change so you needed to perform a global reset either manually or via FPT.

As for the headless display option you mentioned, I do not know.

Will try to fool graphic controller with a dummy vga plug :slight_smile: