Need help installing XP on a Coffee Lake system

Hi there!

I’ve been lurking for a few days on the forums trying to install Windows XP SP3 on a MSI H370M Bazooka with a Coffee Lake processor (i5-8600k). I have tried to integrate the modded ACHI drivers on XP but I haven’t got much luck on it. I either get a BSOD ending with 0x000000A5 or 0x000007B, but the past few days its been giving me the 7B Blue Screen.

The ones I’ve tried were the AHCIs from the retrosystemsrevival website (gave me A5’s) and the Movax-Gen2 driver that was in the XP Integral Edition (gave me 7B).

So which ACHI driver (if any) could help me point to the right direction to install XP?

Sata mode is set to AHCI but it also has a option for RAID.


I use the Optional Patch Integrator that comes with XP Integral Edition.

found here

I already tried that (I should’ve mentioned I tried using that in the first post)

On the Optional Patch Integrator I tried the following

Options 1,3,4,A,B,C,E (BSOD at 7B)
Options 4,6,7,C,H (Also BSOD at 7B)


If you are using a USB drive to install XP you might be getting a 7B BSOD if the backported USB3 driver isn’t working.

you can check if this is the case by loading the XP ISO into RAM to see if the 7B BSOD goes away.
I use Easy2boot + WinVBlk to do this.


Or burn a CD with this XP and use a CDRom drive, which is connected through Sata (USB may give 0x7B)


Using Easy2Boot + WinVBlk I was able to get XP installed and working, though, it doesn’t shutdown fully, it just hangs at “Windows is shutting down”, but none of the USB ports are working.

I used the XP Integral Edition.iso with Options 1,4,6,7,C,E,N


try disabling and re-enabling the USB3 controller in device manager and see if that gets USB working.

Sorry for the late reply, been busy with other stuff.

I tried that but I get a code 10 error.

On the other hand, I did get sound working…somehow with USB Speakers. And the network works…ish. Just stuck at limited or no connectivity, none of the webpages load.


No idea why the USB speakers work.
Regarding you network try setting your IP/DNS/Gateway statically and see if that works.

The limited connection warning goes away after a reset, so I’m fine with that for the time being.

On the other hand. USB ports still ain’t working.

The port that has the USB Speakers plugged in? Works for that only. If I plug USB Drive on that port, nothing happens.

I’ve tried about a few USB3 Drivers for XP and either

A. Won’t install because it’s not made for the system (even though the driver is made for it.)


B. Installs, but gives me a Code 10. Disable and reenabling it does nothing. Uninstalling and reinstalling the drivers also does nothing.